Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
88 user(s) are online (54 user(s) are browsing Forums)

Members: 0
Guests: 88

more...

Support us!

Headlines

 
  Register To Post  

« 1 ... 4 5 6 (7)
Re: Qemu Pegasos II interrupts issue
Quite a regular
Quite a regular


See User information
@geennaam

Quote:

The system is transformed back to a windows PC. And I am not at home right now. So I will not be able to test. Maybe next week. Unless I am banned from this site just like from Discord #amigans .

I haven't been following the discussion. What is wrong with sdl1? Something 16bit screenmode related?

The passtrough system is using 32bit screenmodes and aeon radeonhd drivers.


Why should they be blocked? When it comes to the driver's story I want to stay out of it, that just means it's their driver, they developed him and others need to respect how and where and with what conditions he is available.

Regarding the Qemu problem:

With the Pegasos2 machine there are currently problems operating SDL1 ports and only on this machine. AmigaOneXe/Sam460 can handle SDL1 applications without any problems, we don't yet know why this is and are trying to solve the problem.

The combination of Qemu Pegasos2/SM502 as a graphics card does not seem to be the problem, as this card works with the AmigaOneXe machine and SDL1.

So I ask you to do one last test before you rebuild your system. You can use the link I provided above that Capehill has provided especially for this purpose. Or you can test a few applications from Os4Depot, for example. MegaMario/SpaceInvaders and E-Uae.

You should test it with 16/32 bit output.And to share this result here, we suspect that it could be something in the kernel/graphic.library.kmod or PCIGraphics.card (Pegasos2) Balaton has described several times that a Qemu error has been ruled out, since AmigaOneXe/Pegasos2 are on identical machines code based.

This could prove that there really could be a kernel or kickstart library problem from AmigaOs4.1 for Pegasos2.

MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: Qemu Pegasos II interrupts issue
Not too shy to talk
Not too shy to talk


See User information
@geennaam

Quote:

The system is transformed back to a windows PC. And I am not at home right now. So I will not be able to test. Maybe next week. Unless I am banned from this site just like from Discord #amigans


I have no idea, but for me the topic has been moved and locked.
I have no problem with that. Your programme code, you have clearly stated what is important to you and licensing.
As they say ... ‘What happens in Vegas, stays in Vegas’

If you are willing and still enjoy using AmigaO4 and helping other users (even QEMU) that would be cool.

Greetings

Go to top
Re: Qemu Pegasos II interrupts issue
Quite a regular
Quite a regular


See User information
@Maijestro
I think somebody tested that before with real machine and ATI card with 16 bit mode (it's probably somewhere in the long QEMU pegasos2 thread, I think it was when we tested it with a Mario like game) and it did not reproduce the problem. I think somebody said back then that ATI cards support big endian 16bit mode but SM502 doesn't or something like that and it seems that some function used by graphics library does not take that into account on pegasos2. With the test from Capehill it's now also proven that it's not related to SDL code but it's something in AmigaOS. So we likely won't get more info from trying with real graphics card (unless somebody can try on real pegasos2 with a real SM501/502 card but those are probably rare so likely nobody has such card). The ATI cards were working even in 16 bit in previous tests so it should be the same result with a passed through card.

Go to top

  Register To Post
« 1 ... 4 5 6 (7)

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project