Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
65 user(s) are online (52 user(s) are browsing Forums)

Members: 1
Guests: 64

billyfish, more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 3 4 (5) 6 7 8 ... 19 »


Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
Just a bump for reminder, someone just reported me a "problem" in SMTube.

It was just because his libQtCore was too old.

Thank you ;)

"When using SMTube (or others Qt programs) take care to have the latest libQtCore.

If your Qt:lib/libQtCore.so is from 2013, it's an old one, take this one :

http://sourceforge.net/projects/qtami ... bQtCore.so.4.7.0/download

"

   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
SMTube 14.8 svn 6558 on OS4Depot

When a video was not found, only on AmigaOS4, you could encounter a CPU loop and/or a non display of the error window.

Now, it's fixed, by replacing the original Qt MessageBox by a standard Qt Window.

Thanks to Ricardo to have merged the AmigaOS modifications in his repository and to Kicko and Samo79 for the bug report.

http://os4depot.net/index.php?functio ... ile=video/play/smtube.lha

   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
how to setup Qt and SMTube


SMTube is a standalone software, no need to have Odyssey to use it.
SMTube is a video viewer, therefore it doesn't use ffmpeg but MPlayer.


1) download the most recent Qt libs in the qt4.7-0.9.1-minimal.tar.gz package here :

http://sourceforge.net/projects/qtamigaosnative/files/beta/

and copy the libs/* and new Prefs/Qt program

2) DON'T FORGET to download the latest Qt libQtCore from Alfkill and to install it in your Qt:Lib drawer

http://sourceforge.net/projects/qtami ... bQtCore.so.4.7.0/download

3) go in Prefs/Qt and check "Native Paint Engine" in Painting tab to avoid to use OpenGL.
All others options are unchecked (at least on my system).
you can too, put the 2 first characters of your Locale in the "default language". "fr" for French for me

4) Read the SMTube ReadMe of course to customize the Amiga/PlayVideo.rexx

if you have a x1000/SAM460 without overlay, the Liveforit MPlayer (or MickJT SDL one) is the best MPlayer version.




5) go to os4depot and download Liveforit-Mplayer

6) put mplayer-altivec where you want and double-click once on it (to populate the APPDIR:mplayer-altivec)

7) in PlayVideo.rexx :

-change MPLAYER = "APPDIR:MPlayer" to MPLAYER = "APPDIR:MPlayer-altivec"

-uncomment the first MPLAYER_OPTIONS
"MPLAYER_OPTIONS = "-cache 8192 -cache-min 20 -autoq 100 -autosync 30"

8) now you can start SMTube

9) hit the little screwdiver button at bottom of SMTube

-configure the quality of recording videos (720p MP4 for example) and Streaming Videos (480p webm)


Now you should be able to double-click on videos.

Update ;
If a video doesn't play you can try to force SMTube to update his YouTube script.

-delete Qt:home/.config/smtube/yt.js
-retry to watch the failing video.
-an updated SMTube YouTube code is downloaded.
-retry and enjoy !





Edited by zzd10h on 2015/1/18 0:45:04
Edited by zzd10h on 2015/1/18 0:56:44
   Report Go to top

Re: SMTube : new version on OS4Depot
Just popping in
Joined:
2006/12/18 1:32
From Hawaii
Posts: 221
@zzd10h

I was happy to get this advice. At first. Then I installed MPlayer-Altivec, which works very nicely when I click on it and provide a video file from disk as argument.

Then I undertook step 7), which seems easy enough. Only now I can no longer play any of the videos that get listed when I click on smtube! I guess I must have done something wrong, but I can't imagine what.

Here is the way the modifiable portion of my PlayVideo.rexx looks now (blank lines deleted):

/* REXX */
parse arg type url
/* UPDATE THESE PARAMETERS IF NEEDED */
/* TAKE CARE TO SPECIFY THE PATH OF MUI-MPlayer OR SDL MPlayer SVN-r32561 TO ALLOW STREAMING IN OPTION MPLAYER = "" */
/* Others players or, even, other versions of MPlayer are NOT supported */
MPLAYER_OPTIONS = ""
DEBUG = ON
WAIT = OFF
SECONDS = 3
MPLAYER = "APPDIR:MPlayer-altivec"
MPLAYER_CONSOLE = "0/400/640/400"
/*MPLAYER_CONSOLE = "1450/975/465/99" */ /* console in lower right corner ONLY for 1920x1080 screen */
/*MPLAYER_CONSOLE = "9999/9999/400/100" */ /* console in lower right corner ONLY for 1920x1080 screen */
/* END OF UPDATABLES PARAMETERS */
/* examples */
/* MPLAYER = "APPDIR:MPlayer_SDL_1.1_Altivec_cache" */
/* optimisations from K-L (compatible with MUI-MPlayer Overlay and SDL-MPlayer) */
MPLAYER_OPTIONS = "-cache 8192 -cache-min 20 -autoq 100 -autosync 30"
/* optimisations from K-L (compatible with MUI-MPlayer NON-Overlay) */
/*MPLAYER_OPTIONS = "-vo cgx_wpa -cache-min 20 -autoq 100 -autosync 30" */
APPDIR:ffmpeg -i "input.m4a" -b:a 128k "output.MP3"

Clicking the settings screwdriver brings up Recording, Playback, and Standard Feeds. No mention of Streaming there.

If I click on something in the Music column, by the way, I get an invitation to "update the Youtube code."

I guess I'll try to set the thing back the way it was so I can play Youtube videos again. Or can you see what I did wrong?

   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
@kilaueabart

You are near of the goal.

1) remove the line APPDIR:ffmpeg -i "input.m4a" -b:a 128k "output.MP3"
or redownload smtube package to zhave a clean playvideo.rexx.

In the readme, i mentioned ffmpeg only if you need to extract song from a video, it's not a line to add in playvideo.rexx

2) right, no "streaming" in the prefs of smtube, it's "playback"

3) when smtube ask to update code it's because Youtube changed something and that smtube need update. Click OK everytime.

4) when you type "APPDIR:Mplayer-altivec" in a CLI, it works. Right ?

It should be ok, now !

   Report Go to top

Re: SMTube : new version on OS4Depot
Just popping in
Joined:
2006/12/18 1:32
From Hawaii
Posts: 221
@zzd10h

OK, thanks, it works now!

One weird thing that doesn't really matter: when I open that hanging menu with RMB:

Play video
Record video
Record audio
Watch on YouTube
Copy link

and click "Watch on YouTube," up comes OWB (with a note that I need Adobe Flash Player)! I haven't used OWB for maybe a year, and I can't guess what is calling it.

   Report Go to top

Re: SMTube : new version on OS4Depot
Just popping in
Joined:
2006/12/18 1:32
From Hawaii
Posts: 221
@zzd10h

By the way, I don't know what "streaming" is, but it was your lines

9) hit the little screwdiver button at bottom of SMTube
-configure the quality of recording videos (720p MP4 for example) and Streaming Videos (480p webm)

that made me expect to find it in that configurer.

   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
@kilaueabar
Yes, i know that it was me that wrote "streaming" i was not in front of my x1000. Sorry, i tried to help, nothing more...

Ok, now SMTube works, right ?
Better than GetVideo and that YouTube video under Odyssey, no ?


   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
SMTube 14.12 svn6664

available on OS4Depot and via AmiUpdate.

* New options to set a proxy.

* Updated translations


   Report Go to top

Re: SMTube : new version on OS4Depot
Quite a regular
Joined:
2009/6/1 13:11
From Germany
Posts: 733
@zzd10h
Thank you

_________________
Amiga600/Vampire2/PrismaMegaMix‚Äč/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: SMTube : new version on OS4Depot
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 900
@zzd10h
Thanks.

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: SMTube : new version on OS4Depot
Just popping in
Joined:
2014/5/4 6:48
From Naples
Posts: 16
@kilaueabart

Does your playvideo.rexx works on MorphOS too?

I am interested to see anime videos hosted on these sites:


http://www.popcorntv.it

http://www.daisuki.net

The sites host videos in Flash, and any video has been preeceded by one or two advertising in flash too before the choosen video will be played.

So there is a problem viewing it with OWB, even if spoofed as IPad.

When spoofed as Ipad then it appears playing commands interface, but videos not playing.

Is your mPlayer based Arexx script capable to play these videos (it will be great) or perhaps capable (at least) to recognize the *real* link to which the videos belong?

(in order to download them and transform them with mencoder and watch it in a more suitable codec for our platforms)



Edited by Raffaele1024KB on 2015/1/15 13:19:06
   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
@Raffaele1024KB

PlayVideo.rexx is a rexx made specifically for OS4 SMTube.

Maybe that you thought about my WebReplay (in zTools package) ?


   Report Go to top

Re: SMTube : new version on OS4Depot
Just popping in
Joined:
2014/5/4 6:48
From Naples
Posts: 16
@zzd10h

by zzd10h on 2015/1/15 15:31:27


Quote:
@Raffaele1024KB

PlayVideo.rexx is a rexx made specifically for OS4 SMTube.
[7quote]

Ah ok!

[quote]
Maybe that you thought about my WebReplay (in zTools package) ?


Nice to see it exists.

is it universal for all Amiga platforms?

   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
@Raffaele1024KB

it should work, yes, but

1) it's available only via AMIStore (=> OS4)

2) I have to take a look to the 2 websites that you provided to see if it's possible to add them.

By the way, the thread dedicated to zTools (therefore WebReplay) is here : ;)

http://www.amigans.net/modules/xforum ... e=&order=ASC&type=&mode=0


   Report Go to top

Re: SMTube : new version on OS4Depot
Just popping in
Joined:
2014/5/4 6:48
From Naples
Posts: 16
@zzd10h

Quote:

by zzd10h on 2015/1/15 16:53:43

@Raffaele1024KB

it should work, yes, but

1) it's available only via AMIStore (=> OS4)


Urgh! it will be no availble until Amistore will implement web based pay system...

   Report Go to top

Re: SMTube : new version on OS4Depot
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 900
Why not contact Amigakit, they may look into a non Amistore purchase for you.

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
@Raffaele1024KB

See here for my reply about your websites and WebReplay

http://www.amigans.net/modules/xforum ... t_id=95182#forumpost95182

   Report Go to top

Re: SMTube : new version on OS4Depot
Just popping in
Joined:
2014/5/4 6:48
From Naples
Posts: 16
@ddni

I will not purchase anything from an incomplete webstore relying on third parties.

   Report Go to top

Re: SMTube : new version on OS4Depot
Just can't stay away
Joined:
2012/8/14 12:51
From France
Posts: 1494
Updated SMTube HowTo post
http://www.amigans.net/modules/xforum ... t_id=94635#forumpost94635

If a video doesn't play you can try to force SMTube to update his YouTube script.

-delete Qt:home/.config/smtube/yt.js
-retry to watch the failing video.
-an updated SMTube YouTube code is downloaded.
-retry and enjoy !


   Report Go to top


« 1 2 3 4 (5) 6 7 8 ... 19 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project