Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
74 user(s) are online (65 user(s) are browsing Forums)

Members: 2
Guests: 72

Chris, Severin, more...
Support us!
Recent OS4 Files
OS4Depot.net





Strange things are happening...SFS2
Quite a regular
Joined:
2009/3/10 10:51
From Germany
Posts: 607
Hi,

there is something strange going on with one of my partitions with SFS/2:
There seem so happen random data "disappearance". Maybe this is something that is happening for some time now, but as i do not check my data every day...

The "oldest" data structure on this partition are the icons from Mason and Klesterjr, which i downloaded immidiately after getting my SAM. One after another in some of the directories the .info-files disappear - the drawers are empty or partly empty, *subdrawers* seem NOT to be affected, only files! Yes, I know that there WERE icon files in there - i can remember them (i.e. icons for YAD). Which are not there anymore. And, no, i did not copy or move them to another place...

At the moment there seem to be only the DATA (DH2:) partition affected, is there anything i can do? maybe a check with some (what? partition wizard?) program?

This is my current partition layout:

Data:/DH2: SFS/2 91528GB Block 1K
Device = sii3114ide.device
Unit = 0
Flags = 0
Surfaces = 3
SectorsPerBlock = 2
BlocksPerTrack = 16
Reserved = 2
LowCyl = 4059707
HighCyl = 8058620
Buffers = 600
BufMemType = 1
MaxTransfer = 0x7fffffff
Mask = 0xfffffffe
DosType = 0x53465302
GlobVec = -1
Workbench:/DH0: SFS/0 1081GB Block 1K
Device = sii3114ide.device
Unit = 0
Flags = 0
Surfaces = 3
SectorsPerBlock = 2
BlocksPerTrack = 16
Reserved = 2
LowCyl = 43
HighCyl = 47275
Buffers = 600
BufMemType = 1
MaxTransfer = 0x7fffffff
Mask = 0xfffffffe
DosType = 0x53465300
GlobVec = -1
Work:/DH1: SFS/2 91837GB Block 1K
Device = sii3114ide.device
Unit = 0
Flags = 0
Surfaces = 3
SectorsPerBlock = 2
BlocksPerTrack = 16
Reserved = 2
LowCyl = 47276
HighCyl = 4059706
Buffers = 600
BufMemType = 1
MaxTransfer = 0x7fffffff
Mask = 0xfffffffe
DosType = 0x53465302
GlobVec = -1
Swap:/Swap: SWAP 1908MB
Device = sii3114ide.device
Unit = 0
Flags = 0
Surfaces = 3
SectorsPerBlock = 8
BlocksPerTrack = 16
Reserved = 2
LowCyl = 8058621
HighCyl = 8140040
Buffers = 600
BufMemType = 1
MaxTransfer = 0x7fffffff
Mask = 0xfffffffe
DosType = 0x53574150
GlobVec = -1

   Report Go to top

Re: Strange things are happening...SFS2
Home away from home
Joined:
2006/11/30 18:43
From Norway
Posts: 2461
@cha05e90

You don't get any errors or problems when copying/moving or deleting files from that partition? And if you're 111,25% sure that files are MIA then take backup of the files and reformat the partiton and copy the files back and see if that helps.

_________________
Sam460 Lite
   Report Go to top

Re: Strange things are happening...SFS2
Quite a regular
Joined:
2009/3/10 10:51
From Germany
Posts: 607
To demonstrate what i mean with randomly empty dirs here's a screenshot of my dopus showing the empty "0"-byte size drawers:

http://www.amigans.net/modules/myalbum/photo.php?lid=232&cid=5

   Report Go to top

Re: Strange things are happening...SFS2
Quite a regular
Joined:
2008/3/11 8:29
From Dunedin, New Zealand
Posts: 868
@cha05e90

I wouldn't think that using a 1024k block size would cause this kind of side affect? but you never know? If all else fails and you are left to salvage your partition consider setting it up to use a 512k block size.

These types of errors are always a pain, unless specifically documented and known there are so many variables it drives you mad at times!

_________________
~Yes I am a Kiwi, No, I did not appear as an extra in 'Lord of the Rings'~
1x AmigaOne X5000 2.0GHz 2gM RadeonR9280X AOS4.x
3x AmigaOne X1000 1.8GHz 2gM RadeonHD7970 AOS4.x
   Report Go to top

Re: Strange things are happening...SFS2
Just can't stay away
Joined:
2008/1/6 17:56
From Pennsylvania, USA
Posts: 1247
@cha05e90Quote:
Data:/DH2: SFS/2 91528GB Block 1K

You must use 512 for block size with SFS. SFS docs indicate that PartitionWizard will not work properly with SFS/2 so I wouldn't do that.

   Report Go to top

Re: Strange things are happening...SFS2
Quite a regular
Joined:
2009/3/10 10:51
From Germany
Posts: 607
@xenic

Interesting - my SAM came preinstalled from my dealer with that layout.

   Report Go to top

Re: Strange things are happening...SFS2
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3489
@cha05e90
Sadly not all "Amiga dealers" will be knowledgable on OS4, so they might not configure it as well as possible (or even correctly). Hyperion could have made partitioning a LOT easier, but the OS4 beta is missing template files :(

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: Strange things are happening...SFS2
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1890
@xenic

I think 512 block for sfs is the optimum value, not the compulsory one. That is other block sizes will work but less efficiently. Ideally you wouldn't set up a partition inefficiently but there no need to worry if you did by accident.

   Report Go to top

Re: Strange things are happening...SFS2
Quite a regular
Joined:
2009/3/10 10:51
From Germany
Posts: 607
The first thing i'll do this weekend is an backup of all of the partitions - not sure how, maybe burning some CDs...
Afterwards i'll try to reformat that suspicous DATA:-partition. BTW: I also read that 512k blocksize as optimal setting but not mandatory ?!?

   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project