Remember me

Lost Password?

Register now!


Who's Online
87 user(s) are online (75 user(s) are browsing Forums)

Members: 0
Guests: 87



  Register To Post  

Reset Device Audio AHI sb128
Quite a regular
Quite a regular

See User information
There is a shell command or something similar
to "restart the AHI device" after using an application.
I give an example:
Many times when I use Odyssey and then I exit the program and use immediately after E-UAE the system crashes "DSI"

I tried to use:
KeepAHIOpen, but it doesn't seem to work, it's probably not useful for my purpose.
Is there anything that resets the audio or associated processes without resetting the amiga system?
It is probably due to the winuae emulator.
Thanks for any help.

Go to top
Re: Reset Device Audio AHI sb128
Home away from home
Home away from home

See User information

My guess is some thing is overwritten in memory. Do you get any ISI/DSI errors before starting EUAE.

Some time the only way solve problems like this is to staring at the code until the bugs give up and surrender.


Basilisk II for AmigaOS4
and other tools and apps.
Go to top
Re: Reset Device Audio AHI sb128
Quite a regular
Quite a regular

See User information
Thanks for the reply,
The error occurs only and always after using other programs is later E-UAE.
If I start E-UAE first, this never happens.
Only when I start E-UAE as a second program does this happen.
Do I have a crash log, can I post it or is it better to attach it to a link?
It is probably something to fix in winuae eventually
Thank you very much

Go to top
Re: Reset Device Audio AHI sb128
Quite a regular
Quite a regular

See User information
It's probably completely random, but it seems connected to the AHI device.

the log starts like this:
Crash log for task "uae"
Generated by GrimReaper 53.19
Crash occured in module at address 0x19A33F68
Type of crash: ISI (Instruction Storage Interrupt) exception
Alert number: 0x80000003

Register dump:
GPR (General Purpose Registers):
0: 39A33F68 381A8BA0 82810040 00000A00 0003DEA9 38705E68 37785008 37785008
8: 3A5400B0 000065FA FFFFF600 13477A00 33842935 3B53AF40 39A33F68 3B290000
16: 3B290000 1F15C090 3A5401E8 1F15D7D0 397A0000 3B290000 1EE4C850 3B290000
24: 39AB0000 3982AFE8 3B290000 39A33F68 1EE4B420 39AB4468 3982AFE8 39A33F68

FPR (Floating Point Registers, NaN = Not a Number):
0: 3.36112e-316 1 1.25524e + 58 6.906e + 38
4: -9.00726e + 307 2.88329e-14 -1.29169e-308 2.88489e-14
8: 1.73585e + 212 4.5036e + 15 2.14748e + 09 3.40149e + 06
12: 20 5.42978e-321 -1.99041e + 39 -2.30473e + 116
16: 7.04319e-18 7.09905e + 38 7.0983e + 38 2.92486e + 289
20: -3.94521e-214 -1.57809e-213 -6.66231e-116 7.77624e + 292
24: 1.25852e + 08 1.17874e + 308 1.2548e + 58 544.145
28: -1.13015e-302 3.19039e + 295 -7.58282e-302 -2.91475e-77

FPSCR (Floating Point Status and Control Register): 0xEB3E801C

SPRs (Special Purpose Registers):
Machine State (msr): 0x4000F070
Condition (cr): 0x37A33DA0
Instruction Pointer (ip): 0x19A33F68
Xtended Exception (xer): 0x0882A7E0
Count (ctr): 0x00000000
Link (lr): 0x00000000
DSI Status (dsisr): 0x08849DE0
Data Address (dar): 0x00000000

680x0 emulated registers:
DATE: 00000001 00000000 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 3FFB5500 614699A0 00000000 00000000 00000000 00000000 00000000 381A8400
FPU0: 0 0 0 0
FPU4: 0 0 0 0

Symbol info:
Instruction pointer 0x19A33F68 belongs to module "" (HUNK / Kickstart)

Stack trace:
0x19A33F68 symbol not available
module uae at 0x39A33F68 (section 12 @ 0x28EF44)
module uae at 0x1EE49BB8 (section 5 @ 0x7B94)
module uae at 0x1EE43128 (section 5 @ 0x1104)
module uae at 0x1F19199C (section 5 @ 0x34F978)
native kernel module newlib.library.kmod + 0x000020a4
native kernel module newlib.library.kmod + 0x00002d0c
native kernel module newlib.library.kmod + 0x00002ee8
uae: _start () + 0x180 (section 1 @ 0x17C)
native kernel module dos.library.kmod + 0x000255c8
native kernel module kernel + 0x00045a64
native kernel module kernel + 0x00045aac

Go to top
Re: Reset Device Audio AHI sb128
Quite a regular
Quite a regular

See User information
Solved the problem, I had to make some changes in winuae.
And oddly once I configured the E-UAE file I had to set the write protect flag.
Probably I was wrong, but every time the file was overwritten adding an additional partition also of 4.1
protecting it from writing now everything works perfectly E-UAE, Odyssey, ffplay etc. without crash
I don't understand why if I don't protect it from writing every time it also adds the 4.1FE partition.
However now it works.
here the video, if it can be useful
Thanks again for the advice.

Go to top

  Register To Post


Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )

Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project