Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
49 user(s) are online (31 user(s) are browsing Forums)

Members: 0
Guests: 49

more...

Headlines

Forum Index


Board index » All Posts (jap)




Re: Catweasel SID player
Just popping in
Just popping in


The reason for catweasel.device crashing may be that I have no disk drive connected to the Catweasel.

Go to top


Re: Catweasel SID player
Just popping in
Just popping in


I installed Ian's Catweasel drivers (catweasel.device and catweaselsid.device) from the AmigaOS 4.1 FE installation CD. Once installed Catweasel Disk Preferences program does play a SID test sound but catweasel.device crashes right after that.

AmigaOS 4.1 SDK has Catweasel include files but there is no documentation or example programs. Are they for using the devices or for accessing the card directly?

Go to top


Catweasel SID player
Just popping in
Just popping in


Hello,

Are there any music players for AmigaOS 4 that can play SID tunes using the Catweasel MK3 PCI card?

Go to top


Re: Your graphics and sound card recommendations for X5000
Just popping in
Just popping in


Thanks McFly! I bookmarked the page as well.

Go to top


Re: Your graphics and sound card recommendations for X5000
Just popping in
Just popping in


Thanks for the suggestions!

Based on your recommendations so far, I'm going to select Sound Blaster Audigy Fx for the sound card (https://uk.creative.com/p/sound-cards/sound-blaster-audigy-fx) and ASUS Dual Radeon RX 560 4GB for the graphics card (https://www.asus.com/motherboards-comp ... cards/dual/dual-rx560-4g/).

@khayoz

Thanks for the tips!

I ordered an X5000/20, but lets see if the dealer really has any X5000/20s left.

Go to top


Your graphics and sound card recommendations for X5000
Just popping in
Just popping in


Hello,

I've finally ordered an X5000 motherboard and now I need to choose graphics and sound cards for it. What do you recommend?

Go to top


Re: Pegasos2 with RadeonHD/RX via bridge
Just popping in
Just popping in


@balaton
Quote:
The problem is that there's no technical info available on the net about these machines other than marketing text these seem to be completely vanished or was never publicly available.


I have an AmigaOne-XE/G4 and all the material that came with it, including Articia S brochure PDFs, Mai Logic AmigaOne-XE Motherboard User Manual PDF, and three A1 Linux iso images. Would those be useful to you?

Go to top


Re: Guide for New A1222 Users
Just popping in
Just popping in


Graphics card is a must.

It would be great if a PCIe splitter & PCIe-to-PCI adapter combination worked. It looks like the four PCIe ports that the splitter provides will be slower (x4 performance) than the A1222's x16 PCIe slot.

I wonder if Radeon RX cards mind the slower x4 speed.

Go to top


Re: Guide for New A1222 Users
Just popping in
Just popping in


Thanks for the excellent guide eliyahu!

I have a PCI SID sound card in my AmigaOne-XE. Is there a way to use it with A1222+?

Go to top


Re: Default Workbench color palettes
Just popping in
Just popping in


In case somebody else needs the pen colors, I found them from the Amiga Workbench Simulation site: https://www.taws.ch/WB.html


Edited by jap on 2023/6/11 8:59:09
Go to top


Default Workbench color palettes
Just popping in
Just popping in


Hello,

I'm looking for the default Commodore Workbench 1.x, 2.x, and 3.x color palette RGB values (pen colors). Can anyone help me?

I'd be interested to know GlowIcon and MagicWB palette colors, too.

Go to top


Re: Say or speech: in amigaos4?
Just popping in
Just popping in


@IamSONIC

Your mountlist file is correct. Place the file in the DEVS:DOSDrivers directory and set the file's tool type ACTIVATE to one (ACTIVATE=1). Then remove "Mount SPEAK:" command from the Startup-Sequence and make sure that the Startup-Sequence has the line "Mount QUIET DEVS:DOSDrivers/~(#?.info)". It'll mount the SPEAK: device.

The trick is the ACTIVATE tool type. Without it Say will crash.

Go to top


Re: Getting Red Mars to run on AmigaOS 4.1
Just popping in
Just popping in


@LiveForIt

Ah, I assumed that FozenAt starts the program.

@hotrod

With the help of CIAgent the intro started!

All the graphics are okay and the intro runs but there is no music. At some point I can hear a short sound fragment and then AHI crashes and the intro halts (alert number 80000003).

If I wait long enough or ignore the crash, the intro continues and I can hear sound effects but still no music.

After a 3 minutes or so, the intro crashes again and this time the whole system jams.

I tried starting NallePUH before the intro but then the intro refused to start.

Also the game itself starts but it crashes after I've entered the correct copy protection code (Guru Meditation: 80000003).

Go to top


Re: Getting Red Mars to run on AmigaOS 4.1
Just popping in
Just popping in


@LiveForIt

I tried your tool and it printed this:

Quote:
Program pomIntro:psycheintro
IDebug: 6ff92000
Task not found pomIntro:psycheintro

The game is in three parts: intro (psycheintro), game (psyche), and outro (psycheout).

I got the same address for psycheintro and psyche.

There is no such address in the psyche's assembler listing, so the address is not from the intro/game but perhaps from the destracker library that the intro/game is trying to use.

Go to top


Re: Getting Red Mars to run on AmigaOS 4.1
Just popping in
Just popping in


@LiveForIt

Thanks! I disassembled the game file and at least the game is not waiting for a mouse button to be pressed. There is one subroutine that does some calculations with the VPOSR register:

MOVE.L LAB_2D24(PC),D0
MULU   
#$686b,D0
ADD.L  #$02ceda9f,D0
ADD.L  VPOSR,D0
MOVE
.L D0,LAB_2D24
RTS


Go to top


Re: Getting Red Mars to run on AmigaOS 4.1
Just popping in
Just popping in


I don't have tools to modify the 68k game executable other than a hex editor.

Go to top


Re: Getting Red Mars to run on AmigaOS 4.1
Just popping in
Just popping in


@sinisrus

The goal was to run it on AOS4 (no E-UAE).

@LiveForIt

I just tried running the game with NallePUH. The game started but it jammed. It didn't crash since the system is still fully functional but the game seems to be in some sort of busy loop. There is no sound, nor did the game open its screen, but the game seems to be running.

It would be great to have a "fake" destracker library to get the game running properly. The game would probably work since it uses rtg library for the graphics.

I've tried creating a skeleton library with idltool before but with no success. The problem was that the code it generated could not be compiled without first modifying the code manually. As a library developer beginner, tweaking the code was too hard for me despite the instructions :(

Go to top


Re: Getting Red Mars to run on AmigaOS 4.1
Just popping in
Just popping in


@sinisrus

Here you are: Red Mars
It's a commercial game so I won't put my copy online.

Library's developer release can be downloaded from here: DES-TRACKER.LHA

It contains test programs for the library. I tried one of the test programs and it suffers from the same problem as the game: the library won't open.

Go to top


Getting Red Mars to run on AmigaOS 4.1
Just popping in
Just popping in


Hello,

Has anyone managed to run Red Mars on AmigaOS 4.1? It seems there is a problem with destracker.library that comes with the game.

I can see with Snoopy that the library is loaded in memory but OpenLibrary() call fails.

Go to top


Re: What do you want to see on the A1222?
Just popping in
Just popping in


I'd like to see how it runs Python (pygame) games.

Go to top



TopTop
(1) 2 3 »




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project