Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
49 user(s) are online (22 user(s) are browsing Forums)

Members: 2
Guests: 47

salass00, orgin, more...

Headlines

Forum Index


Board index » All Posts (Cageman)




Re: Star Wars: Jedi Outcast and Jedi Academy not working....
Just popping in
Just popping in


Never mind... I managed to find it... It was an LHA archive and not a zipped one... downloading now. :)

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: Star Wars: Jedi Outcast and Jedi Academy not working....
Just popping in
Just popping in


The link you provided gives me a 404 file not found. :)

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: Star Wars: Jedi Outcast and Jedi Academy not working....
Just popping in
Just popping in


@kas1e

Hello! Thanks for the answer. I would very much like to test your GL4ES port!

Go to top


Star Wars: Jedi Outcast and Jedi Academy not working....
Just popping in
Just popping in


Hello!

I am trying to get Star Wars: Jedi Outcast and Jedi Academy to run on my AmigaONE X5000 but they refuse to start. Something related to not being able to load OpenGL subsystem.... Is there something I have missed installing or is it because I have a too modern graphics card? Radeon RX550.

This is the log that is outputed when I try to start on of those games.

OpenJK: v1.0.1.1 AmigaOS-ppc May 29 2014
Initialising zone memory .....
----- FS_Startup -----
Current search path:
Work:Games/HDD/StarWars_JediAcademy/.openjk/base
Work:Games/HDD/StarWars_JediAcademy/base/assets3.pk3 (16 files)
Work:Games/HDD/StarWars_JediAcademy/base/assets2.pk3 (62 files)
Work:Games/HDD/StarWars_JediAcademy/base/assets1.pk3 (8320 files)
Work:Games/HDD/StarWars_JediAcademy/base/assets0.pk3 (15346 files)
Work:Games/HDD/StarWars_JediAcademy/base

----------------------
23744 files in pk3 files
execing default.cfg
couldn't exec openjk_sp.cfg
couldn't exec autoexec_sp.cfg
Running Jedi Academy Mode
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Initializing OpenGL display
...setting mode 4: 800 600
Coudln't create GL context
----- CL_Shutdown -----
-----------------------
GLimp_Init() - could not load OpenGL subsystem


There are other games that starts just fine, such as Hurrican and Return to Castle Wolfenstein, but they are not based on OpenGL... they are running OpenGLes 2.0 Warp3D NOVA and GL4es with EGL_wrap library.

Go to top


Re: Amigans Discord
Just popping in
Just popping in


@FirstNinja

One doesn't exclude the other?

Discord offers video streaming which makes it easier to live-broadcast your Amiga through a PC with a game-capture card when you need help with something.

Instead of waiting for the next physical meetup in (insert country) to bring your Amiga there to get help troubleshooting something.

:)

Go to top


Re: THEA500 Mini
Just popping in
Just popping in


I own one and I have to say it is a very good "plug and play" solution for A500 and A1200 games. I am surprised at how well it emulates my WHDLoad games, and now with the latest firmware patch, multi-disk games using ADF format.

I know that a lot of emulation enthusiasts spit on it, because you could get something like this running on a RasberryPi with a fraction of the cost of The A500 mini. But what these people also forget in that argument is that everyone would need A LOT of knowledge about the Amiga chips etc to setup the emulation for each game.

I would also argue that this device is not for hardcore Amiga users that are still using Amiga either through emulation, real hardware or next-gen whatever.

It is for people that were found of the Amiga games and they are paying for not having to become Amiga experts on Amiga emulation in order to play the games they have great memories of.

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: AmigaOS 4 Monthly Roundup - May 2022
Just popping in
Just popping in


Thanks a lot for this Roundup!

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Just popping in


The driver works fantastic in my X5000.

Thanks a lot for your hard work @geennaam

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


@nbache

Yeah... if it works for you it "should" work for me... I am quite puzzled with that.

If you are on Discord with a PC we can probably setup a session where I share my Amiga screen (I have a capture card) and then walk and talk through it... Maybe I made a misstake somewhere that we just cant see at the moment?

Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


@all

I am very greatfull with all the suggestions that YOU ALL posted and took time to post. And again, I am NOT the typical Amiga User... the only reason I had a super expanded Amiga 1200 back in the days was because of the creativity tools others developed. All the mod trackers, Octamed Soundstudio, LightWave and Imagine etc.

This is also why I am an Amiga user today... the creativity and friendship.

This means that I do not really know how to write arexx scripts or scripts related to LHA that automate things. I am slowly learning. ;)

With that said and done... today, with the solution that the Swedish Amiga Users presented to me, I have succefully done what I initially asked for.

3374 archives have been made with very little effort compared to what it would have taken doing it manually.

Did the Swedish Amiga Users come to the best solution? From what I see here, no (since I had to resort to install some 3:rd party tools). But they were the first to come to a solution that, despite not being "perfect" worked out in an excellent way for the needs I had in this particular situation.

What works works, and I have yet to test the solutions that you have posted here, but I have copied them and saved them as textfiles.

Thank you ALL so much for assisting me in finding a solution. You guys rock. I will probably have more questions about AmigaONE X5000 in the future.

:)

<3 <3 <3

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


@jPV

I have to say that I am no expert in these things at all. That said, with 15+ years of Cinematics productions for games, spaces in names/directories are a big no-no. It is so rooted in me nowdays that I treat the Amiga the same way. :)

Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


@jPV

Ahh... yes... well... I got a similar but different solution... see my previous post... I must have made that post while you were making yours. :)

Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


An update!!! :)

Some guys over at a Swedish Amiga forum helped me solve this in a different way.

Go to OS4Depot, download and install UHCTools. It includes the ForEachLine command...

Here is an example script. First it creates a list of all directories inside Work:Games/ and saves it to a file called "dirs" in T:

Then it, for each line in the file "dirs", creates an .lha archive with the same name as in the list in the file "dirs". The resulting archives are stored in T: so it is easy to move them wherever you want them.

;BEGIN Script
List DIRS LFORMAT "%N" Work:Games/ >T:dirs
ForEachLine T:dirs
Lha a -a -e -r ${LINE}.lha Work:Games/${LINE}/#?
EndForEach
;END Script

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


I also tried this with my emulated Amiga (WinUAE) running AmigaOS 3.9 and I get the same error message.

I'm very puzzled at this moment. :D

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


Here is what I get when I test if I have LHA installed or not.

New Shell process 4
4.Workbench:> which lha
Workbench:C/LhA

And this is the version of the lha command in Sys:C

4.Workbench:> version lha
LhA 2.15 AOS4 Jan 3 2011

So... it seems I have LhA command installed in the correct place (Sys:C).

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


Tested with a directory I unpacked to RAM: and then wanted to pack it to RAM:

The directory is called WhatIFF1.04

Please insert Volume lha -x -r -a -m -e -F a "WhatIFF1.04.lha" "RAM:" in any drive.

:D

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


I've copied your script, pasted into notepad and saved it as PackDirs.rexx in REXX:

I have then followed your instructions in setting the button up in Dopus4 with

rx REXX:PackDirs.rexx {f} (as an AmigaDOS command)

However I get an error message that reads like this:

lha -x -r -a -m -e -F a "S.lha" "SYS:S": Unknown command

When testing using the S directory in my Workbench installation.

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top


Re: LHA Archiving questions....
Just popping in
Just popping in


Very cool @nbache

I have to mention that I am a returning user of AmigaOS (I recently got my AmigaONE X5000)... and I do remember using Rexx scripts back in the late 1990:s... However, I will probably need more help and take baby steps with this...

First question... Where would I need to store your REXX script? :D

The rest regarding Dopus 4 looks easy enough to setup. But then again, I might have more questions. :)

Go to top


LHA Archiving questions....
Just popping in
Just popping in


Hello!

I wonder if there is a way to archive a list of directories so that each directory gets its own archive. Let me explain... Lets say I have a directory that looks like this

A
B
C

Ok... what I would want to do here is to not have to archive these 3 directories manualy, one by one. What I would want to do is to have them archived like this:

A.lha
B.lha
C.lha

Similar to how WinRAR allows for each selected file (or directory) to get its own archive.

Any ideas on how to achive something like that? And yes... it has to be LHA for reasons.

Thanks in advance. :)

Go to top


Re: THEA500 Mini
Just popping in
Just popping in


For anyone interested....

https://www.youtube.com/watch?v=0Vivn-ek8WY

Another reviewer also took it appart and it is a custom PCB running a dualcore ARM microprocessor. Since it is an ARM processor, it is using AmiBerry for the emulation. And it also emulates AGA.

I really like the Plug-n-Play approach. It is for those people that used Amiga as a games console (A500, A1200) and never thought about it as something more and would want an easy to use Amiga games console, who can't be bothered with the technical side of setting up a PC with WinUAE etc.

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top



TopTop
« 1 2 3 4 (5) 6 »




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project