Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
79 user(s) are online (72 user(s) are browsing Forums)

Members: 1
Guests: 78

daveyw, more...
Support us!
Recent OS4 Files
OS4Depot.net
Report message:*
 

Re: RadeonHD 3.x bug (?): more than ~256mb of used GPU (second chunk) memory cause a heavy lockup/crash.

Subject: Re: RadeonHD 3.x bug (?): more than ~256mb of used GPU (second chunk) memory cause a heavy lockup/crash.
by kas1e on 2019/9/29 11:08:34

@Capehill
Tried to run your test case : it show grey window, but then i can't see it fill extendent GPU video memory, it fill instead first 256mb block wher we have workbench/system/etc (i.e. "system graphics memory of first 256mb chunk").

I remove extra %lu, added "IDOS->Delay(100)"; before freeing of bitmaps, then run it, and GPU memory is not filled for sure. Instead, it use first 256 mb block (which is taken by workbench , by system , etc).

So, with that test case you didn't fill extendend GPU memory, only first 256 mb block. Our issue is second one , which is first for extendent GPU memory.

I even can see via SysMon, that when i run your example for example with 100 bitmaps, it eat 25mb of "system gfx" memory, not the 25mb of GPU extendent memory where we have our issues.

Test case need somehow be told that we need to put data inside of extendent GPU memory exactly (that one which after first 256 mb of "system gfx memory" , so its second and more chunk of whole VRAM)

EDIT: maybe we even can't fill up GPU extendent video memory via graphics.library, because its in hands of Hyperion, and "breaking of 256mb barier" was added to RadeonHD and warp3dnova, so i assume, its doing something which graphics.library can't / don't do. So , we can only fill it by warp3dnova functions, probably.
Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project