Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
73 user(s) are online (55 user(s) are browsing Forums)

Members: 1
Guests: 72

miggymac, more...

Support us!

Headlines

Forum Index


Board index » All Posts (ScottCabit)




Re: Big E-UAE JIT blog
Just popping in
Just popping in


@LiveForIt

Oh...yes..you are right.
I was experimenting and must have had it that way when I used it last. Please do set cpu_speed=max for fastest results.



Go to top


Re: First native betas of dopus5, check this out !
Just popping in
Just popping in


I seem to get DSI errors any time I go to Edit the button banks.
Anyone else having this problem?


Go to top


Re: Big E-UAE JIT blog
Just popping in
Just popping in


@Elwood

If the only thing you did was replace the original euae binary with the JIT one, you are NOT running in JIT mode. To enable JIT, you must add these commands to your .uaerc file.

enable_jit=yes
cpu_speed=real
cpu_type=68020
cpu_compatible=false
cpu_cycle_exact=false
blitter_cycle_exact=false
comp_optimize=no
cachesize=8192
comp_constjump=yes
comp_trustbyte=indirect
comp_trustword=indirect
comp_trustlong=indirect

You can tell if you are running with JIT enabled if you turn on the control panel LEDs. With JIT enabled, you will see the rightmost LED indicate "JIT" which will flash green.
Without the above variables, the JIT version just runs the same as the normal euae.

Scott

Go to top


Re: Amiupdate
Just popping in
Just popping in


@Rigo
So is there a way for me to have new versions of applications like sketchblock, cinnamon writer, or AmigaAmp get updated automatically as they become available through AmiUpdate?
If so, that would be awesome!

Thanks

Only Amiga Makes It Possible!
AmigaOne Micro A1-c 512M RAM 1TB SSD using SATA 3114 controller
Go to top


Re: A small (and dangerous) new years gift for the os4 community :)
Just popping in
Just popping in


@Spirantho

Interesting that it works on your A1XE. It just locks up on my microA1 with built in Radeon Graphics.....


Scott

Go to top


Re: Micro A1 and Graphics
Just popping in
Just popping in


@slcroucher

Don't know about the composite video out on the micro A1. As far as using a different graphics card, I know there was a special version of UBoot that allowed support of such a possibility but it was not, to my knowledge, made publicly available. Without UBoot support any attempt to use a graphics card in the micro A1 other than the built-in graphics will not work. Even with the modified UBoot software, I'm not sure if anyone got good results with other graphics cards on the micro A1.

Scott

Go to top


Re: Christmas donations :)
Just popping in
Just popping in


@Antique

I tried to donate with paypal to the email you gave for the Friedens above (minus spaces and the final "." and paypal says it is not valid. Is it really .org or is it .com?

Thanks

Go to top


Re: Christmas donations :)
Just popping in
Just popping in


@Antique

Where did you find the Frieden's paypal info for donating? I'd like to donate to them and to Kas1e as well!

Links please?

(Okay...just donated to kas1e...where is the Frieden's paypal donate?)

Thanks!


Go to top


Re: Qt5 progress
Just popping in
Just popping in


@alfkil

No worries! We all appreciate your work on QT 4.7 and look forward to QT5 whenever you have an opportunity. You are doing a wonderful job of porting QT. Thank you for your efforts!

Scott

Go to top


Re: First native betas of dopus5, check this out !
Just popping in
Just popping in


IIRC I got that same DSI error when I first installed the OS4 version of Dopus5 on my microA1 because I already had an assign from the original 68k version in my user-startup somewhere. Took me a little while to figure it out. I hope it gets fixed!

By the way, great work on Dopus5 you guys!

Only Amiga Makes It Possible!
AmigaOne Micro A1-c 512M RAM 1TB SSD using SATA 3114 controller
Go to top


Re: Screenmode on OS4
Just popping in
Just popping in


@Severin wrote "There is no program to genererate UAE config files..."


Not true. Get UAEConfig from OS4Depot. I wrote is several years ago and it generates working uaeconfig files on AmigaOS4 systems using a Reaction interface.

Scott


Go to top


Re: Basilisk 1.0 beta testing
Just popping in
Just popping in



I finally figured out that if I set my workbench screenmode prefs to an 8 bit display, Basilisk2 1.0 works, that is, the graphics corruption vanishes. But if workbench is in either 16 or 32 bit display mode, I get screen corruption.
Haven't done much compatibility testing yet, but version 1.0, just like 0.93, fails to run Adobe Photoshop 3.0 with an error indicating that the MAC display parameters are invalid.

Scott

Go to top


Re: First native betas of dopus5, check this out !
Just popping in
Just popping in


@kas1e

I just downloaded and tried your Dopus5 for OS4 and it looks very good. I downloaded the nightly build from Nov 1, 2013 and it started up okay. No DSIs.
However, when I went to open the environment option window from the menu bar, I got a DSI. I selected ignore and continued. I saved my environment, loaded a theme I had downloaded from Aminet and it worked great.
I think I still have the hardcopy of my Dopus 5 manual around here somewhere. I'll need to look at how to set up file types using sniffer...I tried to do it the way I thought I remember it working and got nowhere...but its been a long time!

Overall, great work! Thanks to everyone who has contributed to get this working.

Scott

Go to top


Re: Basilisk 1.0 beta testing
Just popping in
Just popping in


Just tried this new version of Basilisk2 for the first time. It seems that it doesn't work with certain ROM files, but others are okay. The ROM file I used with the 0.93 version of Basilisk2 for example just causes the white screen at startup and nothing else ever happens.
But when I choose a different ROM it does boot up, as long as I hold down the right shift key to disable extensions.
On all screenmodes I've tried, I always get the "blur" effect, like the pixels are rapidly shifting to the right and back several times a second. So the display is not useable until I can figure out how to get that fixed.

Anyone have a solution?

Thanks,



Oh, I have a microA1 with the built in Radeon graphics chips.

Go to top


Re: Beta testing
Just popping in
Just popping in


@alfkil

I'm still having a problem building the animation/animatedtiles program, or actually any program that uses the libz.so.1 library. I get the following errors after I do a qmake then gmake:

4> gmake
ppc-amigaos-c++ -use-dynld -Wl,--export-dynamic -o animatedtiles .obj/release-shared/main.o .obj/release-shared/qrc_animatedtiles.o -L/qt/lib -lQtGui -L/qt/lib -lfreetype -lfontconfig -lexpat -lQtCore -lpthread -liconv -lz -lm -lintl -ldl -lunix
ld: warning: libz.so.1, needed by /qt/lib/libQtGui.so, not found (try using -rpath or -rpath-link)
.obj/release-shared/main.o: In function `Button::mousePressEvent(QGraphicsSceneMouseEvent*)':
main.cpp:(.text._ZN6Button15mousePressEventEP24QGraphicsSceneMouseEvent[_ZN6Button15mousePressEventEP24QGraphicsSceneMouseEvent]+0x12): undefined reference to `Button::pressed()'
main.cpp:(.text._ZN6Button15mousePressEventEP24QGraphicsSceneMouseEvent[_ZN6Button15mousePressEventEP24QGraphicsSceneMouseEvent]+0x16): undefined reference to `Button::pressed()'
gmake: *** [animatedtiles] Error 1

Do I need to add a parameter to the makefile (-rpath-link) or something? I tried copying the libz.so.1 file from my SYS:sobjs directory to the QT-4.7 (/bin I think)...to no avail.
Can you help?

Thank you!

Scott

Go to top


Re: About Icons, automated Effects and why it will never work
Just popping in
Just popping in


Mason

Thank you for pointing out these flaws. You have thought about this considerably.
Good work on the OS4 icons! We all eagerly await you newest offering. You have done wonderful work.

Scott

Go to top


Re: Beta testing
Just popping in
Just popping in


@alfkil

I'm having a problem building the animation/animatedtiles program. I get the following errors after I do a qmake then gmake:

4> gmake
ppc-amigaos-c++ -use-dynld -Wl,--export-dynamic -o animatedtiles .obj/release-shared/main.o .obj/release-shared/qrc_animatedtiles.o -L/qt/lib -lQtGui -L/qt/lib -lfreetype -lfontconfig -lexpat -lQtCore -lpthread -liconv -lz -lm -lintl -ldl -lunix
ld: warning: libz.so.1, needed by /qt/lib/libQtGui.so, not found (try using -rpath or -rpath-link)
.obj/release-shared/main.o: In function `Button::mousePressEvent(QGraphicsSceneMouseEvent*)':
main.cpp:(.text._ZN6Button15mousePressEventEP24QGraphicsSceneMouseEvent[_ZN6Button15mousePressEventEP24QGraphicsSceneMouseEvent]+0x12): undefined reference to `Button::pressed()'
main.cpp:(.text._ZN6Button15mousePressEventEP24QGraphicsSceneMouseEvent[_ZN6Button15mousePressEventEP24QGraphicsSceneMouseEvent]+0x16): undefined reference to `Button::pressed()'
gmake: *** [animatedtiles] Error 1

Do I need to add a parameter to the makefile (-rpath-link) or something? I tried copying the libz.so.1 file from my SYS:sobjs directory to the QT-4.7 (/bin I think)...to no avail.
Can you help?

Thank you!

Scott

Go to top


Re: My last AmigaOS frontier
Just popping in
Just popping in


Expect it to take a little time. Don;t over estimate what you can do at once...but just learn C and enjoy it as you go, otherwise you will find yourself frustrated and giving up!
Get a simple "C for dummies" book with lots of examples. Set up the OS4 SDK etc as per Trixie's advice. Beware, right from the start there may be an issue or two....setting up the correct libraries etc. It often happens.
Be persistent. Be patient. And most of all, HAVE FUN!

Scott

Go to top


Re: Beta testing
Just popping in
Just popping in


Okay, here's what I've learned so far....

1) download QT4.7 from OS4 Depot. Decompress & Install it.

2) Run the QTprefs program in sys:prefs and set:
Native Menus (ON)
Native Dialogs (ON)
Native Paint engine (ON)
Native Fonts (OFF)

3) Add these files: .qmake.cache and .qmake.var from the link previously listed HERE to the root of the QT-4.7 directory.

4) Ensure that the qt-4.7/bin moc command has the execute bit set

5) Add the path command:
setenv PATH $PATH:/qt/bin
to the end of startup-sequence, save and reboot


To build a QT application;

a) open a shell
b) Set stack to 2000000
c) cd to the directory of your source code you want to build
d) type "qmake"
e) type "gmake"

At this point, I am getting an error when linking with the symbol "protected" as follows:

/SDK/newlib/include/sys/select.h:80: error: expected ',' or '...' before 'protected'
gmake: *** [imagewidget.o] Error 1

Your solution for this is: Solution: Just put an underscore in front of the word "signals", ie. "_signals". This you will have to do in three places (you will be told by the compiler where to look). (i.e. search your source for signals and change to _signals), then run qmake/gmake again!

You should now be able to build many QT applications.

Great work alfkil! This is awesome!

Scott

Go to top


Re: Is VOiP Available For AOS4?
Just popping in
Just popping in


Amazingly, the Amiga was perhaps the first home computer that did VOIP way back in the late 1980's, early 1990s...can't remember exactly. But there was an old VOIP programs on Aminet for Amiga OS2.0 which I used with great success. Probably won't work now with changes to protocols etc.
Similarly, I recall using a voice activated command program from Aminet or Fred Fish that allowed you to speak commands to your Amiga by plugging in a microphone to any one of several audio digitzers and you could tailor any command to any DOS command line in a script. Great stuff. I used to really freak out my MAC and PC friends by turning on my Amiga and just talking to it and having it open programs, or even speak back to me in return. Great times!

Scott

Go to top



TopTop
« 1 (2) 3 4 »




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project