Remember me

Lost Password?

Register now!
Who's Online
24 user(s) are online (6 user(s) are browsing News)

Members: 0
Guests: 24

Support us!
Recent OS4 Files
Recent Replied Topics
Topic Replies Last Post
AmigaOS4 Movie Collectors Database 6 (163) 1mouse Yesterday 22:11
Amiga Emulation RunInUAE r8 beta 4 (PPC JIT v1.0.0) [1][2][3] 48 (19406) nubechecorre Yesterday 21:21
AmigaOS4 GL4ES: another OpenGL over OpenGLES2 emulation - some tech. info and porting progress [1][2] ... [7][8][9][10] 193 (12129) kas1e Yesterday 18:51
AmigaOS4 How to use sgit? 6 (219) salass00 3/17 20:25
AmigaOS4 SDL1 open issues [1][2] ... [5][6][7][8] 141 (8286) Capehill 3/17 19:43
AmigaOS4 Can we use any C++11 features with the latest GCC? 3 (171) Hans 3/17 14:40
AmigaOS4 SDL2 [1][2] ... [19][20][21][22] 431 (90025) Capehill 3/17 10:16
AmigaOS4 Warzone 2100 Tutorial on AmigaOS4.1FE 5 (387) Younghippie 3/17 8:46
Odyssey OdysseyLauncher2 released [1][2][3] 43 (11208) Lio 3/16 21:52
AmigaOS4 Tower57 AmigaOS4 version out! [1][2] 24 (1238) Thematic 3/16 18:18
AmigaOS4 BOH ADVANCE Physical Copy and BOH Deluxe Box 2 (127) saimo 3/16 13:16
AmigaOS4 Simplemail 0.38 error Sending 2 (190) atom 3/14 18:13
AmigaOS4 AWeb 3.5.12 - AmiSSL 4.2 support 16 (734) white 3/14 6:08
AmigaOS4 yt.nsrx and netsurf beta 4318 7 (500) white 3/13 15:08
AmigaOS4 Strange crash [1][2] 21 (663) Raziel 3/10 18:56
[View all topics]  [Forum Settings]
Software News : AmigaAmp 3.12
Posted by Raziel on 2013/11/6 12:01:08 (986 reads) News by the same author
Software News

AmigaAMP 3.12 (OS4-NATIVE) released

Latest changes:

o Auto depth-arrange attached windows in skinned mode
o Revised window dragging routine in skinned mode
o Added cover display
o Added "FilePath" config option
o Changed loading of whole directories to pattern matching files only
o Big internal code change, switched unskinned main- and playlist-window to ReAction

Have fun!


Printer Friendly Page Send this Story to a Friend Create a PDF from the article
The comments are owned by the author. We aren't responsible for their content.
Author Thread
Published: 2013/11/6 13:21  Updated: 2013/11/6 13:21
Amigans Defender
Joined: 11/19/2006
From: Cambridgeshire, UK.
Comments: 2064
 Amiga Amp
Cool, Thanks for the continued effort in developing this nice music player, it has been developed for more years than I can remember, must be at least over 10 years, as I remember using it on my A1200T. Much appreciated
Published: 2013/11/6 13:30  Updated: 2013/11/7 6:07
Home away from home
Joined: 09/11/2007
From: Russia
Comments: 4462
 still problems with loading of directories

New "move" of windowses are cool. Through still some problems with loading of whole dirs. I.e. visually everything loads just fine, i see whole list in the playlist, but only first files are plays.

To reproduce, just put 2 any mp3 files in any directory. Then do open, and open that directory without going inside. It will load to play list both 2 files, but only one can (first) can be played. Non dbl-click on next one, non pressing on "next" button works. Like there is no second file, while playlist have it.
Published: 2013/11/6 14:44  Updated: 2013/11/6 14:44
Home away from home
Joined: 11/26/2006
From: A haunted Castle somewhere in the Bavarian Mountains
Comments: 2959
 Re: still problems with loading of directories

Works here without problems.

I even did your "2 files in a dir" test and still it works as expected.

Might it be a possibility that you copied a file that is corrupted and can't be played because of that?
Because the files itself (even broken) are always load into the playlist.
AmigaAmp will only see if it can be played when actually reading it in and trying to play.
Published: 2013/11/6 16:16  Updated: 2013/11/6 16:16
Home away from home
Joined: 07/07/2009
From: Toronto, Canada
Comments: 2229
 Re: AmigaAmp 3.12
thanks will try out tonight!
Published: 2013/11/6 16:59  Updated: 2013/11/6 16:59
Just can't stay away
Joined: 10/25/2007
From: Gothenburg / Sweden
Comments: 1175
 Re: AmigaAmp 3.12
Thanks for the update :)
Published: 2013/11/6 20:35  Updated: 2013/11/6 20:35
Home away from home
Joined: 11/30/2006
From: Norway
Comments: 2462
 Re: AmigaAmp 3.12
Just downloaded. :-D
Published: 2013/11/6 23:34  Updated: 2013/11/6 23:35
Just can't stay away
Joined: 08/14/2012
From: France
Comments: 1477
 Re: AmigaAmp 3.12
Works very well,
I just posted a question on your AmigaAmp forum about the eventual possibility to disable Ringhio notifications.

Thank you for this essential software.
Published: 2013/11/7 6:06  Updated: 2013/11/7 6:06
Home away from home
Joined: 09/11/2007
From: Russia
Comments: 4462
 Re: still problems with loading of directories

Tried again after hard reboot, and still have the same problem. Maybe related to what kind of settings i have, dunno. All what i do now its :

-- run amigaamp
-- press "open" gadget
-- go to "work:music/"
-- change "Keny_Arkana" directory which contain 2 working mp3 files.
-- winamp load them to playlist and show me both names, how long they are, etc.
-- trying to dbl-click on second one do nothing, pressing on "next" button play again first song.

While , if i just do that:

-- run amigaamp
-- press "open" gadget
-- go to "work:music/Key_Arkana"
-- and there mark those 2 files and press ok in asl request
-- both files can be played , both can be dbl-clicked, and pressing on "next" jump on next file as well.

Name of files are and full path are:

Published: 2013/11/7 10:22  Updated: 2013/11/7 10:22
Home away from home
Joined: 11/26/2006
From: A haunted Castle somewhere in the Bavarian Mountains
Comments: 2959
 Re: still problems with loading of directories

That indeed is strange behaviour :-/

Have you tried installing AmigaAmp to a new directory (fresh install)?
Maybe it has really something to do with your settings?
Published: 2013/11/7 13:26  Updated: 2013/11/7 13:26
Home away from home
Joined: 09/11/2007
From: Russia
Comments: 4462
 still same

Just download it again, unpack to ram, and run from : the same problems.
Published: 2013/11/8 7:53  Updated: 2013/11/8 7:53
Home away from home
Joined: 11/26/2006
From: A haunted Castle somewhere in the Bavarian Mountains
Comments: 2959
 Re: still same
Sorry, i'm out of ideas

You might want to contact the author
Published: 2013/11/15 18:12  Updated: 2013/11/15 18:12
Just popping in
Joined: 10/23/2013
From: Kuusamo, Finland
Comments: 82
 Thank You
Thank you for this new version.
For me this new version works without problems
Published: 2013/11/17 10:42  Updated: 2013/11/18 20:31
Just popping in
Joined: 02/15/2012
Comments: 86
 Crashing on greek filenames
Nice to see frequent updates!
I`m currently using an older version (v3.6) due to file handling errors as I posted some time ago.
The current version pops up a Gurumeditation error the moment I drag&drop a file with greek characters in file name & Tag. The older versions behaviour is described in my previous post.

I temporarily resolved the issue by unticking the "ID3 Tag reading". No more crashes but seems to be a bug there.
Published: 2013/11/21 10:17  Updated: 2013/11/21 10:17
Just popping in
Joined: 02/21/2009
Comments: 50
 Re: still problems with loading of directories
Hi, I've found a bug in the directory loading routine that trashes some of AmigaAMPs internal memory.

This might explain the strange behaviour -- works in some case, fails in others.

I'm about to release a patch.
Site sponsors
Advertise Here

Site statistics
Registered members
Logged in last:
  24 hours, 55
  7 days, 95
  30 days, 146
Top Posters
1 kas1e   kas1e 4462
2 ChrisH   ChrisH 3508
3 Chris   Chris 3195
4 orgin   orgin 3116
5 samo79   samo79 3017
6 Raziel   Raziel 2959
7 LiveForIt   LiveForIt 2676
8 Antique   Antique 2462
9 328gts   328gts 2229
10 Mikey_C   Mikey_C 2064
New Members
flash   flash 03/01/2018
Lord76   Lord76 03/01/2018
a2x   a2x 02/26/2018
icbrkr   icbrkr 02/24/2018
shift838   shift838 02/23/2018
Lord   Lord 02/23/2018
Some-E   Some-E 02/20/2018
remotenemesis   remotenemesis 01/20/2018
dooz   dooz 01/16/2018
frederick   frederick 01/14/2018
Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project