Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
50 user(s) are online (35 user(s) are browsing Forums)

Members: 0
Guests: 50

more...
Support us!
Recent OS4 Files
OS4Depot.net
Report message:*
 

Issue with QT on X1000 [Solved]

Subject: Issue with QT on X1000 [Solved]
by Epsilon on 2014/4/3 22:11:21

Hi All,

At the moment on my X1000 I am struggling and somewhat frustrated with Qt, which is not working at all since the move from SFS to NTFS partitions (note I didn't use NTFS for the system partition - it is still running SFS as before).

More detail on what i did with the partitions is here on my blog if you need more detailed info:

http://amigax1000.blogspot.com.au/201 ... ith-sata-hd-on-x1000.html

I deleted Qt on the NTFS partition, commented out the Qt assign references in user-startup, rebooted and then reinstalled Qt on the system drive (SFS) which went ok, but no go to run any Qt apps. (and yes, I did put the dir SOBJS: >NIL line into the right place in user-startup..)

Qt Apps still say they can't find the lib#? .so objects they need, even though they are there (I checked the folder location) and referenced correctly as before, when it was working.

Btw I should also mention that the drive names changed for programs already installed when I moved everything to the new disks (from DH0: to HD0:, DH1: to HD2: in my case).

AmigaOS4 does not know about the changes to non-system disk files (as you would expect). I had already updated the relevant startup files to reflect the drive name change where needed prior to booting off the new disks for the first time. No errors on boot. (just to cover this off)

However in AmigaOS4.1 I note that it now uses a sys:prefs/env-archive/AppPaths folder to track any program locations across the various partitions when they are run. However, this only updates the location when an application is run. So I believed it is probably necessary to manually update each entry to reflect the new location, as the only other way is if you plan to run them all in turn to update the location. (Yes, I did this manual update last night including the Qt Apps referenced - took ages). Maybe there is another quicker way...but doing this had no effect on fixing Qt Apps though.

I am also curious if this app path information is used by AmiUpdate to work out what apps are installed to determine updates needed?

I am thinking about adding an assign in startup-sequence for DH0 to HD0, DH1 to HD2 to see if it cleans things up for Qt, which if it does would prove if something critical is still referencing to the old location. Since I reinstalled Qt from scratch using the new drive names, I can't imagine this would be affecting things, but you never know...

Please let me know if you have any other ideas on what else I can do to resolve this Qt issue? Appreciate any help.

Catcha,
Epsilon



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project