Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
75 user(s) are online (54 user(s) are browsing Forums)

Members: 0
Guests: 75

more...
Support us!
Recent OS4 Files
OS4Depot.net
Report message:*
 

Re: NetSurf development builds

Subject: Re: NetSurf development builds
by KimmoK on 2012/10/17 17:23:35

Just re-checked. I have 2.8 installed.
AmiUpdate always tries to update netsurf, same today.
It loads files ok, install "looks like" it progress ok.
No errors. Update complete.

But I still have 2.8 installed.

au.log
...
20:40:08 Starting file download (6142996 Bytes)
20:40:08 Trying to connect to: flounder.pepperfish.net on port: 80
20:40:08 Connected
20:40:35 Transfer of file 'netsurf-2.9.lha' complete
20:40:35 Preparing to unarchive: netsurf-2.9.lha
20:40:39 Archive unpacked successfully
20:40:39 Trying to locate AutoInstall script..
20:40:39 'AutoInstall' script detected, preparing RollBack...
20:40:40 Executing AutoInstall script...
20:40:42 Script completed without errors
20:40:42 Cleaning up working directory...
20:40:42 Cleaned up without errors
20:40:42 Update finished
20:40:42 Checking for other entries in the same archive...
20:40:42 None found
20:40:42 Deleting working directory...

None of the files in internet/netsurf have changed.
Amiupdate sees that netsurf still needs updating, easy to redo...
I saw that extracted folder was present in RAM but got deleted... perhaps just the netsurf install script is broken...
Adding more debug log ...
And told au to leave the downloaded archive in ram...

autoinstall command:
; AmiUpdate AutoInstall for NetSurf
cd NetSurf
Installer Install APPNAME NetSurfAutoInstall DEFUSER NOVICE

NS_install.tmp:
1 ;BEGIN NetSurf
2 ClientName="NETSURF" ClientPath="APPDIR:NETSURF" CMDFORMAT="URL=*"http://www.%s*""
3 ;END NetSurf

Then I manually extracted netsurf. And tried it's installer in intermediate mode... it worked (did not have to change any parameters). (had no time to test further)

Perhaps the problem is with novice/automated install mode
Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project