Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
60 user(s) are online (36 user(s) are browsing Forums)

Members: 0
Guests: 60

more...

Headlines




(1) 2 3 »


APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
In attempting to install the modules required for APod on "make" I get the following.

gmake:no rule to make target 'DYNAMIC' needed by linktext

With thanks

   Report Go to top

Re: APod - modules
Quite a regular
Joined:
2006/11/27 14:35
From Nantes, France
Posts: 869
Your makefile is faulty or incomplete.
It seems make is trying to build something called 'DYNAMIC' but can't find any rule to make it.

_________________
Back to a quiet home... At last
   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310
Which version of Perl do you have installed?

Which modules fail?

Are you trying to update the archives to newer versions? As I remeber I bundle prebuilt modules with the aPod archive. It's along time since I looked at it!


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
Not near my Sam at present, will answer your questions tomorrow.

Thanks for your assistance

   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
Version of Perl Perl5.8.5

It occurs with the following

Audio-Wav-0.05
MP3-Info-1.20
XML-Parser-2.34
Unicode-String-2.09

Regards

   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310
Quote:

Version of Perl Perl5.8.5


Could you do

list SDK:Local/C/perl

just to make sure you have the latest version (which is quite old )

you should get


New Shell process 11
11.AmigaOS4:> list sdk:local/C/perl
Directory "sdk:local/C" on Saturday 03-Sep-11
perl 2130268 ----rwed 20-Oct-06 04:06:50
1 file - 2080K bytes - 4162 blocks used
11.AmigaOS4:>



_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310

@Cara

I've uploaded a fix to perl which deals with some issues and changes that have occured since perl was ported.

It's in the upload queue at os4depot at the moment

http://os4depot.net/index.php?function=uploads

If it's gone from there then look for the package "perlpatch.lha"

Follow the intructions in the README very carefuly, then try and build your modules again.

Hopefully that time it'll work.


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
@ broadblues.

Thank you for the upload, will let you know how I get on.

Many Thanks

   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310
Made a small fix the to instruction in the README for this patch.

Please make sure you follow the instructions in version 1.1 of the patch.

Will be nice to hear back on whether it works for you ....


Andy

_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
@ broadblues

After installing the Perl update.
Results were as follows.

Audio-Wav-0.05 is Good.

MP3-Info-1.20 is Good.


Unicode-String-2.09

Has the following:

/SDK/newlib/include/sys/signal.h:34:1: warning this is the location of the previous definition.

/SDK/Local/clib2/lib/perl5/5.8.5/pcc-amigaos/CORE/amigaos.h:29: error: expected '=', ',', '.,', 'asm' or '-attribute-' before 'constructed'
gmake *** [string.o] error 1

XML-Parser-2.34

Has the following:

/SDK/newlib/include/sys/signal.h:34:1: warning this is the location of the previous definition.

/SDK/Local/clib2/lib/perl5/5.8.5/pcc-amigaos/CORE/amigaos.h:29: error: expected '=', ',', '.,', 'asm' or '-attribute-' before 'constructed'
gmake *** [expat.o] error 1

gmake [1]: leaving directory '/work/audio/apod/xml-parser-2.34/Expat'
gmake: ***[subdirs] error2

Best Regards

   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310
Er that's odd, that exactly the issue the patch was design to fix.

Gcc is trying to use newlib when it should be using clib2 for perl modules.

Can you post the entire output from one of the two failures.

Also please do

List SDK:local/clib2/lib/perl5/5.8.5/ppc-amigaos/Config.pm

You should get

Directory "SDK:local/clib2/lib/perl5/5.8.5/ppc-amigaos" on Tuesday 06-Sep-11
Config.pm 32227 ----rwed Saturday 17:27:18
1 file - 31K bytes - 64 blocks used
4.AmigaOS4:>

If you don't you may not have installed the patch correctly.



_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
@ broadblues

All four modules are now installed.

Checked config.pm as you mentioned, I had not installed the update. See where I went wrong. On using the command "copy" as there was no error shown I took it that all was well and the files had being installed. Nothing had being installed, protect was in use.

After entering the protect lines you included in your readme the issue was resolved. Will finish the rest tonight.

Many thanks

   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310
Okay.

Odd that copy didn't report and an error, but at least you've got the files installed now.

Before using aPod I recomend makeing a backup of your iPod.

In fact you can test out aPod on the backup by setting the "mount point" of the iPod to the backup copy on your hardrive.


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
Finding the following with Apod:

global symbol "$version" requires explicit package name at apod line 27

BEGIN not safe after errors--compilation aborted at apod line 76

regards

   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310
Uhg there a trivial error in that version which noone ever reported! Maybe they just fixed themselves or just dumped it without giving any feedback.

So in your case thanks for reporting it!


You can fix this by editing line 15 of the apod file

Change
use vars qw $help  $mntpnt $itunes_db $gnupod_db $ipod $drawer $changed @songs


to
use vars qw $version $help  $mntpnt $itunes_db $gnupod_db $ipod $drawer $changed @songs


ie add the word '$version' to the list

In the mean time I have version 1.2 sitting here on my SAM which has some extra functionailty, I'll release it as soon as I can....




_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
@ broadblues

Will edit it tonight. Thank you

Apod Ver. 1.2

regards

   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
Have the following

Could not open IPOD:/iPod-Control/iTunes/iTtunesDB at line 1347

As my settings in .apordc might well have a bearing,

For mountpoint I have tried both of the following:

$=mntpnt_rc = "/work/audio/mp3";
$=mntpnt_rc = "/ipod";

also have

$ itunes_db.rc="IPOD:iPod_Control/iTunes/itunesDB";

Have created Control/.gnupod/ directory.

With thanks

   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310
apod look for the default config file in

apod:.apodrc

so you you can add an assign 'apod:' to the location of the aPod directory or do

perl apod --config .apodrc

Checking the version at os4depot I see there is a bug on line 55 where it says

$mntpnt = 'IPOD:' unless ...

it should say

$mntpnt = '/IPOD' unless

This is fixed in 1.2

1.2 requires an update to a few modules etc so I can't just send you the script, I'm on tour in France till after the weekend (three gigs in the south fri sat sun ) I'll do my best to get an archive togther after that.

BTW what kind of iPod do you have?

I've only tested this with a G3 version, which is a little old now.

As I said I do recomend you backyour iPod up before trying this. Also the iPOd needs to be vfat formated (Windows Ipod rather than Mac)

Thansk for persisting with this!


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: APod - modules
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
@broadblues

Thank you for your reply.


Will wait for the release of apod ver 1.2

Enjoy you holiday and the gigs, sound good , real good. Give the computer a holiday.

Regards

   Report Go to top

Re: APod - modules
Home away from home
Joined:
2006/12/4 23:15
Posts: 2310
Just in the process of uploading aPod version 1.2 to OS4depot it should appear in the upload queue soon I hope, although, the uploads is going very slowly for some reason.

This version has extended support for MP4 files and comes packaged with the latest ersiosn of all dependant modules, and even better is has an installer script which takes care of all the module installation for you. (Modules have been prebuilt)


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top


(1) 2 3 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project