Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
92 user(s) are online (73 user(s) are browsing Forums)

Members: 1
Guests: 91

TiredOfLife, more...

Support us!

Headlines




(1) 2 3 »


NetSurf2.0(dev) Bugs Thread
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
Firts of all, thanks Chris for the beta, awesome to be able to test the port

I do know it has many flaws still, and i'd like to give a
better report, unfortunately i can only say it locks up with
a certain webpage, but this reproduceable.

Go to http://www.scummvm.org, let the page load until finished
(it won't display anything though, seems it already broke while
loading) and click anywhere on NetSurf's window (resize-gadget e.g.),
it will completely lock up my system.

Keep on, mate, thats a great project your on there


Edited by Raziel on 2008/8/24 10:55:46
_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
@Raziel

Copy&Paste from the menu, will DSI crash my system
Crashlog: http://crashlog.os4depot.net/cl61

Edit: Fixed erroneous link

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
@Raziel

Preview and Quote button here on amigans doesnt seem to be clickable!?

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
@Raziel

After some surfing in the same window with different sites (e.g. try amigans.net, read posts,
go to amigaworld.net, read posts and head back to amigans.net) makes CSS(?) the site
layout go crazy, unreadable sometimes

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Quite a regular
Joined:
2007/7/23 21:35
Posts: 656
On Amigaworld the home page is fine
Clicking on forum pages seems to be a problem for me.
Page shows up until it's completely loaded.
Then most of the page disappears.
After that pages on any site are similary affected.

I have an issue when posting on Amiga.org.
Page displays fine but the submit button is missing.

   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Supreme Council
Joined:
2006/11/16 19:25
From Sweden
Posts: 3188
@Raziel

> Preview and Quote button here on amigans doesnt seem to be clickable!?

No javascript remember? :)

_________________
Vacca foeda. Sum, ergo edo

Mr Bobo Cornwater
   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Not too shy to talk
Joined:
2006/12/8 18:02
From Germany
Posts: 391
@Chris
Wow, really nice Browser, good work.

NetSurf does not display the german umlauts correctly in the Hotlistmenu and probably in all Reaction parts of NetSurf, the Webpages dont have this problem.

   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
@orgin

Oi, stupid me ... hm, that makes it pretty hard to nail
bugs down that does NOT rely on JS, doesn't it?

Anyway, http://www.hd-rec.de crashes with a DSI error (which
can be Ignored) after opening lots of windows and draws the
site displayed rather unuseable due to it's ripped apart
windows
http://crashlog.os4depot.net/cl62

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3245
@all

Up and down cursor keys don't work in these forms either (just spotted that one!)

the amigaworld issue is known, but it's an odd one. Scrolling down the forums, it seems to be certainly posters who cause the display to go wrong, once you get them off the screen the page reappears correctly. It does upset other sites visited afterwards though so I suspect it's trashing memory somewhere along the line.

It seems to be related to the avatars so if anybody can narrow it down that will be very useful.

@TiredOfLife
Scroll down the page until the smileys are off-screen and it will appear (same issue as above)

@ZeroG
Oops, UTF-8 conversion I missed (the form popups aren't converted either yet)

   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Not too shy to talk
Joined:
2006/11/29 21:59
From Croatia
Posts: 325
@Raziel

I just put my crash log on OS4Depot

http://crashlog.os4depot.net/?function=view&crashlogid=64

_________________
A1200 sandwich

uA1c AmigaOS4.1 Final + upd #1 + 512 mb

MacMini 1.5 1GB MOS 3.9
Warp - Croatian Amiga portal
   Report Go to top

Re: NetSurf2.0(dev) bugs thread
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3245
@Raziel

hd-rec crashes when setting the vertical scroller (1121), I'd hazard a guess that the page is so large that the value being passed to the scroller is out of range. I've seen crashes on other large pages too so this seems likely.

scummvm gets netSurf to output the following:
assertion "block->type == BOX_BLOCK || block->type == BOX_INLINE_BLOCK || block->type == BOX_TABLE_CELL" failed: file "render/layout.c", line 190

This looks like a NetSurf core problem rather than something I've introduced, so I'll post on the ml about that.

Lastly, copying text - what are you trying to copy? does it do it all the time? this crash is occuring in the function that writes the text to the clipboard (rather than any of the setup) so I'll need a reproduceable test case for that one.

edit; don't worry, I've found and fixed the clipboard problem.

Chris


Edited by Chris on 2008/8/24 12:41:42
   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Just popping in
Joined:
2008/3/1 9:53
Posts: 138
Chris, good work! I've tried Netsurf, I'm remained surpriced :)
bravo :)

- www.amigapage.it are bad visualized and links are blue(?!?) ;

- it seems shift modifier doesn't work good, just try and see you have to press shift for a more time to motify a button behaviour;

Fonts are too less;

100% CPU usage ((

Thanks in advance :)

   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Just popping in
Joined:
2008/3/1 9:53
Posts: 138
@ShInKurO

My site is bad visualized :9
http://shinkuro.amiga.it

-missing whell mouse support

   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3245
@VooDoo

Go to http://www.masonicons.de and download AISS - update it if you have it already.

If that doesn't solve it, can I ask which release of OS4 you are using? I haven't tested on anything other than the AmigaOne July update.

I forgot to say, but it only works on 32-bit screen modes, If your graphics card doesn't support that then it probably won't work (and will exit with an error) - however the crashlog looks like it has passed that point.

   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Not too shy to talk
Joined:
2006/11/29 21:59
From Croatia
Posts: 325
@Chris

I have last AISS 4.2 installed..and now again install it,try in 32bit mode but the same..grimreaper is here :( no lucky for me :(

Using uA1c 256mb OS4 with last update!

_________________
A1200 sandwich

uA1c AmigaOS4.1 Final + upd #1 + 512 mb

MacMini 1.5 1GB MOS 3.9
Warp - Croatian Amiga portal
   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3245
@ShInKurO

There are various bits of CSS that aren't implemented in NetSurf yet, and various bits of graphics plotting functions that aren't implemented (or aren't working, in the case of tiling images) in my port yet.

What are you trying to do with shift? It's not being sent through to NetSurf yet, except in the case of forms. You can open links in new windows with the middle mouse button.

Minimum font size can be changed by opening Resources/Options in notepad and searching for font_min_size (there's also font_size which you'll need to add to the file, but modify that at your own risk!)

100% CPU usage is because it doesn't Wait() - it seems to want to go off and do other things which prevented me from doing this. I need to revisit it as it could just be the scheduler. It's very much on my list.

   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 683
@Chris
Great work.

I have a 100% CPU work when netsurf runs.
Also, on this website (http://www.in.gr) a window pops up with no close object.

Keep up the good work

   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3245
@VooDoo

hmm, i've just examined that crashlog again, and I think it's requester.class that is crashing.

I think there's a way of changing the default images it uses - i don't suppose you have done that?

Try extracting this file to your NetSurf/Resources directory.

Attach file:


zip hotlist.zip Size: 0.00 KB; Hits: 65

   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3245
@walkero

That's the slightly iffy frames support.

chris

   Report Go to top

Re: NetSurf2.0(dev) Bugs Thread
Not too shy to talk
Joined:
2006/11/29 21:59
From Croatia
Posts: 325
@Chris

Unpack this file in NetSurf dir..reset Amiga..try run it but the same..GR is again here :(

_________________
A1200 sandwich

uA1c AmigaOS4.1 Final + upd #1 + 512 mb

MacMini 1.5 1GB MOS 3.9
Warp - Croatian Amiga portal
   Report Go to top


(1) 2 3 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project