Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
95 user(s) are online (80 user(s) are browsing Forums)

Members: 0
Guests: 95

more...

Headlines






Bug in MultiEdit - Bug submitted, anyone else reproduce?
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 394
I just submitted the following bug with MultiEdit. Is anyone else able to reproduce this issue? (Version 2.9)

Summary:
0000792: MultiEdit - Copy from seperate document and pasting into MultiEdit changes position in the document

Description:
If I copy a line from an application other than MultiEdit and paste it into a docuemnt loaded int MultiEdit, the position in the MultiEdit document jumps to a location other than where the line was pasted and you can no longer see that pasted line.

Steps To Reproduce:
1. Load the OpenSSL.doc comument from the documentation directoy on the Sys: partition. Do not click inside the MultiEdit document.

2. Load a document into NotePad and copy a single line into the clipboard. (I used the Workbench-ARexx.doc document.)

3. Scroll to the bottim of the MultiEdit document using the slider.

4.Click left mouse button at end of document, then use right mouse button and paste (from pop up menu) the cut line after the last line in the document.

Notice that when you paste the line into the document the position within the MultiEdit jumps up within the docuemnt so the pasted line is no longer displayed. You have to scroll back down in the document to see the pasted line. This is very annoying and makes the editor difficult to use for copy and paste work. Note that you do not necessarly have to paste the line at the very bottom of the document for this to occurs. This will now occur every time you paste a line in the document.

Notice that copy and paste sometimes does work properly without changing position. I think this might have to do with clicking inside the MultiEdit document before you try to paste. That's why I said to not click within the document before trying to cut and paste.


Edited by ktadd on 2021/6/7 23:09:21
_________________
AmigaOne X1000, uA1
   Report Go to top

Re: Bug in MultiEdit - Bug submitted, anyone else reproduce?
Just can't stay away
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 1258
@ktadd

I haven't tried your procedure, but I'm just wondering while reading it:

If you don't click anywhere in the first file (MultiEdit), I assume your text cursor will be at the start of the file. When you then paste, won't it be pasted there? So if you have scrolled the display, but not moved the text cursor, isn't it natural for the display to scroll back where the paste is done, i.e. the start? At least that's what I would expect.

Or do you mean that in step 4, you actually click into the document at then end before pasting there? If so, yeah, I'd expect the display to stay there.

Best regards,

Niels

   Report Go to top

Re: Bug in MultiEdit - Bug submitted, anyone else reproduce?
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 394
@nbache
Quote:
Or do you mean that in step 4, you actually click into the document at then end before pasting there? If so, yeah, I'd expect the display to stay there.

Yes, that's what I mean. Left click at bottom of page then use right mouse button and paste from pop up menu.

Thanks for asking and helping me make it clear. Updated step 4 above.

_________________
AmigaOne X1000, uA1
   Report Go to top

Re: Bug in MultiEdit - Bug submitted, anyone else reproduce?
Home away from home
Joined:
2006/12/4 23:15
Posts: 2284
Just on the way out, so can't do any tests myself, but to be clear, once you have clicked, is you cursor now at the end of the document? And is the pasted text added where you would expect (irrespective of how it displays?)

Is the horizontal scroll option enabled?


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Bug in MultiEdit - Bug submitted, anyone else reproduce?
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 394
@broadblues
Quote:
Just on the way out, so can't do any tests myself, but to be clear, once you have clicked, is you cursor now at the end of the document? And is the pasted text added where you would expect (irrespective of how it displays?)

Is the horizontal scroll option enabled?

Thanks for the response.

Yes, I click at the end of the document before pasting and the text is added at the end of the document as expected. The Horizontal scroll is not active.

Made a quick video: (manually set player to 720p for good quality on Amiga)
MultiEdit_Paste_Issue_Video

_________________
AmigaOne X1000, uA1
   Report Go to top

Re: Bug in MultiEdit - Bug submitted, anyone else reproduce?
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7041
@ktadd
Some time ago i reported another issue about "jump of the text", check this out plz: http://www.amiga.org/developer/bugreports/view.php?id=477

Maybe it has the same roots?

EDIT: watching your video, yeah! Looks like about the same kind of issue!

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Bug in MultiEdit - Bug submitted, anyone else reproduce?
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 394
@kas1e
Quote:
Some time ago i reported another issue about "jump of the text", check this out plz: http://www.amiga.org/developer/bugreports/view.php?id=477

Maybe it has the same roots?

I reproduced this and yes. It looks like a very similair issue. I'd guess it's the same root cause.

_________________
AmigaOne X1000, uA1
   Report Go to top





[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project