Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
111 user(s) are online (91 user(s) are browsing Forums)

Members: 0
Guests: 111

more...

Headlines




« 1 2 (3) 4 »


Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
@Rolar

If Radeon hdmi audio works for you under linux (X5000) then this card should work too. They are both HD audio and use the same linux driver.

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
5/13 6:34
From France
Posts: 4
@geennaam

>If Radeon hdmi audio works for you under linux (X5000) then this card
>should work too. They are both HD audio and use the same linux driver.

Yes, hdmi audio works, but at least earlier many intel Linux users have reported problems to get that card really working instead of the hdmi one. I do not know what is the situation with latest kernels... So, I hope someone using X5000 and the Audigy card can confirm this!

BTW, would it be possible to use the hdmi audio also with your driver, under AmigaOS?

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
@Rolar

I see reports that it is working with x86 linux distros. Some users with problems simply forgot to unmute the card.
Never tried linux on ppc so I'm not sure how mature that is.

But the audigy FX is nothing special. So there should be no reason why it shouldn't work.

Quote:
BTW, would it be possible to use the hdmi audio also with your driver, under AmigaOS?

No, but that has a different reason.

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
5/13 6:34
From France
Posts: 4
@geennaam

In this thread there were more complicated problems than just having forgotten to unmute the card:

https://www.linuxquestions.org/questio ... gy-fx-to-work-4175505881/

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
@Rolar

That's an old thread. Bug then again, the current X5000 version may be older.

Can you point me to the linux distro that you intent to use?

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2020/3/29 14:21
From Finland
Posts: 53
@geennaam
>Can you point me to the linux distro that you intent to use?

There are currently only three distros which are still updated and usable in X5000:

- MintPPC (which is best kept up-to-date)
http://mintppc.nl/

- Fienix (which is the most Amiga-friendly as the keeper has X5000)
https://fienixppc.blogspot.com/

- Ubuntu 16.04 (only minor updates, this will soon be unsupported)

But the kernels for X1000/X5000 are common for all distros, and they are very well kept up-to-date, thanks to the work of 'xeno74' (see https://forum.hyperion-entertainment.com/viewforum.php?f=58).


Edited by Gregor on 2021/7/5 21:40:22
   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
@Gregor

HDA driver is part of the kernel. So that's good news. I'll try Fienix tomorrow.

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
@Gregor

Unfortunately, Fienix halts after Loading the device tree.


Edited by geennaam on 2021/7/6 18:16:25
   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 4195
@geennaam

You're not alone.
Never got fienix running on my x1000

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2020/3/29 14:21
From Finland
Posts: 53
@geenam @Raziel

Do you have an account at the Hyperion's site? The Linux fora there would be the best place to solve Linux issues.

BTW, I hope you do not have a RX graphics board....? They are unfortunately not supported in PPC Linux, so you cannot get the desktop loaded if you have one.

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2017/10/28 11:03
From Netherlands
Posts: 147
@Gregor

You might be able to just use the FBDEV in XORG to use your graphics card.

All Southern Island cards (and beyond) are not supported in PPC Linux.
I use the FBDEV with my Linux distros.


_________________
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
@Skateman

Radeon HDMI audio will not work with the framebuffer driver. Both the HDA driver and Radeon driver are needed for that.

Tried a Radeon HD4850 today. But this results into the black screen.

So bad luck.

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2020/6/30 1:08
From United States
Posts: 46
@DStastny

Driver works great with the card you mentioned. Only thing missing is the digital outs, i would like to have the toslink at least for my soundbar. Another thing the stability of my Sam460ex has improved drastically when i swapped the Esi Juli@ out. Cant believe how much fun it is now. I still have some testing to do. The card comes with a header for the front mic in and headphones, if possible could that be included somehow? Thank you so much for the good work geennaam .

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2020/11/5 3:55
From Älvsbyn, Sweden
Posts: 21
@devils_advisor

agree, but mine didn't come with the breakout (daughter)
board

does this ahi driver need a new midi driver too or does the audigy emu10kx work with these ones too? (probably not!)

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just can't stay away
Joined:
2009/5/1 18:57
From Czech Republic
Posts: 1310
@beanbandit

Quote:
does this ahi driver need a new midi driver too

I would recommend that you use the USB MIDI driver instead and connect your MIDI gear via a USB MIDI interface (such as the M-Audio MidiSport). USB MIDI is well tested and reliable under OS4, and will give you better connection options than the MIDI port on a soundcard.

_________________
The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
@beanbandit

No need for a driver.

These kind of cards do not have a wave table nor a MIDI connector.

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
New version uploaded to os4depot:

Changelog:

6.8: (12 Jul 2021)
- Added Output selection (ALL, Line, Front HP, S/PDIF)
- Added S/PDIF out support ( Both RCA and Optical)
- Added Output Mute support (Mutes Line, Front HP, and S/PDIF)
- Added Line In and Microphone Pre-Amplifier support. (From a CODEC perspecitive, Line In and MIC are equal. So Pre-Amps can be enabled for Line In as well)
- Speed improvements
- Small Bug fixes

Note:
AHIRecord allows you to select a monitor output. This is a weird implementation because in reality it makes an AHI request to change the playback output. This would require a digital loop. But that's not implemented in AHIrecord.
Since playback output selection is now implemented, you control the playback output for the next playback cycle this way. So beware.
The internal monitor hardware provides an analog loopback to a small selection of outputs. The Sound Blaster Audigy FX is limited to Front HP and Line outputs.
The CM8828+CM9882 cards are limited to Line out only. So you cannot use the HD audio front panel output as monitor output
AHI doesn't have a provision to change to monitor input. Just the monitor volume. So all monitor outputs are enabled. But if there's a demand for a single monitor output, I can add a mute option for the other individual outputs.

   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just can't stay away
Joined:
2009/5/1 18:57
From Czech Republic
Posts: 1310
@geennaam

Great progress! Can we paypal you a small donation?

_________________
The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 4195
@geennaam

Are you still thinking about supporting the HDAudio codec from the X1000 series?

I'd love to test and to have another option for a sound driver (especially one that is still maintained and enhanced).

Device: 0x4383 Rev: 0x00 (SBx00 Azalia (Intel HDA))
Vendor: 0x1002 (Advanced Micro Devices, Inc. (AMD/ATI))

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: First user's report of new Intel HD Audio (Azalia) driver by geennaam
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 184
@Raziel

To be honest, my motivation is fading away quickly. It took me a month to find the right motivation to do one day of work on this driver to create 6.8.
I've seen negativity, bitterness and zealotism (close to religious fanatism) when it comes to OS4. Not only on amigaworld.net and other sites/chats, but recently on this site as well.

I still cannot comprehend what's going on in the minds of those who rather wait for nothing to happen at Hyperion than to embrace any OS4 progress from whomever it comes from. This is not normal. The OS4 community is broken beyond repair imho.

It makes me sad. Embarrassed even to those who still put in time, effort and money to make the best of it. Especially when the future of OS4 is in limbo for quite some years now.

So why spend my precious spare time on anything other than my own needs. I'd rather spend it with my family instead.


   Report Go to top


« 1 2 (3) 4 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project