Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
39 user(s) are online (20 user(s) are browsing Forums)

Members: 1
Guests: 38

billyfish, more...

Support us!

Headlines




« 1 ... 4 5 6 (7) 8 »


Re: New Sam460cr boards will hit the road soon!
Quite a regular
Joined:
2014/6/29 15:12
From Montserrat
Posts: 500
@geennaam

Only A-Cube might have run Cow3D-Nova on a SaM440ep before yourself.

_________________
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Quite a regular
Joined:
2007/7/23 21:35
Posts: 711
@geennaam

Good going, i'm sure there will be a few people interested in your results.

Cheers

   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Quite a regular
Joined:
2014/6/29 15:12
From Montserrat
Posts: 500
@TiredOfLife

I have referenced this thread in my old thread on Amigaworld.net

_________________
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 151
@Spectre660

Spencer trail first level runs between 30-36 fps at 1920x1080.

Warp3D-SI drivers runs fine as well. Shogo is very playable at 1920x1080.

Cow3d improved to 223fps. Even on a 3440x1440 workbench screen.

Ragemem gives only 23 MB/s read/write from/to gfx memory.

Noticed some stabity issues. Seemed related to ethernet. But it could also be my test setup. Graphics card didn't fit into the small case so it was outside the case. Will share a photo of the frankenstein setup tomorrow.

This ends my test. R9 270X returned to the X5000.






   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Quite a regular
Joined:
2014/6/29 15:12
From Montserrat
Posts: 500
@geennaam

Nice going.

Your Spencer FPS is beter than what I was getting with an X5000/20 and an Oland based card some years ago.

X5000/20

ASUS R7-240 (Oland) = 22-23 fps
PowerColor R7-250X (Cape Verde) = 64-69 fps
ASUS R9-270X (/Pitcairn/Curaçao XT)= 72-80 fps
Sapphire Rx 550 4Gb (Polaris 12) = 95-109 fps
Asus Rx 560 4GB (Polaris 11) = 128-161 fps


Sam460ex

Sapphire Rx 550 4Gb (Polaris 12) = 25-37 fps
PowerColor R7-250X (Cape Verde) = 34-44 fps
Asus Rx 560 4GB (Polaris 11) = 34-46 fps

_________________
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Not too shy to talk
Joined:
2006/12/2 0:31
From Poland
Posts: 323
Maybe it is better to continue about SAM440 in this thread...

https://www.amigans.net/modules/xforum ... php?topic_id=8370&start=0

_________________
Sam440 flex 800MHz RAM 1GB R9250 128MB OS4.1 SBLive! ->
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7016
@All
And "CoolerMaster MASTERBOX NR200P [MCB-NR200P-WGNN-S00] White" is the 100% winner! Very small (not slim, but very small), video card fits very well vertically, 3 more horizontal slots (exactly good for Sata and audio card), coming with Riser cable, full of additional stuff (like fans which I of course will not install), strained glass, real metal with no plastic. And sam460cr fits very-very well in! Without the need for additional work.

There are some images (click on them for full size ones):

Case

Resized Image Resized Image Resized Image

Matherboard inside

Resized Image Resized Image


Riser

Resized Image Resized Image Resized Image


Vertical GFX setup (RadeonRX 560)

Resized Image Resized Image

Resized Image Resized Image

Back

Resized Image




Edited by kas1e on 2021/4/18 18:40:16
_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Just popping in
Joined:
2006/12/6 12:05
From Beverland
Posts: 151
@kas1e

Nice case

I've send you a pm with a link to the new HD audio driver with cache coherency fix for SAM boards.


   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7016
@geennaam

Thanks! Got it, but sadly will be able to test it only after a week (going to other place today :( )

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Just popping in
Joined:
2019/12/31 15:27
From Sweden
Posts: 70
@kas1e

Cool that the riser cable is included. I might get a case for my Sam460ex. You paid about €100 (without SFX-PSU)?

   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7016
@arfcarl
Quote:

Cool that the riser cable is included. I might get a case for my Sam460ex. You paid about €100 (without SFX-PSU)?


Yeah, cost me 90 Euro for the Case and about 50-60 Euro for SFX-PSU on 550W. If sam460ex is the same size as sam460cr, then it will fit surely. If it bigger, then chances high that it will not.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7016
@All
Start to assembly my sam460cr, and have some more questions:

1.

That one fixed. Was about issues to have 3 USB devices connected at one time (mouse, keyboard, and USB stick to boot from). While experimenting finds out that if you want to boot when USB stick in the motherboards USB ports, it works only when you put the USB stick to 1st slot, and keyboard to the second. Not another way around.

But then when I just connect mouse and keyboard to mother board's port, and a USB stick to one on front panel connect to JP12 via USB3<->USB2 adapter (as I have USB3.0 cable coming with Tower, so had to use an adapter) - then all fine, I can boot from USB-stick, and have both a USB mouse and USB keyboard working as well.

There is also very easy to made a mistake to how to connect it to JP12/JP13, even if it pointed out where pin1 placed, so to reference later there is how it should be:

http://4.bp.blogspot.com/-s_Tc-PcHKyM ... JWp75U/s1600/IMG_7108.JPG

2.

The second question still valid: I attached SSD, to the first slot of that expansion SATA card. Then when I boot just with keyboard and USB-Stick to amigaos4 installation screen, in the media toolbox all I see is "usbstorage.device", but nothing about the SATA device or how it will be called.

Should I do something else manually in the OS so it will be visible?

From UBoot on serial i have see that information:

U-Boot 2015.a (May 16 2015 14:20:11)

CPU:   AMCC PowerPC 460EX RevB at 1100 MHz (PLB=220 OPB=110 EBC=110)
       
No Security/Kasumi support
       Bootstrap Option H 
Boot ROM Location I2C (Addr 0x52)
       
Internal PCI arbiter enabled
       32 kB I
-Cache 32 kB D-Cache
Board
Sam460ex/crPCIe 4x PCIe 1x
I2C
:   ready
DRAM
:  2 GiB (ECC not enabled440 MHzCL4)
PCI:   Bus Dev VenId DevId Class Int
        00  04  1095  3512  0104  00
PCIE0
successfully set as root-complex
        02  00  1102  0012  0403  ff
PCIE1
successfully set as root-complex
        04  00  1002  699f  0300  ff
Net
:   ppc_4xx_eth0
FPGA
:  Revision 03 (2010-10-07)
SM502not found
PERMD2
:not found
VGA
:   1
VESA
:  OK
Board
Sam460crPCIe 4x PCIe 1x
USB
:   EHCI 1.00
       scanning bus 
for devices... 6 USB Device(sfound
       scanning usb 
for storage devices... 2 Storage Device(sfound
SATA Device 0
OK SATA Device 1not available
Model
KINGSTON SA400S37480G FirmSBFKK1C3 Ser#: 50026B7783C29DC9
            
TypeHard Disk
            Supports 48
-bit addressing
            Capacity
457862.8 MB 447.1 GB (937703088 x 512)
not available
Press SPACE 
for menuESC or for promptEnter for boot source
Countdown
.. 0
A1 Second
-level booter V2.
Ideadesign and main codeAndrea Vallinotto.
Testing and fixesStefan Burstroem
SFS 
and ISO9660 reading routinesJoerg Strohmayer.
Linux booting extensionsAndrea and the GRUB team.
Possible selections:
-> AmigaOS 4.xSD0 AmigaOS 4.1 CD
Choice 
?


So SATA card visibly, SSD connected to it visibly in Uboot too. But why I didn't see it in the media toolbox? Something like "sixxxxx.device" should be, right?

If I run Ranger, I can see in the device "sii3512ide.device" which looks indeed like my card. But it still didn't show in the media toolbox. Probably I need to do something manually there, like switching to some other mode or something?

I checked Epsilon's blog when he installs things on sam460cr, and he surely has this sii3114ide.device show up in the media toolbox:

http://4.bp.blogspot.com/-g8n4dRDOO08 ... F5RlVk/s1600/IMG_7144.JPG

But I didn't have it in my media toolbox si3512ide.device there for some reasons (while having it in Ranger).

Maybe this sii3512 is just a bad card for sam460?

Thanks!


Edited by kas1e on 2021/4/28 12:08:36
Edited by kas1e on 2021/4/28 12:09:38
Edited by kas1e on 2021/4/28 12:34:23
Edited by kas1e on 2021/4/28 12:36:51
Edited by kas1e on 2021/4/28 12:38:33
Edited by kas1e on 2021/4/28 12:43:07
Edited by kas1e on 2021/4/28 12:44:09
Edited by kas1e on 2021/4/28 12:47:06
Edited by kas1e on 2021/4/28 12:49:53
_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Just popping in
Joined:
2019/12/31 15:27
From Sweden
Posts: 70
@kas1e

"1 -> AmigaOS 4.x: SD0 AmigaOS 4.1 CD"

It seems you prefer both SD and CD before HDD? Please change that in Uboot settings.

   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7016
@arfcarl
Quote:

It seems you prefer both SD and CD before HDD? Please change that in Uboot settings.


Are you sure it can be a cause of not showing my SI device in the media toolbox, but showing si.device loaded in Ranger?

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Just popping in
Joined:
2019/12/31 15:27
From Sweden
Posts: 70
@kas1e

No, I'm not. But I suggest you try. :)

Suggestion:
1: CD
2: HDD
3: SD or None

   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Quite a regular
Joined:
2014/6/29 15:12
From Montserrat
Posts: 500
@kas1e

Try a regular harddrive first.
SSD's may not always work.


_________________
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7016
@arfcarl
sorry not sure that I understand what you mean :) this "1 -> AmigaOS 4.x: SD0 AmigaOS 4.1 CD" is what I have when just boot from a USB stick (default name of it). And when I hit "1" I just start loading from the USB stick - all as expected and as should be. I.e. it just a "welcome string".

Just when installation from USB stick loads up (and while I have in the Uboot that my SSD is recognized), when I load up media-toolbox i have no si_xxxxx.device shown. Only usbdisk.device

And when I fire up Ranger, I can see that the necessary sixxxxxx.kmod is loaded, and the device is in the memory, just MediaToolbox didn't see it.


@Spectre

Sadly I didn't have any regular hard drives anymore, only SSD ones.

And for now, I tried another SATA card, this time: si3114ide.device : it also showups in Ranger fine (that is loaded, so AOS4 installation detect correctly what card are attached to sam), but again, nothing in MediaToolbox about :(

It's like something should be set/unset in Uboot or so... Or maybe I should use newer siixxxxx.device (in installation CD for SAM I have 53.20, while the latest is 53.22 with some fix, but dunno if that related).

In Ranger, when I select sii3114ide.device, and hit "Query" it returns for NSD Query :

Open: 44 (Unknown)
Type: N/A
Sub: N/A

If that brings any info about .. And opens count in Ranger also "0".

When in uboot i type "sata info 1" i have:

Quote:

] sata info 1
Units on controller Sii3114
SATA device 0: Model: KINGSTON SA400S37480G Firm: SBFKK1C3 Ser#: 50026B7783C29DC9
Type: Hard Disk
Supports 48-bit addressing
Capacity: 457862.8 MB = 447.1 GB (937703088 x 512)


So Uboot clearly detect SSD and of the correct size. Just wtf amigaos4 install CD didn't load up a device in the media toolbox...

As can be seen, it's "SATA device 1", not "0". And does not matter which ports I use: SSD recognized only when I connect it to the first port on the SATA card, and it's already "device 1".

I have in my current envs those strings related to SI and boots:

Quote:

boot1=usb
boot2=ssii
boot3=s4sii
s4sii_maxbus=1
bootargs=root=/dev/sda3 console=tty0


Can't see there anything which should make mediatoolbox not see sixxxxx.device (which is loaded by system as Ranger shown, so detected by os4 too, just not by mediatoolbox).

"pci" show that it all connected too:

Quote:

] pci
Scanning PCI devices on bus 0
BusDevFun VendorId DeviceId Device Class Sub-Class
_____________________________________________________________
00.04.00 0x1095 0x3114 Mass storage controller 0x04



Edited by kas1e on 2021/4/28 20:22:32
Edited by kas1e on 2021/4/28 20:42:11
Edited by kas1e on 2021/4/28 20:43:49
_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Just popping in
Joined:
2019/12/31 15:27
From Sweden
Posts: 70
kas1e: Try boot AmigaOS from CD and skip USB completely.

And perhaps set your Uboot nvram settings back to default.

   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7016
@Spectre
And i tried to do some trick: i just loaded up, and in mediatoolbox change DEVICE tooltype on DEVICE=sii3114ide.device. Then save, run, and it brings me an error with the words "Couldn't use sii3114ide.device because there are no units attached."

Strange! Uboot shows that unit attached for sure (through as device #1, not as device #0, even in the first slot), but OS4 didn't see it

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: New Sam460cr boards will hit the road soon!
Just popping in
Joined:
2006/12/1 12:20
From Anzio (Rome), Italy
Posts: 115
@kas1e

is there any info on the debug output when AOS4.1 start the siixxxx_ide.device?

_________________
Max Tretene, ACube Systems Srl, Soft3
   Report Go to top


« 1 ... 4 5 6 (7) 8 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project