Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
36 user(s) are online (18 user(s) are browsing Forums)

Members: 0
Guests: 36

more...

Support us!

Recent OS4 Files
OS4Depot.net






New X5000 build hangs during startup from USB
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 477
I got my new motherboard, Enhancer, and USB startup stick from Amiga kit, and assembled it all today. The USB boot stick from Amigakit is found OK. "Loading finished ######################### 100%" message comes up after a short time. Next Line reads: "About to call loader entry at 0x7BD02020" at which point it just hangs there. Also, at power on, sometimes the boing ball starts spinning and "shoots", other times the graphic just sits there. I choose to boot from Mass storage when I do get the menu. I burned a boot ISO from my Windoze computer , but when I try to boot from optical, it says no valid boot source was found. I have the SSD HD plugged into SATA 0, and the DVD/CD in SATA 1.

The graphics card is an RX550.

Any ideas what I should do?

Paul

_________________
Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
   Report Go to top

Re: New X5000 build hangs during startup from USB
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 279
@Paul

It is possible that you don't actually have the driver for the Polaris card installed on the USB startup drive . It is currently sold as an extra pre release item of the the Enhancer 2.0 as Enhancer 2.0 has not been released yet. Solution is to try booting from a supported older model video card .

   Report Go to top

Re: New X5000 build hangs during startup from USB
Just popping in
Joined:
3/29 14:21
From Finland
Posts: 7
@Spectre660

> It is possible that you don't actually have the driver for the Polaris card installed on the USB startup drive . It is currently sold as an
> extra pre release item of the the Enhancer 2.0 as Enhancer 2.0 has not been released yet. Solution is to try booting from a supported older model
> video card.

Indeed... I had forgotten that detail and gave somewhat missleading info to Paul in the earlier thread. Sorry...

The other possibility is to buy that Radeon HD 3.x drivers prerelease packeage (that purchase gives the right to download the Enhancer 2.0 software, too, when ready). But it is available via AmiStore which can only used from a working AmigaOS system.

Paul: maybe you could contact AmigaKit and ask for some custom arrangement for purchaasing that 3.x driver package?

   Report Go to top

Re: New X5000 build hangs during startup from USB
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 477
@Spectre660
@Gregor

Yup. I heard back from Amigakit already, saying I need an older card to boot from. Based on the X5000 Wiki, I've ordered a crappy little VisionTek HD5450 (Evergreen) which supposedly should work. Basically it's a throw away card once I've' got it set up and get the latest Polaris drivers from Amistore. Available on Amazon for $40. should be here Friday. So no Amiga fun 'til next week.

I had to go to Plan B when assembling the 5000. I wanted to use my old Corsair Mystique case, but due to drive mounting issues for the 2.5" SSD, I had to use the Fractal Design case I bought over a year ago for this project.

Probably a silly question. . . but do any wireless keyboards/ mice work with the 5000? I was using a "wireless" Microsoft combo with my A1-XE. A large wired dongle plugged into the PS2 ports receiving data from the keyboard and mouse. Tried it on the 5000 with PS2 to USB converters, but it doesn't work. Is anyone still selling those nice Mechanical keyboards with the Amiga key caps?

Paul

_________________
Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
   Report Go to top

Re: New X5000 build hangs during startup from USB
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 279
@Paul

If you have another working AmigaOS 4.1 machine that can read and write the X5000 USB Drive with an internet connection you could purchase the Polaris Driver using AMIStore on the other machines and manually copy the Polaris driver onto the X5000 USB drive. The file format was SFS/00 .

You woudl need to copy the RadeonRX.chip file to
SYS:Kickstart
and
add the following to the SYS:Kickstart/Kicklayout file

MODULE Kickstart/RadeonRX.chip

   Report Go to top

Re: New X5000 build hangs during startup from USB
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 477
@Spectre660

My A1-XE was barely usable any more. I had to boot from the OS CD which in turn brought up the HD. I think the Mai chip is what controlled the PCI slots??? At any rate, the SiI SATA card and SATA HD's kept throwing up block and checksum errors. I wouldn't want to trust my USB startup for the X5000 to that rickety setup.

Thanks for your ongoing tips.

Paul

_________________
Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
   Report Go to top

Re: New X5000 build hangs during startup from USB
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 279
@Paul

No Problem.

For future reference remember that the current X5000 DVD .iso also does not contain the Polaris driver so keep the HD5450 safe after you have used it to the install the Polaris driver.



   Report Go to top

Re: New X5000 build hangs during startup from USB
Just popping in
Joined:
2006/11/29 7:57
Posts: 164
I do not know how to obtain the drivers and download Them without amistore and the updater program but IF you can work that out with amigakit it's easy to create a bootup media from another machine.
All you need is THE kickstart drawer and the files in it on a media that you can boot Up from.(usb flash drive is recomended)
You can boot from several filesystems, including fat/fat32 iirc.
When THE kickstart with your updated files are loaded you can continue to boot from your os4.1 install medium for example.


   Report Go to top

Re: New X5000 build hangs during startup from USB
Just popping in
Joined:
2006/12/6 23:24
From Indianapolis, Indiana USA
Posts: 18
@Paul

While I don't know specifically regarding wireless keyboards/mouse combos that work with the X5000, I am using a Logitech K520 wireless keyboard & matching mouse without any issues with my X1000. Its one of the Unifying USB dongle products and is fully compatible with OS 4.1

   Report Go to top

Re: New X5000 build hangs during startup from USB
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 477
@BCP

Thanks for that info. Once I have the OS installed and stable, I'll see if I can get one locally and give it a try.

Paul

_________________
Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
   Report Go to top

Re: New X5000 build hangs during startup from USB
Not too shy to talk
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 477
@BCP

I found a 540 on sale with the new monitor my wife needed. Working well with the 5000/

Paul

_________________
Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
   Report Go to top





[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project