Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
110 user(s) are online (96 user(s) are browsing Forums)

Members: 0
Guests: 110

more...

Support us!

Recent OS4 Files
OS4Depot.net




« 1 (2)


Re: Andrea Palmate's releases on os4depot
Just popping in
Joined:
2017/10/28 11:03
From Netherlands
Posts: 53
@kas1e

Thanks a lot! Working but only with the older minigl.library like you mentioned.

With the latest minigl.library i get a DSI crash. Even though my card is a SI R7 250.


_________________
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6354
@Skateman
You mean "UFO" ? That one crashes with mgl4gles currently, yes.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3336
@kas1e

Still eventually more Andrea's games to upload, GemRB, Nexuiz and Battle For Wesnoth 1.8.4 .. but about Wesnoth still in OS4Depot and old version from salass00 that i don't know how we can handle it, if mantain it or not in OS4Depot or just replaced it with the recent version done by Andrea

   Report Go to top

Re: Andrea Palmate's releases on os4depot
Just popping in
Joined:
2007/1/10 21:56
From Stockholm Sweden
Posts: 103
@kas1e
UFO:AI
I just get a black screen and if I click mouse X5000 hangs,
original minigl & mglut from X5000 iso, data files installed in base folder.

Edit: the little I see in debug output window since mouse=hangs X5000 is-
GL_EXT_texture_load_bias not found
GL_EXT_stencil_wrap not found
GL_EXT_fog_coord not found
GL_ATI_separate_stencil not found
GL_EXT_stencil_two_side not found
max texture size: detected 16384
but using 2048 as requested

_________________
1989-> A500, A600, A3000, A4000, A1200, CD32, µA1, PegII, A1XE, CDTV, Amy/416D79, A1X5000, Vampire 500 V2+, Vampire 600 V2, Amy-ITX<-2020
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6354
@khayoz
If you on polaris, there currently no way it will works for you: basic minigl didnt works on polaris. Minigl4gl4es also not works with UFO currently and it crashes exactly on place you show.

If you on radeonhd, then the only way is original minigl and mglut. Seeing your error, and if assume you on radeonhd, it mean you still on mgl4gl4es. Double recheck, check versions of both, do hard reboots and stuff. Because for me it 100% works on x5000 with radeonhd and minigl/mglut v2.23

I can made a video tomorrow

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Just popping in
Joined:
2007/1/10 21:56
From Stockholm Sweden
Posts: 103
@kas1e
I'm using R9 280X but will delete all minigl and mglut, reboot and reinstall minigl and mglut. Maybe it's the minigl4es4.. delete/replace bug that Daytona talked about.

Edit: Same problem with delete of all minigl/mglut, hard reboot, install of minigl/mglut from X5000 ISO, hard reboot, then start UFO:AI same crash.

Edit2: Every other game you ported work flawless.

Edit3: Nothing on serial, is there a debug command?


Edited by khayoz on 2020/1/10 21:47:31
Edited by khayoz on 2020/1/11 2:20:20
Edited by khayoz on 2020/1/11 8:00:56
_________________
1989-> A500, A600, A3000, A4000, A1200, CD32, µA1, PegII, A1XE, CDTV, Amy/416D79, A1X5000, Vampire 500 V2+, Vampire 600 V2, Amy-ITX<-2020
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6354
@khayoz
Are you sure you have Warp3D SI bought and installed? Not NOVA one, but Warp3D Si? To be sure it works, check if that one runs for you: http://os4depot.net/share/demo/magazine/thevague/the_vague_2.lha

If that works, it means Warp3D SI works for you, and need to deal with minigl. If it didn't work, it means Warp3D SI didn't work for you.

Next, if warp3d si works, then install minigl.library and mglut.library from there:
http://www.hyperion-entertainment.com ... c/precompiled_binaries.7z

Take the ones from libs/ppc directory, place them to System:LIBS and be sure that when you do "version full system:libs/minigl.library" and "version full system:libs/mglut.library" it show 2.23. Then hard reboot and try UFO again.

But be sure that this "the_vague_2.lha" works for you (its pure warp3d prod).

Also be sure, you didn't have anything like waZp3d installed.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Just popping in
Joined:
2007/1/10 21:56
From Stockholm Sweden
Posts: 103
The Vague 2 works without problem, and yeah I got all Warp3D SI updates to the latest. The first thing I do every boot is check Amiupdate & Updater.

Installed your minigl/mglut and now everything works!
Success! :)


Thank you again kas1e!


EDIT:But then again, why didn't it work in the first place with the X5000 iso minigl/mglut?
Is there a newer version of the X5000 iso floating around? ;)

_________________
1989-> A500, A600, A3000, A4000, A1200, CD32, µA1, PegII, A1XE, CDTV, Amy/416D79, A1X5000, Vampire 500 V2+, Vampire 600 V2, Amy-ITX<-2020
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Amigans Defender
Joined:
2006/12/2 13:27
From Taranto, Italy
Posts: 922
Guys.. hope i can recompile them (even if for most of them it is useless). I've always tried to add .so files because i was pretty sure that in the time many of them could be different or lost.. Unlucky i have no great time to track all library changes these days.
I've recompiled right now the latest GemRB version but i can't test it because i have no working machines here at home (i have my SAM at work and that't why i hope in a laptop one day).
Monday i'll try to run it and see if it is working correctly.
Unlucky with latest GCC version i have a lot of strange problems and it is hard for me in the few time i have to track all problems

_________________
i'm really tired...
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6354
@khayoz
Quote:

EDIT:But then again, why didn't it work in the first place with the X5000 iso minigl/mglut?
Is there a newer version of the X5000 iso floating around? ;)


Dunno why it didn't works with those default one. Maybe they was buggy and/or too old. But at least it works now, good :)

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: Andrea Palmate's releases on os4depot
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 627
@afxgroup
I am really interested about latest GemRB. If you need someone to test, don't hesitate to contact me.

   Report Go to top

Re: Andrea Palmate's releases on os4depot
Quite a regular
Joined:
2007/2/27 10:47
From Gravity well
Posts: 686
@walkero
+1

   Report Go to top


« 1 (2)



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project