Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
61 user(s) are online (48 user(s) are browsing Forums)

Members: 0
Guests: 61

more...

Support us!

Headlines






PCI very slow when using Radeon9250 on X1000 ?
Just can't stay away
Joined:
2012/8/14 13:51
From France
Posts: 1495
Hi, 
I'm using a PCI Radeon 9250 128bits 256mB (only 128mB are recognized) to have Overlay and native Warp3D on my x1000. 

I have tried to play a HD movie with this gfx card, it works but it's really worst than on my Peg2 AGP Radeon 9000Pro (sold last week)

When I play this movie
http://mirrorblender.top-ix.org/peach ... k_bunny_720p_surround.avi

In fullscreen and in window mode, I have 34% of skipped frames (16 fps) with DVPlayer verbose option (same skipped frame % in fullscreen and window mode)

On the Peg2, I only have 2% of skipped frames (23 fps)

Indicating by RageMem, the Video bus speed is very slow (Read = 3 mB/sec, Write = 25 mB/sec) comparing to Peg2 (52 and 221 respectively)
I have tried it with 3 cards (2 9250 128bits and 1 9250 64bits) and the DVPlayer results are around the same for each...

http://zzd10h.amiga-ng.org/Divers/Rad ... DVPlayer_RageMem_9250.jpg

Next,
I have tested to put the Radeon9250 on the Starteck PCI2PCIE adapter. 
And it works very better (but far of my Peg2 results)

For the same DVPlayer video 
Now, I just have 5% of skipped frames and 22 fps 
(instead of 34% and 16 fps for the test directly on the PCI slot) 

RageMem 
Video Bus Read = 17 MB/s (instead of 3 MB/s directly on PCI slot) 

Video Bus Write = 31 MB/s (instead of 25 MB/s directly on PCI slot) 

http://zzd10h.amiga-ng.org/Divers/Rad ... yer_RageMem_9250_PCIE.jpg

Unfortunately, I can't keep the 9250 on the Starteck adapter, the card is to much heavy.

It's strange, that the PCI slot and PCI-E were so slow with the Radeon 9250, no ?


1) I thought that the slowest PCI bandwith (33mhz) was around 100 mB/sec...
Do you know where I am wrong ?

2) And do you know if the future Gallium3D will resolve this Overlay big problem ?

Thank you if you could help me on one of these 2 questions.
And sorry for this long post.


Edited by zzd10h on 2013/1/6 0:29:19
   Report Go to top

Re: PCI very slow when using Radeon9250 on X1000 ?
Not too shy to talk
Joined:
2006/12/2 0:31
From Poland
Posts: 280
1. My little SAM440 Flex 800MHz (66MHz) gives 39Mb/s (Read) and 58Mb/s (Write).

2. http://www.amigans.net/modules/xforum ... t_id=76254#forumpost76254

_________________
Sam440 flex 800MHz RAM 1GB R9250 128MB OS4.1 SBLive! ->
   Report Go to top

Re: PCI very slow when using Radeon9250 on X1000 ?
Home away from home
Joined:
2007/1/26 21:48
From New Zealand
Posts: 2310
@mr2

You already started a thread on this topic on the Hyperion forums. Why not just continue asking there?

Quote:

1) I thought that the slowest PCI bandwith (33mhz) was around 100 mB/sec...
Do you know where I am wrong ?

That's theoretical throughput, which can only be achieved by transferring large blocks at a time (usually using DMA). Using DMA for such transfers is only implemented for Sam4x0 machines at this time. The Peg2 write speed is interesting, and suggests that the Peg2's north-bridge may have special hardware to chain multiple writes into larger blocks. By contrast, the PA6T does not do this. This shouldn't matter as we should be using DMA anyway, but this isn't implemented yet.

Quote:
2) And do you know if the future Gallium3D will resolve this Overlay big problem ?

Gallium3D may help at some point, but textured video is also on the to-do list (as you already know). Please see this thread for more details.

Hans

_________________
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more.
https://keasigmadelta.com/ - more of my work
   Report Go to top

Re: PCI very slow when using Radeon9250 on X1000 ?
Just can't stay away
Joined:
2012/8/14 13:51
From France
Posts: 1495
Thank you mr2

1) are these big results differences between our 2 systems just because of the 33mhz PCI speed difference ?

Is a x1000 owner could make a RageMem test, please, with or without a PCI card?
Or better, could you test the linked video test ?

2) thank for the link !
Great, happy to read thet Gallium3D will resolve our lack of overlay and that it's in the to-do list of the AmigaOS team :)

   Report Go to top

Re: PCI very slow when using Radeon9250 on X1000 ?
Just can't stay away
Joined:
2012/8/14 13:51
From France
Posts: 1495
Yes, I opened too the same thread on Hyperion...
But Ihave opened this new thread to have more answers, because I don't know if it was a problem from me or from x1000.

And, now I have the answer,, thank you.

But, i don't understand if the large block transfer with DMA is planned for PA6T ?

Thank you Hans for this explanation

   Report Go to top





[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project