Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
105 user(s) are online (92 user(s) are browsing Forums)

Members: 0
Guests: 105

more...

Headlines




« 1 2 3 4 (5) 6 7 8 ... 55 »


Re: SDL2
Just can't stay away
Joined:
2007/7/14 21:30
From Lothric
Posts: 1335
@broadblues

Some tests don't even rely on SDL cleanup. They rely on OS cleanups. Sigh.

I hope nobody tries to learn SDL from its "test" code :)

   Report Go to top

Re: SDL2
Amigans Defender
Joined:
2006/12/2 13:27
From Taranto, Italy
Posts: 968
@Capehill

I suppose that Compositing should produce better results. However only a test can give us some responses

_________________
i'm really tired...
   Report Go to top

Re: SDL2
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 594
Fixed SDL_Image configure (thanks to Mtchael T. Suggestions)
Fixed the SDL_Image makefile.
SDL_Image compiled.

Still few errors in loadimage.c sample file.

_________________
Retired
   Report Go to top

Re: SDL2
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 594
Ported SDL_GFX2 too

very cool effects possible.

Demo makers could play with those effects a little.




_________________
Retired
   Report Go to top

Re: SDL2
Just can't stay away
Joined:
2007/7/14 21:30
From Lothric
Posts: 1335
@AmigaBlitter

What, no teaser images?

   Report Go to top

Re: SDL2
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 594
@Capehill

Sorry for the bad quality

Resized Image
upload immagini gratis

Resized Image
hosting immagini

Resized Image
invia immagini

for the third image sgrab can't catch the animated image, but the effect still nice

_________________
Retired
   Report Go to top

Re: SDL2
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 594
@thread

Please don't forget to danate to the developers for the time they spend to the project.

A big thank to capehill.

Capehill for president


Edited by AmigaBlitter on 2016/2/23 19:48:50
_________________
Retired
   Report Go to top

Re: SDL2
Just can't stay away
Joined:
2007/7/14 21:30
From Lothric
Posts: 1335
@AmigaBlitter

Thanks for the support and testing.

A new issue popped up when testing accelerated (OpenGL) renderer. It cannot open all necessary functions so it fails. glBlendFuncSeparate is the first failure. I am not sure at the moment what else might be missing - list is here (used functions are the ones with SDL_PROC macro):

https://sourceforge.net/p/sdl2-amigaos ... nder/opengl/SDL_glfuncs.h


   Report Go to top

Re: SDL2
Quite a regular
Joined:
2013/10/17 16:21
From Hungary
Posts: 665
@Capehill
There's no such function in MiniGL, because Warp3D doesn't support setting the color and alpha blending separately.

_________________
This is just like television, only you can see much further.
   Report Go to top

Re: SDL2
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 594
@Capehill

You're welcome.

Ported SDL2_TTF and SDL2_Mixer meanwhile.

Have to test asap

...found an error for the mixer


Edited by AmigaBlitter on 2016/2/23 22:53:23
_________________
Retired
   Report Go to top

Re: SDL2
Quite a regular
Joined:
2009/4/28 4:57
From Adelaide, Australia
Posts: 939
I'm having trouble building SDL2 (svn r63). When linking the .so:

build/.libs/SDL_cpuinfo.o:(.got2+0x14): undefined reference to `IExec'
build/.libs/SDL_os4events.o:(.got2+0x0): undefined reference to `IExec'
build/.libs/SDL_os4framebuffer.o:(.got2+0x0): undefined reference to `IExec'
build/.libs/SDL_os4messagebox.o:(.got2+0x0): undefined reference to `IExec'
build/.libs/SDL_os4modes.o:(.got2+0x0): undefined reference to `IExec'
build/.libs/SDL_os4mouse.o:(.got2+0x0): more undefined references to `IExec' follow
/usr/local/amiga/ppc-amigaos/SDK/newlib/lib/libc.a(stub_iconv_open.o): In function `iconv_open':
(.text+0xa): undefined reference to `INewlib'
/usr/local/amiga/ppc-amigaos/SDK/newlib/lib/libc.a(stub_iconv_open.o): In function `iconv_open':
(.text+0x26): undefined reference to `INewlib'
/usr/local/amiga/ppc-amigaos/SDK/newlib/lib/libc.a(stub___NewlibCall.o): In function `__NewlibCall':
(.text+0x2): undefined reference to `INewlib'
/usr/local/amiga/ppc-amigaos/SDK/newlib/lib/libc.a(stub___NewlibCall.o): In function `__NewlibCall':
(.text+0x6): undefined reference to `INewlib'

Any ideas? I'm using gcc 5.3.0 in Cygwin, and base/newlib/clib from SDK 53.30

I'll try again with an earlier compiler (just stock non-cross SDK) later on.


Edited by MickJT on 2016/2/24 15:28:45
Edited by MickJT on 2016/2/24 15:36:55
   Report Go to top

Re: SDL2
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2969
@MickJT

Try with G++ incited of GCC
or try with -lauto flag.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: SDL2
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2969
Double post... :-/

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: SDL2
Just can't stay away
Joined:
2007/7/14 21:30
From Lothric
Posts: 1335
@MickJT

What was your configure line?

With GCC4.something, I can't build .so without modifying the makefile. I remove -no-undefined for libtool _and_ gcc and then I get the lib. I don't know why these switches exist in buildsystem, but also SDL1 has -no-undefined switch for libtool at least:

https://github.com/adtools/os4sdl/blob/master/Makefile#L51

You can try that, but I'm not really familiar with this topic. There is a ticket open on SDL2 project page regarding .so.

   Report Go to top

Re: SDL2
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 594
@MickJT

I had some problem with the 5.3. The configure freeze the system.

Reverted back to 4.9.1


_________________
Retired
   Report Go to top

Re: SDL2
Just can't stay away
Joined:
2007/7/14 21:30
From Lothric
Posts: 1335
@AmigaBlitter

Try bigger stack + serial cable :)

   Report Go to top

Re: SDL2
Just can't stay away
Joined:
2007/7/14 21:30
From Lothric
Posts: 1335
@BSzili

Yeah, luckily, glBlendFuncSeparate seems to be the only missing function. Here are the SDL blenders:

https://wiki.libsdl.org/SDL_SetTextureBlendMode

Looks like we can use just glBlendMode for "none" and "blend", while "add" and "mod" can be a little bit funky.

EDIT: forgot the issue of NPOT textures. This can be a showstopper for MiniGL renderer.
EDIT2: damn, it's good to be wrong. Looks like internally SDL2 uses POT textures.


Edited by Capehill on 2016/2/24 19:43:46
   Report Go to top

Re: SDL2
Quite a regular
Joined:
2009/4/28 4:57
From Adelaide, Australia
Posts: 939
I removed -no-undefined in a few places in the Makefile, and was able to build the .so and .a

I then compiled SDL2_image. Both the static and shared versions worked (note that there are source code changes that are needed to build a functional .so of SDL_image).

I tested showimage on a .pcx image, and set the stack to 1000000. It freezes shortly after displaying the image, and the window cannot close.

Anyway, good to see progress :)

   Report Go to top

Re: SDL2
Just can't stay away
Joined:
2007/7/14 21:30
From Lothric
Posts: 1335
@MickJT

If I had serial log, I might be able to help. At the moment I have hands full with the core lib so I'm not going to compile satellite libs this week...


Source code of showimage doesn't look buggy. It relies on implicit initialization and quitting of video system so it's a bit "lazy" though. But at least it calls SDL_Quit.

   Report Go to top

Re: SDL2
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 594
@MickJT

I've compiled the SDL2_Image previously and worked fine. Haven't tried a PCX, tho.

SDL2_TTF compiled too.
SDL2_Mixer compiled removing the libmodplug option atm. It causes the SDL2_mixer compilation failure, cause it come from a previously wrong compilation (from SDL 1.2

_________________
Retired
   Report Go to top


« 1 2 3 4 (5) 6 7 8 ... 55 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project