Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
74 user(s) are online (57 user(s) are browsing Forums)

Members: 2
Guests: 72

Raziel, orgin, more...

Headlines




« 1 2 3 4 (5) 6 7 8 ... 12 »


Re: OWB (1.18) bugs and feature requests
Quite a regular
Joined:
2006/11/27 22:17
From Israel
Posts: 932
@joerg

Thanks for .so locations clarification.

Quote:

Quote:

Edit: and does it detects LOWMEM as commandline arg?

No, but it reads the tooltypes even if you start it from a shell.


Just did some test before reading your reply and found that LOWMEM results in about 8MB difference when started from WB with amigans.net loaded.
Starting form shell results in similar to "LOWMEM"-enabled consumption.
Great feature
BTW: what makes AWeb to display "E" button for external editor in right-bottom corner of editor area in forums?
Is there an option to do this in OWB?
Or alternatively: are there some shortcuts for editing text?
Currently this and lack of storing of passwords is the main reason for AWeb remaining the main browser here, but OWB is in the right direction


Thanks!
Jack

_________________
Resized Image
"the expression, 'atonal music,' is most unfortunate--it is on a par with calling flying 'the art of not falling,' or swimming 'the art of not drowning.'. A. Schoenberg
   Report Go to top

Re: OWB (1.18) bugs and feature requests
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3284
@Jack
Quote:

BTW: what makes AWeb to display "E" button for external editor in right-bottom corner of editor area in forums?


It comes from the text editor gadget class that AWeb uses (I'm guessing it is an internal custom one).

Quote:

Or alternatively: are there some shortcuts for editing text?


Shift and the cursor keys highlight text, which make it easier to delete chunks. Copy and paste doesn't seem to work (either internal to OWB or with the global clipboard).

Highlighting doesn't work with the mouse for some reason.

Quote:

Currently this and lack of storing of passwords is the main reason for AWeb remaining the main browser here, but OWB is in the right direction


AWeb can't store passwords, can it?

Chris

   Report Go to top

Re: OWB (1.18) bugs and feature requests
Quite a regular
Joined:
2006/11/27 22:17
From Israel
Posts: 932
@Chris

Quote:

AWeb can't store passwords, can it?


"Edit" menu->"Save authorizations"

Thanks for the reply
Jack


Edited by Jack on 2008/3/25 23:00:13
_________________
Resized Image
"the expression, 'atonal music,' is most unfortunate--it is on a par with calling flying 'the art of not falling,' or swimming 'the art of not drowning.'. A. Schoenberg
   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just popping in
Joined:
2007/1/15 17:54
Posts: 36
@Raziel
Just tried OWB 1.19. The tool types don't work for setting home page or font size or window size.. Also a message output window opens in back.
That nice proggie OWB Adressbook can't find OWB now.
BIG OOPS. I upacked and installed the wrong version.
renoir

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Quite a regular
Joined:
2006/11/27 22:17
From Israel
Posts: 932
Opening second OWBs (while the first is running) throws an ISI and a msg saying "error during opening AmigaOS stuff" into stdout

Edit: killing the 2-nd instance and opening again (1-st is still running) displays the message without the GR window...
Jack

_________________
Resized Image
"the expression, 'atonal music,' is most unfortunate--it is on a par with calling flying 'the art of not falling,' or swimming 'the art of not drowning.'. A. Schoenberg
   Report Go to top

Re: OWB (1.18) bugs and feature requests
Amigans Defender
Joined:
2006/11/17 22:40
From England
Posts: 3284
@Jack

Oh, that!

That only does proper HTTP authentication*, I thought you meant a password manager like Mozilla has that can store passwords on arbitrary pages (I think iBrowse can do this but not 100% sure)

Chris
* Which is also quite useful, but I use it so infrequently that I forgot AWeb could save the passwords.

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just can't stay away
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 1276
@joerg

Quote:

joerg wrote:
Since some of the reported bugs are the AmigaOS4 parts, and adapting the AmigaOS4 parts for Doduo will probably take some time, I've uploaded a new AmigaOS4 version of OWB Blastoise.
It includes the changes for only rendering the visible parts as well (add the tooltype LOWMEM to enable it), but I doubt it will help much for classic Amigas, it needs much less RAM for large pages but it's probably too slow on classic Amigas that way.

Great! Thanks, J?rg.

I can confirm that it has solved the crash on http://qxl.dk/ and *almost* the problems with nested framesets.

Almost? Well, it looks like when I load a frameset (such as the ones on my site) into the lower (main) frame of e.g. the PROGDIR:UI/ff/navigation.html, some space is added at the top of the main frame, above the two frames of the nested frameset. And the height of this extra space looks suspiciously like the same distance with which all links in the two lower frames are now offset vertically from their visible rendering.

In other words, all the links work as they should in the frame where they should, except you have to move the mouse that distance upwards from the visible link.

Does this explanation make sense? If not, say so, and I'll try a better one tomorrow.

(Good night ...)

Best regards,

Niels

   Report Go to top

Re: OWB (1.18) bugs and feature requests
Just can't stay away
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 1276
@Chris

Quote:

Chris wrote:
@Jack

Oh, that!

That only does proper HTTP authentication*, I thought you meant a password manager like Mozilla has that can store passwords on arbitrary pages (I think iBrowse can do this but not 100% sure)

Correct, IBrowse, at least in the latest version(s?), has a password manager.

Best regards,

Niels

   Report Go to top

Re: OWB (1.18) bugs and feature requests
Just popping in
Joined:
2006/12/1 18:10
From Poland
Posts: 36
@joerg

Quote:

joerg wrote:
@SKOLMAN_MWS

Quote: Unlike all other crashes this one is a bug in the AmigaOS4 parts (actually 2 bugs, and that it tries to download SVG images at all will be changed in the next version as well, I'll use my original version to only download application/#? mime types), will be fixed in the next version.


Thanks

version 1.19 button "nowy mms" on multibox orange.pl ok no crash only button send message problem with javascript don't act.

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@nbache

Quote:
Almost? Well, it looks like when I load a frameset (such as the ones on my site) into the lower (main) frame of e.g. the PROGDIR:UI/ff/navigation.html, some space is added at the top of the main frame, above the two frames of the nested frameset. And the height of this extra space looks suspiciously like the same distance with which all links in the two lower frames are now offset vertically from their visible rendering.

In other words, all the links work as they should in the frame where they should, except you have to move the mouse that distance upwards from the visible link.

Does this explanation make sense?
It probably wouldn't if I wouldn't know the problem

It's another frames bug, not the one I fixed. One of the pages were it's really bad are for example the middle frames on http://os4welt.de/
It can be fixed by scrolling the frame(s) up with the mosue wheel, even if they should be at the top already, that will move them where they belong.
It's not a bug in the OWB parts but in WebKit, for example the KDE4 Konqueror had exactely the same bug. In the WebKit version used in current Ubuntu/Hardy KDE4 Konqueror it's fixed now, but the WebKit version used in OWB Blastoise is about 5 months old. Should get fixed in OWB Doduo which will use the current version of WebKit.

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Not too shy to talk
Joined:
2006/11/29 21:59
From Croatia
Posts: 326
@Renoir

hmm...Try OWB 1.19 but have slower scroll rutin?? anz have smilar problem? 1.18 OWB have faster and better scroll..

_________________
A1200 sandwich

uA1c AmigaOS4.1 Final + upd #1 + 512 mb


Warp - Croatian Amiga portal
   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just popping in
Joined:
2007/1/15 17:54
Posts: 36
@Raziel

Ok I got it right this time OWB 1.19. Try this page http://www.mcmunnandyates.com/ click on products and try select s"suppliers and vendors" or "pre-fab packages" you can't do it. You can only select "feature product".

renoir

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 4323
@Renoir

Sorry, works quite nice here, EVERY link on that page works

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 209
@VooDoo

Yes the scroll on my uA1 now with this version is slow.

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just can't stay away
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 1276
@joerg

Quote:
It's another frames bug, not the one I fixed. One of the pages were it's really bad are for example the middle frames on http://os4welt.de/
It can be fixed by scrolling the frame(s) up with the mosue wheel, even if they should be at the top already, that will move them where they belong.
Yep, I can see that is also the case on my own page; after I scroll each of the two sub-frames into position, the links work as they should in both. Didn't think of trying that.

Quote:
It's not a bug in the OWB parts but in WebKit, for example the KDE4 Konqueror had exactely the same bug. In the WebKit version used in current Ubuntu/Hardy KDE4 Konqueror it's fixed now, but the WebKit version used in OWB Blastoise is about 5 months old. Should get fixed in OWB Doduo which will use the current version of WebKit.
Okay, we'll just have to wait for that then. But good to know how to work around it.


Best regards,

Niels

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@sofistisoftware

Quote:
Yes the scroll on my uA1 now with this version is slow.
If you have the LOWMEM tooltype enabled it's of course slow since it has to rerender everything when scrolling.

It could be that some parts of the new code are always enabled, even if the tooltype isn't set, but on my A1 it's fast enough and since the code is very likely useless for the next version anyway it would be a waste of time trying to optimize it now.

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just popping in
Joined:
2006/11/23 21:49
From Budapest / Hungary
Posts: 97
@VooDoo

Confirmed here. I noticed the same behavior.

_________________
A1-XE/G4@933+Radeon7500/64MB, A1200BPPC+BVision
AmigaOS4 on both of course.
   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just popping in
Joined:
2006/11/23 21:49
From Budapest / Hungary
Posts: 97
@joerg

I'm using the old icon, so no LOWMEM key is enabled. Could the old ICON cause it?

_________________
A1-XE/G4@933+Radeon7500/64MB, A1200BPPC+BVision
AmigaOS4 on both of course.
   Report Go to top

Re: OWB (1.19) bugs and feature requests
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@Chip

Quote:
I'm using the old icon, so no LOWMEM key is enabled. Could the old ICON cause it?
No. But I didn't do any speed tests, as I wrote it could be that some of this code is always enabled and 1.19 is therefore it's slower than 1.18 was.

   Report Go to top

Re: OWB (1.19) bugs and feature requests
Not too shy to talk
Joined:
2006/11/29 21:59
From Croatia
Posts: 326
@joerg

Yeah is slower..here I disabled LOWMEM option and the same..scroll is slow.. back to 1.18 for now!

_________________
A1200 sandwich

uA1c AmigaOS4.1 Final + upd #1 + 512 mb


Warp - Croatian Amiga portal
   Report Go to top


« 1 2 3 4 (5) 6 7 8 ... 12 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project