Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
89 user(s) are online (69 user(s) are browsing Forums)

Members: 0
Guests: 89

more...

Support us!

Headlines




« 1 (2) 3 »


Re: Sam460 and 720p video playback
Just popping in
Joined:
2013/10/1 5:30
From Austin, TX
Posts: 8
@LiveForIt and @Severin,

Thanks for the short, clear description of the "http: requestor" issue. I am guessing that the mplayer I was using was doing exactly the same thing, just internally.

I will look (again) at AmigaAmp. It and Tunenet are yet 2 more programs to learn well enough to know the work arounds for their quirks. MPlayer was, seemingly, a "one-program-solves-all", but "internet stations" keep messing around with their delivery schemes and stations become no longer accessible.

Inexplicably, the mplayer began, some months ago, to connect to the audio at too slow, too fast, sometimes just right speed. Only "just right speed" would play for more that 2 hours with perfection. So many times, I have to run an errand, leaving mplayer working, and return to find the X1000 hung, and a buzzing noise coming from the head phones. The buffering (for even delivery) was not settable and was not adequate.

All reasons to look into liveForIt-MPlayer as a replacement.

More, later.

==============
PS: I have to agree about the less than ideal GUI of Amigans.net. It has the screwest way of allowing me to finally login. The seemingly normal way, over there on the left, WON'T work. I'm serious: I have to purposefully enter a wrong password, get sent to that "intermediate screen" where I enter that proper password, and I'm in. Strange.

   Report Go to top

Re: Sam460 and 720p video playback
Quite a regular
Joined:
2007/7/23 21:35
Posts: 659
@LiveForIt

I can't see UVD and VDPAU being a priority for A-EON, as their , machines will be able to cope without.

On the other hand it will be a good thing to free up cpu usuage for other tasks.

Cheers

   Report Go to top

Re: Sam460 and 720p video playback
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2847
@ggw

Quote:
Inexplicably, the mplayer began, some months ago, to connect to the audio at too slow, too fast, sometimes just right speed. Only "just right speed" would play for more that 2 hours with perfection.


That's the problem with the internet, some time it slows down, because hi traffic on servers or the client side, if you have more then one computer connected to the internet and need to share the line out.

To prevent buffer under run, you can increase buffering, the older version of mplayer including liveforit-mplayer don't have option for how many % it has to buffer, and so on, only the size of the buffer.

Quote:
So many times, I have to run an errand, leaving mplayer working, and return to find the X1000 hung


Audio codecs like AAC can crash the mplayer, at least the older versions.

Quote:
All reasons to look into liveForIt-MPlayer as a replacement.


While I have fixed many bugs in liveForIt-MPlayer compared to the older Mplayer, there are some bugs that have not been fixed like AAC codec, this because this fixed by MplayerHQ team in the version the beta tester and I have, only problem I have done a lots of changes to video outputs and now they no longer support the old graphic.library your using.

So wait for AmigaOS4.1 final, and I get the newest version out.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Sam460 and 720p video playback
Just popping in
Joined:
2013/10/1 5:30
From Austin, TX
Posts: 8
Yep.
"When its done!"

   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
Anyone have any feedback on 480p mp4 video playback on Sam460's with AmigOS4.1 FE and the latest Mplayer?

   Report Go to top

Re: Sam460 and 720p video playback
Quite a regular
Joined:
2010/5/16 12:20
From Grimsby, UK
Posts: 950
Now possible to watch big buck bunny at 480p and keep in near sync with audio, I say near because it's still a little out. 720p still Slow, but not Very Slow. YouTube playback getting better but still falling short. All in all a marked improvement, but with some way to go.

Am I expecting too much from my Radeon card? Honest answer is I really don't know.


Is this even possible?

   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
@djrikki

480p Avi's like big buck bunny have worked for me with AmiagOS4.1 update 6 and DVplayer and Liveforit Mplayer 5.1 .
480p MP4's have not(Mplayer 5.1 ). Should have AmigaOS 4.1 FE by the end of next week so will see how it works for me. My main video card is a Radeon HD 6670. Also have a HD 7750 to test with video playback. Have had to convert 480p videos from MP4 to AVI using a PC to be able to watch on the Sam460ex so If I no longer need to convert them I will be happy.


   Report Go to top

Re: Sam460 and 720p video playback
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2847
@djrikki

>Am I expecting too much from my Radeon card? Honest answer is I really don't know.

Yes, No speed up for Radeon cards, nothing interesting has changed for P96_PIP overlay support, no DMA from RAM to VRAM for P96_PIP video output.

Radeon HD cards, the story is different, we now have DMA support, we have hardware accelerated YUV420p bitmaps, we have DRI support in video outputs (COMP_YUV and COMP_YUV2).


Edited by LiveForIt on 2015/1/12 20:15:13
_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Sam460 and 720p video playback
Quite a regular
Joined:
2010/5/16 12:20
From Grimsby, UK
Posts: 950
HD is what I meant, sorry I missed it out.

   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
AmigaOS4.1 FE plus the RadeonHD 2.4 driver now installed.
Cant get get audio and video in 480p mp4 videos to play in sync with Liveforit-Mplayer.


   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
Interestingly 480p mp4 play back in a window in sync (with frame drop) under Linux using mplayer2 .OS4.1 FE on the Sam's has DRI support were as Linux does not so I would have expected better results in OS 4.1FE with Liveforit-Mplayer .

   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
Still experimenting.

480p Xvid playback ok .
720p Mjpeg playback ok.
so it is possible to play some 720p videos an a Sam460ex.
4x file size of xvid though .

   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
@Spectre660

a link for future reference.
https://morph.zone/modules/newbb_plus/ ... hp?topic_id=11064&forum=9

Convert the video to the format your machine can handle.

   Report Go to top

Re: Sam460 and 720p video playback
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1172
@Spectre660

To convert videos on OS4 use this little script:


ugly double extension version.

.bra {
.
ket }
.
key filename

ffmpeg 
-"{filename}" -b 1548k -ab 128k "{filename}.avi"


Version using my cutstring command to avoid renaming:

.bra {
.
ket }
.
key filename

set filename2 
`cutstring {filename} NAME`
ffmpeg -"{filename}" -b 1548k -ab 128k "$filename2.avi"
unset filename2


The script will convert any format video to AVI

If 1548k is too much try 1200k or 1000k

Cutstring is in this pic, just save it and use DICPNG from OS4Depot to extract it

Resized Image

Run it with no arguments for help.

_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
@Severin

Thanks. Will give it a look.
Using a quad core box to do the conversions currently and
I am spoiled by the conversion speed.
Using 2000k with no problems on playback on the Sam460ex.

   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 332
@Spectre660
Quote:
Convert the video to the format your machine can handle.

If you want to convert virtually any codec and format on your SAM460 with an easy to use GUI use ffmpeg and ffmpegGUI from OS4depot. You can set the "duration" time so you don't have to convert the whole video.

Resized Image
(Click for larger view)

_________________
AmigaOne X1000, uA1
   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
Command below line works for 720x404 h.264 playback

mplayer -really-quiet -framedrop -lavdopts skiploopfilter=all:skipframe=nonref

   Report Go to top

Re: Sam460 and 720p video playback
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1099
Spectre660 : of course it works. It's really ugly but it works

_________________
--
AmigaONE X1000 1,8Ghz, 2GB, Sapphire Radeon HD 7700, with Amiga OS 4.1 FE
http://www.amiga-ng.org
   Report Go to top

Re: Sam460 and 720p video playback
Quite a regular
Joined:
2007/7/23 21:35
Posts: 659
@Spectre660

Have you tried DvPlayer?


   Report Go to top

Re: Sam460 and 720p video playback
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 286
@TiredOfLife

Current DvPlayer wont playback mp4 videos.


   Report Go to top


« 1 (2) 3 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project