Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
82 user(s) are online (61 user(s) are browsing Forums)

Members: 0
Guests: 82

more...

Support us!

Headlines




« 1 2 3 4 (5) 6 »


Re: Atheros WLAN driver success/failures
Quite a regular
Joined:
2010/5/16 12:20
From Grimsby, UK
Posts: 950
Keep up the work guys, as much as I want you to succeed I also want to see the bloody thing provided as-standard in the OS - its really too much to ask it ?

   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2006/12/2 1:41
From VA, USA
Posts: 289
Hi all,

Finally got some time to get the WPN311 card back into the
SAM440-mini and to try manually & verbosely starting the
WirelessManager and AddNetInterfaces...

Sorry for a long post, but here's what happened:

First, I continued trying with the atheros5000.device.debug4
(090313) version, I get:
Quote:
5.aSYS:> c:WirelessManager atheros5000.device VERBOSE
Initializing interface 'atheros5000.device:0' conf 'ENV:Sys/Wireless.prefs' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file 'ENV:Sys/Wireless.prefs' -> 'ENV:Sys/Wireless.prefs'
Reading configuration file 'ENV:Sys/Wireless.prefs'
Line: 10 - start of a new network block
ssid - hexdump_ascii(len=11):
50 4a 53 77 69 72 65 6c 65 73 73 PJSwireless
key_mgmt: 0x4
Priority group 0
id=0 ssid='PJSwireless'
*** [wpa_sm_init] sm->pmksa=0x55e2d824 ***
Own MAC address: 00:1b:2f:cf:ba:a7
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
Added interface atheros5000.device:0
State: DISCONNECTED -> SCANNING
Starting AP scan for wildcard SSID
MLME: starting scan
MLME: scan channel 1 (2412 MHz)
sana2: sending MLME frame

When I tried starting the network, it times out like this:
Quote:
6.aSYS:> AddNetInterface DEVS:NetInterfaces/~(#?.info)
Interface "interface" added.
Trying interface "interface" configuration...
AddNetInterface: Interface "interface" configuration attempt timed out.
6.aSYS:>

This was the same result with all my tests... I have Internet Prefs
simply configured to use the atheros driver with a dynamic DHCP connection.

So I rebooted, installed the vanilla v15 driver (from OS4Depot), ran WM
again, and I got this:
Quote:
5.aSYS:> c:WirelessManager atheros5000.device VERBOSE
Initializing interface 'atheros5000.device:0' conf 'ENV:Sys/Wireless.prefs' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file 'ENV:Sys/Wireless.prefs' -> 'ENV:Sys/Wireless.prefs'
Reading configuration file 'ENV:Sys/Wireless.prefs'
Line: 10 - start of a new network block
ssid - hexdump_ascii(len=11):
50 4a 53 77 69 72 65 6c 65 73 73 PJSwireless
key_mgmt: 0x4
Priority group 0
id=0 ssid='PJSwireless'
*** [wpa_sm_init] sm->pmksa=0x5af83824 ***
Own MAC address: 00:1b:2f:cf:ba:a7
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
Added interface atheros5000.device:0
State: DISCONNECTED -> SCANNING
Starting AP scan for wildcard SSID
MLME: starting scan
MLME: scan channel 1 (2412 MHz)
sana2: sending MLME frame

Finally, seeing the line above about "wpa" (my network is now open),
I thought maybe results might be different if I tried an encrypted
network. So I rebooted, changed the network to WEP and the
ENVARC:sys/wireless.prefs file. I tried WM again and got this:
Quote:
6.aSYS:> c:WirelessManager atheros5000.device VERBOSE
Initializing interface 'atheros5000.device:0' conf 'ENV:Sys/Wireless.prefs' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file 'ENV:Sys/Wireless.prefs' -> 'ENV:Sys/Wireless.prefs'
Reading configuration file 'ENV:Sys/Wireless.prefs'
Line: 15 - start of a new network block
ssid - hexdump_ascii(len=11):
50 4a 53 77 69 72 65 6c 65 73 73 PJSwireless
key_mgmt: 0x4
wep_key0 - hexdump(len=13): [REMOVED]
wep_tx_keyidx=0 (0x0)
Priority group 0
id=0 ssid='PJSwireless'
*** [wpa_sm_init] sm->pmksa=0x581f9824 ***
Own MAC address: 00:1b:2f:cf:ba:a7
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
Added interface atheros5000.device:0
State: DISCONNECTED -> SCANNING
Starting AP scan for wildcard SSID
MLME: starting scan
MLME: scan channel 1 (2412 MHz)
sana2: sending MLME frame

As always, trying to AddNetInterface, things just timed out. In
all cases I rebooted before each test.

Thanks,

PJS

   Report Go to top

Re: Atheros WLAN driver success/failures
Just popping in
Joined:
2008/9/20 23:50
Posts: 65
@pjs

It looks like you have the same problem as utri007. As I said to him:

Do other cards work in that PCI slot? E.g. an old RTL8139 or SoundBlaster. If so, do they get the same interrupt number? Also, what range are the interrupts for other PCI devices in?

EDIT: In general have SAM owners had any problems using other PCI cards?

   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 369
I haven't heard any problems with PCI card, could this be usefull?

http://amigaworld.net/modules/news/article.php?storyid=5816

I made a search sam ep pci on amigaworld, it was only match.

I'm running that utility on my startup, I also tested d-link without it running in background.

On my sam, I don't have any problems with addnetinterface, it work nicely.

   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2006/12/2 1:41
From VA, USA
Posts: 289
Hi ncafferkey,
Quote:
ncafferkey wrote:

Do other cards work in that PCI slot?
E.g. an old RTL8139 or SoundBlaster. If so, do they get the same interrupt number?
Also, what range are the interrupts for other PCI devices in?
Yes, indeed other PCI cards work in my SAM... The Amigakit prism card, even.
Just for not very long. It typically dies after a while (0.5-6 hours). My
experience with that was reported in this thread:

http://www.amigans.net/modules/xforum ... t_id=76630#forumpost76630

FWIW, I'm posting this via the prism card.

I looked at the prism card in Ranger and if this is the right item, this is what I saw:
Quote:
vendor: 0x1260 (N/A)
Cacheline Size: 32 bytes
Line: 0x32 Pin: A Number: 66
Resource Ranges: # = 0, Base = 0xa0023000, Physical = 0xa0023000, Size = 4096, Flags = PreFetch Mem
Just for the sake of testing, I ran WM manually on the prism and got this:
Quote:
5.aSYS:> c:WirelessManager prism2.device VERBOSE
Initializing interface 'prism2.device:0' conf 'ENV:Sys/Wireless.prefs' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file 'ENV:Sys/Wireless.prefs' -> 'ENV:Sys/Wireless.prefs'
Reading configuration file 'ENV:Sys/Wireless.prefs'
Line: 10 - start of a new network block
ssid - hexdump_ascii(len=11):
50 4a 53 77 69 72 65 6c 65 73 73 PJSwireless
key_mgmt: 0x4
Priority group 0
id=0 ssid='PJSwireless'
*** [wpa_sm_init] sm->pmksa=0x58f91814 ***
Own MAC address: 00:0e:6a:7a:e8:8c
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
Added interface prism2.device:0
State: DISCONNECTED -> SCANNING
Starting AP scan for wildcard SSID
BSS: Start scan result update 1
BSS: Add new id 0 BSSID 68:7f:74:92:6f:a7 SSID 'myfreedom'
BSS: Add new id 1 BSSID 28:c6:8e:a7:4b:10 SSID '87S4EOO9'
BSS: Add new id 2 BSSID 94:44:52:5e:f3:42 SSID 'REAL'
BSS: Add new id 3 BSSID b8:8d:12:60:c8:23 SSID 'Apachejoel'
BSS: Add new id 4 BSSID e2:91:f5:05:c9:94 SSID 'NETGEAR_EXT'
BSS: Add new id 5 BSSID 20:e5:2a:f4:0c:8c SSID 'RED27'
BSS: Add new id 6 BSSID 00:24:b2:1e:10:24 SSID 'zRocket'
BSS: Add new id 7 BSSID 00:1c:10:20:b2:0e SSID 'linksys_SES_12386'
BSS: Add new id 8 BSSID 00:18:e7:f5:74:ea SSID 'PJSwireless'
BSS: Add new id 9 BSSID 00:1f:f3:c2:42:7d SSID 'Network'
New scan results available
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 68:7f:74:92:6f:a7 ssid='myfreedom' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - no WPA/RSN IE
1: 28:c6:8e:a7:4b:10 ssid='87S4EOO9' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - no WPA/RSN IE
2: 94:44:52:5e:f3:42 ssid='REAL' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - no WPA/RSN IE
3: b8:8d:12:60:c8:23 ssid='Apachejoel' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - no WPA/RSN IE
4: e2:91:f5:05:c9:94 ssid='NETGEAR_EXT' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - no WPA/RSN IE
5: 20:e5:2a:f4:0c:8c ssid='RED27' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - no WPA/RSN IE
6: 00:24:b2:1e:10:24 ssid='zRocket' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - no WPA/RSN IE
7: 00:1c:10:20:b2:0e ssid='linksys_SES_12386' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - no WPA/RSN IE
8: 00:18:e7:f5:74:ea ssid='PJSwireless' wpa_ie_len=0 rsn_ie_len=0 caps=0x421
skip - no WPA/RSN IE
9: 00:1f:f3:c2:42:7d ssid='Network' wpa_ie_len=0 rsn_ie_len=0 caps=0x421
skip - no WPA/RSN IE
Try to find non-WPA AP
0: 68:7f:74:92:6f:a7 ssid='myfreedom' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - SSID mismatch
1: 28:c6:8e:a7:4b:10 ssid='87S4EOO9' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - SSID mismatch
2: 94:44:52:5e:f3:42 ssid='REAL' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - SSID mismatch
3: b8:8d:12:60:c8:23 ssid='Apachejoel' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - SSID mismatch
4: e2:91:f5:05:c9:94 ssid='NETGEAR_EXT' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - SSID mismatch
5: 20:e5:2a:f4:0c:8c ssid='RED27' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - SSID mismatch
6: 00:24:b2:1e:10:24 ssid='zRocket' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - SSID mismatch
7: 00:1c:10:20:b2:0e ssid='linksys_SES_12386' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - SSID mismatch
8: 00:18:e7:f5:74:ea ssid='PJSwireless' wpa_ie_len=0 rsn_ie_len=0 caps=0x421
selected non-WPA AP 00:18:e7:f5:74:ea ssid='PJSwireless'
Trying to associate with 00:18:e7:f5:74:ea (SSID='PJSwireless' freq=2412 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: clearing own WPA/RSN IE
No keys have been configured - skip key clearing
State: SCANNING -> ASSOCIATING
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - EAP fail=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portControl=ForceAuthorized
EAPOL: Supplicant port status: Unauthorized
Association info event
req_ies - hexdump(len=2): 00 00
WPA: clearing own WPA/RSN IE
State: ASSOCIATING -> ASSOCIATED
Associated to a new BSS: BSSID=00:18:e7:f5:74:ea
Associated with 00:18:e7:f5:74:ea
WPA: Association event - clear replay counter
WPA: Clear old PTK
EAPOL: External notification - portEnabled=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portValid=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state S_FORCE_AUTH
EAPOL: Supplicant port status: Authorized
EAPOL: SUPP_BE entering state IDLE
Cancelling authentication timeout
State: ASSOCIATED -> COMPLETED
CTRL-EVENT-CONNECTED - Connection to 00:18:e7:f5:74:ea completed (auth) [id=0 id_str=]
Cancelling scan request
EAPOL: disable timer tick


Thanks,

PJS


   Report Go to top

Re: Atheros WLAN driver success/failures
Just popping in
Joined:
2008/9/20 23:50
Posts: 65
@pjs & utri007:

Do either of you have Linux installed on your SAMs? If so, do your Atheros cards work under Linux?

Reports are welcome from anyone else too, or are there only two SAM owners with an interest in wireless networking?

   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2006/12/2 1:41
From VA, USA
Posts: 289
Linux???


Wassat???

;)

Sorry, no. Only AmigaOS on my Amigas.

Bear in mind, this isn't a SAM specific problem - the
atheros driver wasn't working in my X1K either.

Thanks,

PJS


   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 369
I don't have linux installed either, I'm simply not a interested.

   Report Go to top

Re: Atheros WLAN driver success/failures
Just popping in
Joined:
2008/9/20 23:50
Posts: 65
Quote:

pjs wrote:

Bear in mind, this isn't a SAM specific problem - the
atheros driver wasn't working in my X1K either.


But the problem in the X1000 appears to be different, as it partially works for you.

   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2006/12/2 1:41
From VA, USA
Posts: 289
Hi ncafferkey,

Quote:
ncafferkey wrote:
But the problem in the X1000 appears to be different, as it partially works for you.


Agreed, yes it is.

FWIW, I took the atheros card to my office, plugged it into
my A1-XE and it's mostly working here. This is with the
v15 driver from OS4Depot.

The only drawback is that I have to cold boot and then warm
boot to get the machine started with the card in, but I
think this may be a problem with UBoot variables.

If it helps any, I started the network manually and here's
the feedback I got from WM:
Quote:

Initializing interface 'atheros5000.device:0' conf 'ENV:Sys/Wireless.prefs' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file 'ENV:Sys/Wireless.prefs' -> 'ENV:Sys/Wireless.prefs'
Reading configuration file 'ENV:Sys/Wireless.prefs'
Line: 15 - start of a new network block
ssid - hexdump_ascii(len=14):
50 4a 53 77 69 72 65 6c 65 73 73 4e 65 74 PJSwirelessNet
key_mgmt: 0x4
wep_key0 - hexdump(len=13): [REMOVED]
wep_tx_keyidx=0 (0x0)
Priority group 0
id=0 ssid='PJSwirelessNet'
*** [wpa_sm_init] sm->pmksa=0x64396824 ***
Own MAC address: 00:1b:2f:cf:ba:a7
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
Added interface atheros5000.device:0
State: DISCONNECTED -> SCANNING
Starting AP scan for wildcard SSID
MLME: starting scan
MLME: scan channel 1 (2412 MHz)
sana2: sending MLME frame
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
MLME: scan channel 2 (2417 MHz)
sana2: sending MLME frame
MLME: scan channel 3 (2422 MHz)
sana2: sending MLME frame
Unknown Broadcom information element ignored (type=52 len=26)

unknown vendor specific information element ignored (vendor OUI 00:03:7f len=9)
unknown vendor specific information element ignored (vendor OUI 00:03:7f len=10)
MLME: scan channel 4 (2427 MHz)
sana2: sending MLME frame
Unknown Broadcom information element ignored (type=52 len=26)

unknown vendor specific information element ignored (vendor OUI 00:03:7f len=9)
unknown vendor specific information element ignored (vendor OUI 00:03:7f len=10)
Unknown Broadcom information element ignored (type=52 len=26)

unknown vendor specific information element ignored (vendor OUI 00:03:7f len=9)
unknown vendor specific information element ignored (vendor OUI 00:03:7f len=10)
MLME: scan channel 5 (2432 MHz)
sana2: sending MLME frame
MLME: scan channel 6 (2437 MHz)
sana2: sending MLME frame
Unknown Broadcom information element ignored (type=52 len=26)

unknown vendor specific information element ignored (vendor OUI 00:03:7f len=9)
unknown vendor specific information element ignored (vendor OUI 00:03:7f len=10)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
MLME: scan channel 7 (2442 MHz)
sana2: sending MLME frame
MLME: scan channel 8 (2447 MHz)
sana2: sending MLME frame
MLME: scan channel 9 (2452 MHz)
sana2: sending MLME frame
MLME: scan channel 10 (2457 MHz)
sana2: sending MLME frame
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=6)
MLME: scan channel 11 (2462 MHz)
sana2: sending MLME frame
MLME: scan channel 12 (2467 MHz)
sana2: sending MLME frame
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
MLME: scan channel 13 (2472 MHz)
sana2: sending MLME frame
EAPOL: disable timer tick
EAPOL: Supplicant port status: Unauthorized
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
MLME: scan channel 14 (2484 MHz)
sana2: sending MLME frame
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
Unknown Broadcom information element ignored (type=52 len=26)

MLME: scan channel 1 (2412 MHz)
sana2: sending MLME frame
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=11)
MLME: scan channel 2 (2417 MHz)
sana2: sending MLME frame
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=11)
Unknown Broadcom information element ignored (type=52 len=26)

unknown vendor specific information element ignored (vendor OUI 00:03:7f len=9)
unknown vendor specific information element ignored (vendor OUI 00:03:7f len=10)
MLME: scan channel 3 (2422 MHz)
sana2: sending MLME frame
Unknown Broadcom information element ignored (type=52 len=26)

unknown vendor specific information element ignored (vendor OUI 00:03:7f len=9)
unknown vendor specific information element ignored (vendor OUI 00:03:7f len=10)
MLME: scan channel 4 (2427 MHz)
sana2: sending MLME frame
MLME: scan channel 5 (2432 MHz)
sana2: sending MLME frame
MLME: scan channel 6 (2437 MHz)
sana2: sending MLME frame
Unknown Broadcom information element ignored (type=52 len=26)

unknown vendor specific information element ignored (vendor OUI 00:03:7f len=9)
unknown vendor specific information element ignored (vendor OUI 00:03:7f len=10)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
MLME: scan channel 7 (2442 MHz)
sana2: sending MLME frame
MLME: scan channel 8 (2447 MHz)
sana2: sending MLME frame
MLME: scan channel 9 (2452 MHz)
sana2: sending MLME frame
MLME: scan channel 10 (2457 MHz)
sana2: sending MLME frame
MLME: scan channel 11 (2462 MHz)
sana2: sending MLME frame
MLME: scan channel 12 (2467 MHz)
sana2: sending MLME frame
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=11)
unknown vendor specific information element ignored (vendor OUI 00:10:18 len=9)
Unknown Broadcom information element ignored (type=52 len=26)

MLME: scan channel 13 (2472 MHz)
sana2: sending MLME frame
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=11)
unknown vendor specific information element ignored (vendor OUI 00:03:93 len=7)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=14)
unknown vendor specific information element ignored (vendor OUI 00:17:f2 len=11)
MLME: scan completed
BSS: Start scan result update 1
BSS: Add new id 0 BSSID 00:7f:28:99:51:13 SSID 'LFZ7J'
BSS: Add new id 1 BSSID 7c:d1:c3:d1:51:d8 SSID 'METE Network'
BSS: Add new id 2 BSSID 1c:af:f7:dc:ad:29 SSID 'pewettco'
BSS: Add new id 3 BSSID c0:3f:0e:76:c4:f3 SSID 'Ellens Network'
BSS: Add new id 4 BSSID 68:7f:74:21:43:d5 SSID 'equallevel3'
BSS: Add new id 5 BSSID c0:3f:0e:8e:bc:5c SSID 'CTP'
BSS: Add new id 6 BSSID 0a:90:7f:8a:c7:24 SSID 'FR'
BSS: Add new id 7 BSSID 00:12:17:19:39:ee SSID 'ABS'
BSS: Add new id 8 BSSID 00:04:e2:ad:1e:40 SSID 'PJSwirelessNet'
New scan results available
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 00:7f:28:99:51:13 ssid='LFZ7J' wpa_ie_len=0 rsn_ie_len=24 caps=0x411
skip - SSID mismatch
1: 7c:d1:c3:d1:51:d8 ssid='METE Network' wpa_ie_len=0 rsn_ie_len=20 caps=0x1431
skip - SSID mismatch
2: 1c:af:f7:dc:ad:29 ssid='pewettco' wpa_ie_len=26 rsn_ie_len=24 caps=0x431
skip - SSID mismatch
3: c0:3f:0e:76:c4:f3 ssid='Ellens Network' wpa_ie_len=26 rsn_ie_len=24 caps=0x431
skip - SSID mismatch
4: 68:7f:74:21:43:d5 ssid='equallevel3' wpa_ie_len=28 rsn_ie_len=24 caps=0x411
skip - SSID mismatch
5: c0:3f:0e:8e:bc:5c ssid='CTP' wpa_ie_len=0 rsn_ie_len=20 caps=0x431
skip - SSID mismatch
6: 0a:90:7f:8a:c7:24 ssid='FR' wpa_ie_len=26 rsn_ie_len=0 caps=0x411
skip - SSID mismatch
7: 00:12:17:19:39:ee ssid='ABS' wpa_ie_len=24 rsn_ie_len=0 caps=0x411
skip - SSID mismatch
8: 00:04:e2:ad:1e:40 ssid='PJSwirelessNet' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - no WPA/RSN IE
Try to find non-WPA AP
0: 00:7f:28:99:51:13 ssid='LFZ7J' wpa_ie_len=0 rsn_ie_len=24 caps=0x411
skip - SSID mismatch
1: 7c:d1:c3:d1:51:d8 ssid='METE Network' wpa_ie_len=0 rsn_ie_len=20 caps=0x1431
skip - SSID mismatch
2: 1c:af:f7:dc:ad:29 ssid='pewettco' wpa_ie_len=26 rsn_ie_len=24 caps=0x431
skip - SSID mismatch
3: c0:3f:0e:76:c4:f3 ssid='Ellens Network' wpa_ie_len=26 rsn_ie_len=24 caps=0x431
skip - SSID mismatch
4: 68:7f:74:21:43:d5 ssid='equallevel3' wpa_ie_len=28 rsn_ie_len=24 caps=0x411
skip - SSID mismatch
5: c0:3f:0e:8e:bc:5c ssid='CTP' wpa_ie_len=0 rsn_ie_len=20 caps=0x431
skip - SSID mismatch
6: 0a:90:7f:8a:c7:24 ssid='FR' wpa_ie_len=26 rsn_ie_len=0 caps=0x411
skip - SSID mismatch
7: 00:12:17:19:39:ee ssid='ABS' wpa_ie_len=24 rsn_ie_len=0 caps=0x411
skip - SSID mismatch
8: 00:04:e2:ad:1e:40 ssid='PJSwirelessNet' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
selected non-WPA AP 00:04:e2:ad:1e:40 ssid='PJSwirelessNet'
Trying to associate with 00:04:e2:ad:1e:40 (SSID='PJSwirelessNet' freq=2452 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: clearing own WPA/RSN IE
No keys have been configured - skip key clearing
State: SCANNING -> ASSOCIATING
MLME: Initial auth_alg=0
MLME: authenticate with AP 00:04:e2:ad:1e:40
sana2: sending MLME frame
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - EAP fail=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portControl=ForceAuthorized
EAPOL: Supplicant port status: Unauthorized
MLME: RX authentication from 00:04:e2:ad:1e:40 (alg=0 transaction=2 status=0)
MLME: authenticated
MLME: associate with AP 00:04:e2:ad:1e:40
sana2: sending MLME frame
MLME: RX AssocResp from 00:04:e2:ad:1e:40 (capab=0x431 status=0 aid=2)
MLME: associated
Association info event
req_ies - hexdump(len=32): 00 0e 50 4a 53 77 69 72 65 6c 65 73 73 4e 65 74 01 08 02 04 0b 16 0c 12 18 24 32 04 30 48 60 6c
resp_ies - hexdump(len=16): 01 04 82 84 8b 96 32 08 0c 12 18 24 30 48 60 6c
freq=2452 MHz
WPA: clearing own WPA/RSN IE
State: ASSOCIATING -> ASSOCIATED
Associated to a new BSS: BSSID=00:04:e2:ad:1e:40
Associated with 00:04:e2:ad:1e:40
WPA: Association event - clear replay counter
WPA: Clear old PTK
EAPOL: External notification - portEnabled=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portValid=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state S_FORCE_AUTH
EAPOL: Supplicant port status: Authorized
EAPOL: SUPP_BE entering state IDLE
Cancelling authentication timeout
State: ASSOCIATED -> COMPLETED
CTRL-EVENT-CONNECTED - Connection to 00:04:e2:ad:1e:40 completed (auth) [id=0 id_str=]
Cancelling scan request
sana2: setting negotiate


As I said, the network is working and I've got a continuous
ping running to my router. The only running hickup I see
is the occasional "(DUP!)" in the ping returns.

Thanks & I hope this helps,

PJS

   Report Go to top

Re: Atheros WLAN driver success/failures
Just popping in
Joined:
2006/12/9 15:47
From The Bostin' Black Country
Posts: 111
Hi Neil,
Quote:
are there only two SAM owners with an interest in wireless networking?


I'm very keen to get wireless up and running on my SAMep, but it's in a tiny case so would need a low profile card (or preferably a USB dongle). Any ideas on which one to get? I'm happy to splash out on a couple of different ones to try out and pay for a working driver.


_________________
Happiness is mandatory
   Report Go to top

Re: Atheros WLAN driver success/failures
Just popping in
Joined:
2010/1/11 11:57
From Highway 61
Posts: 57
@ Neil,

"are there only two SAM owners with an interest in wireless networking?"

I am interested also in wireless networking.

In answer to other pci cards working, I have a Netgear that works with the prism driver.

Best Regards

   Report Go to top

Re: Atheros WLAN driver success/failures
Just popping in
Joined:
2008/9/20 23:50
Posts: 65
Quote:

yoodoo2 wrote:

I'm very keen to get wireless up and running on my SAMep, but it's in a tiny case so would need a low profile card (or preferably a USB dongle). Any ideas on which one to get? I'm happy to splash out on a couple of different ones to try out and pay for a working driver.


There should be some cards available with a low-profile bracket, but you should probably wait until the problems other SAM users have with Atheros cards are resolved. There are no USB WiFi dongles available that have Amiga drivers unfortunately.

   Report Go to top

Re: Atheros WLAN driver success/failures
Just popping in
Joined:
2008/9/20 23:50
Posts: 65
Quote:

pjs wrote:

FWIW, I took the atheros card to my office, plugged it into
my A1-XE and it's mostly working here. This is with the
v15 driver from OS4Depot.

The only drawback is that I have to cold boot and then warm
boot to get the machine started with the card in, but I
think this may be a problem with UBoot variables.


If this happens when the driver isn't started during boot, then you're probably right. Thanks for doing the tests.

   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2011/11/29 0:54
From Norway
Posts: 305
i'm also interested in a working wifi drivers for my sam460ex. but i haven't bought any wifi card since i don't know which would work. but i do have 2-3 different wifi-usb sticks.

   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2006/12/2 1:41
From VA, USA
Posts: 289
An update on the A1-XE:

Last week I got the WPN311 installed and running on my
A1-XE and thought I'd leave it online and pinging overnight
to see how things go...

Instead it got a bit longer term test... I never got back
to the office last week and my Amiga ran all weekend with
the WPN311 up & pinging away.

I'm glad to report everything is still working today
(~96 hours later), my Amiga is still online and ping still
running. I'm looking forward to seeing this on my SAM
and X1K!

:)

Thanks ncafferkey!

PJS


   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2006/12/2 1:41
From VA, USA
Posts: 289
Just to provide some more test results, I've replaced the
WPN311 card with my Amigakit wifi card in my A1-XE to see
how it worked.

Using the v2.4 prism driver, I started WM manually and it
looks like everything fired up OK and my system is online.
Here's the WM output:

Quote:
Initializing interface 'prism2.device:0' conf 'ENV:Sys/Wireless.prefs' driver 'default' ctrl_interface 'N/A' bridge 'N/A'
Configuration file 'ENV:Sys/Wireless.prefs' -> 'ENV:Sys/Wireless.prefs'
Reading configuration file 'ENV:Sys/Wireless.prefs'
Line: 15 - start of a new network block
ssid - hexdump_ascii(len=14):
50 4a 53 77 69 72 65 6c 65 73 73 4e 65 74 PJSwirelessNet
key_mgmt: 0x4
wep_key0 - hexdump(len=13): [REMOVED]
wep_tx_keyidx=0 (0x0)
Priority group 0
id=0 ssid='PJSwirelessNet'
*** [wpa_sm_init] sm->pmksa=0x66f26814 ***
Own MAC address: 00:0e:6a:7a:e8:8c
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
Added interface prism2.device:0
State: DISCONNECTED -> SCANNING
Starting AP scan for wildcard SSID
BSS: Start scan result update 1
BSS: Add new id 0 BSSID 00:04:e2:ad:1e:40 SSID 'PJSwirelessNet'
BSS: Add new id 1 BSSID 0a:90:7f:8a:c7:24 SSID 'FR'
BSS: Add new id 2 BSSID c0:3f:0e:76:c4:f3 SSID 'Ellens Network'
BSS: Add new id 3 BSSID 1c:af:f7:dc:ad:29 SSID 'pewettco'
BSS: Add new id 4 BSSID f8:e4:fb:d9:f1:b1 SSID 'MLN7Q'
BSS: Add new id 5 BSSID 00:7f:28:99:51:13 SSID 'LFZ7J'
New scan results available
Selecting BSS from priority group 0
Try to find WPA-enabled AP
0: 00:04:e2:ad:1e:40 ssid='PJSwirelessNet' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - no WPA/RSN IE
1: 0a:90:7f:8a:c7:24 ssid='FR' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - no WPA/RSN IE
2: c0:3f:0e:76:c4:f3 ssid='Ellens Network' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - no WPA/RSN IE
3: 1c:af:f7:dc:ad:29 ssid='pewettco' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
skip - no WPA/RSN IE
4: f8:e4:fb:d9:f1:b1 ssid='MLN7Q' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - no WPA/RSN IE
5: 00:7f:28:99:51:13 ssid='LFZ7J' wpa_ie_len=0 rsn_ie_len=0 caps=0x411
skip - no WPA/RSN IE
Try to find non-WPA AP
0: 00:04:e2:ad:1e:40 ssid='PJSwirelessNet' wpa_ie_len=0 rsn_ie_len=0 caps=0x431
selected non-WPA AP 00:04:e2:ad:1e:40 ssid='PJSwirelessNet'
Trying to associate with 00:04:e2:ad:1e:40 (SSID='PJSwirelessNet' freq=2452 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: clearing AP WPA IE
WPA: clearing AP RSN IE
WPA: clearing own WPA/RSN IE
No keys have been configured - skip key clearing
State: SCANNING -> ASSOCIATING
Setting authentication timeout: 10 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - EAP fail=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portControl=ForceAuthorized
EAPOL: Supplicant port status: Unauthorized
Association info event
req_ies - hexdump(len=2): 00 00
WPA: clearing own WPA/RSN IE
State: ASSOCIATING -> ASSOCIATED
Associated to a new BSS: BSSID=00:04:e2:ad:1e:40
Associated with 00:04:e2:ad:1e:40
WPA: Association event - clear replay counter
WPA: Clear old PTK
EAPOL: External notification - portEnabled=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portValid=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portEnabled=1
EAPOL: SUPP_PAE entering state S_FORCE_AUTH
EAPOL: Supplicant port status: Authorized
EAPOL: SUPP_BE entering state IDLE
Cancelling authentication timeout
State: ASSOCIATED -> COMPLETED
CTRL-EVENT-CONNECTED - Connection to 00:04:e2:ad:1e:40 completed (auth) [id=0 id_str=]
Cancelling scan request
EAPOL: disable timer tick
BSS: Expire BSS 1 due to age
BSS: Remove id 1 BSSID 0a:90:7f:8a:c7:24 SSID 'FR'
BSS: Expire BSS 2 due to age
BSS: Remove id 2 BSSID c0:3f:0e:76:c4:f3 SSID 'Ellens Network'
BSS: Expire BSS 3 due to age
BSS: Remove id 3 BSSID 1c:af:f7:dc:ad:29 SSID 'pewettco'
BSS: Expire BSS 4 due to age
BSS: Remove id 4 BSSID f8:e4:fb:d9:f1:b1 SSID 'MLN7Q'
BSS: Expire BS

Hopefully, the Amigakit card stays online longer here than
it does on my SAM. I'll keep a shell pinging the router
and see what happens.

I hope this helps with your development.

Thanks,

PJS

   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2006/12/2 1:41
From VA, USA
Posts: 289
Another bit of good news for the drivers... It's been
24 hours and the prism's connection is still up and
running on my A1-XE with ping running continuously.

Thanks,

PJS

   Report Go to top

Re: Atheros WLAN driver success/failures
Quite a regular
Joined:
2006/11/27 17:23
Posts: 535
Today I fitted my DLink card (I think it was a G520 or something - can't remember off hand, but I can find out if people want).

Anyway, the important thing is that I'm typing this on my A1XE G4 using this card as my wi-fi!

Excellent! :)

_________________
--
Ian Gledhill
ian.gledhill@btinternit.com (except it should be internEt of course...!)
Check out my company's shop: http://www.mutant-caterpillar.co.uk/shop/ - specialising in Sinclair Spectrums but will be adding Amigas!
   Report Go to top

Re: Atheros WLAN driver success/failures
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 369
Any new about this? Has aCube answerd to you Neil?

   Report Go to top


« 1 2 3 4 (5) 6 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project