Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
81 user(s) are online (67 user(s) are browsing Forums)

Members: 0
Guests: 81

more...

Support us!

Headlines




« 1 ... 61 62 63 (64)


Re: Odyssey 1.23 progress: r5 beta07
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1101
After having played a YouTube video with Odyssey

I can confirm this weird behaviour with Emotion after having played a video with Odyssey : sometimes Emotion crashes when trying to play the video and sometimes after having played it.

Along with the GrimReaper, I got an Emotion window with this :

Stackpointer: (0x4645dd20memoryAddress0x7a0c07b0
SymbolName
CURRDIR:avutil2.library
Offset
36 Seg1 Segoffset81148    function: av_vlog    baseCURRDIR:avutil2.library
SymbolName
CURRDIR:avformat2.library
Offset
240 Seg1 Segoffset90144    function: avio_close    baseCURRDIR:avformat2.library
SymbolName
CURRDIR:avformat2.library
Offset
144 Seg1 Segoffset1039340    function: avformat_close_input    baseCURRDIR:avformat2.library
SymbolName
Emotion
Offset
3276 Seg1 Segoffset64584    function: decode_thread    baseEmotion
SymbolName
dos.library.kmod
Offset
153032    
SymbolName
kernel
Offset
270508    
SymbolName
kernel
Offset
270580


And the associated crashlog : https://amiga-ng.org/resources/CrashLo ... d_2020-06-05_04-15-33.txt

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7041
@Samo
Quote:

don't know if you ever had this specific crash


If you remember there already ticket for http://muidev.de/ticket/401. You even wrote something in as well.

@K-L
It looks like something weird happen with ffmpeg shared libraries. Most possible it Odyssey trash something which cause that, or it can be something with ffmpeg libs itself.

But sadly if it just "sometime", we then can't normally debug it :(

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1101
@Kas1e

Not sometimes. It took me some time to understand why Emotion was crashing on a regular basis and sometimes not (white's message put me on the right way to the problem since he has the same behaviour).

It is crashing if I have been using Odyssey's media player just before using Emotion.

It can be reproduced each time.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3432
@kas1e

Right, i was completely forgot it .. it was 18 month ago
So it means that one was reproducible even in old version 1.23 on os4depot

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1101
@Thread

Could someone check YouTube with Odyssey (to be sure I am not the only one with the proble)? It seems the page cannot be displayed anymore (doesn't work either with Odyssey 1.26 on MorphOS).

Google must have changed something.

When trying to play a video directly from Google, YouTube video is played but there is no possibility to switch to fullscreen.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Not too shy to talk
Joined:
2018/1/4 10:56
From Italy
Posts: 387
@K-L
@All
I have tried Odyssey (OS4.1FE) beta 07
If I close the Odyssey window when I watch a video on youtube and leave the requester open, the Emotion player works perfectly.
But if I completely exit Odyssey the Emotion player crashes
I hope it will be useful in some way, Thanks again for the work dedicated to Odyssey.

I leave the video if it can be useful:
https://www.youtube.com/watch?v=v_aLqSFvFu4


Edited by white on 2020/6/9 18:52:37
   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Quite a regular
Joined:
2007/2/6 13:57
From Donostia (SPAIN)
Posts: 637
@K-L

Seems so

Try to Spoof as IPAD and see if it works.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1101
@Thread

Well, now that we have fullscreen enabled for YouTube video, YouTube doesn't work anymore with Odyssey (no matter what you spoof with).

Too bad.

And even if you acces a video directly with its link you won't be able to switch to fullscreen and enjoy acceleration.

Edited : ah, you can switch to fullscreen if you access a video directly. You just have to right click on the vido and select "switch to fullscreen".

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 394
@K-L
Quote:
Well, now that we have fullscreen enabled for YouTube video, YouTube doesn't work anymore with Odyssey (no matter what you spoof with).

Youtube still works fine for me using Odyssey Beta 07. Sometimes it takes me to a screen that says your browser is outdated and will not be supported soon but I can click on a continue button and it takes me to the YouTube page. Has a warning at the top about outdated browser but works fine. Videos play in full screen fine as well.

Maybe try deleting your YouTube Cookies before loading the page. When playing with spoofing I have ended up with things not working and YouTube seems to use a cookies to remember your settings so things won't work again until you clear the cookies. Mine works with the user agent set to Odyssey.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7041
@All
It just time come and youtube start their changes they says about months ago. Just not in all countries changes immediately take place, but soon or later everyone will have the same issues K-L have.

What we can do there currently, it's to find out ways how to workaround it for future. Maybe some new youtube scripts need to be written which can handle that issues, etc. They surely should't abandon iPad, etc support too soon, so probabaly we firstly need to find correct spoofing and then maybe some new youtube scripts.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1101
@kas1e

Actually, there seems to be a JS error when loading YouTube' site. I don't think spoofing will help

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7041
@K-L
Youtube go more modern route not for every device. At least not for IPAD (mean it use some older JS route). That why spoofing will help at least to render something.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 899
@kas1e
Hello there. When you compiled Odyssey with gcc-10 did you have some issues like below?

/opt/code/Odyssey/odyssey-r155188-1.23/Source/WebKit/OrigynWebBrowser/Api/MorphOS/appclass.cpp:1355:8errornarrowing conversion of ‘MA_OWBApp_QuickLinkLook’ from ‘int’ to ‘long unsigned int’ [-Wnarrowing]
 
1355 |   case MA_OWBApp_QuickLinkLook:
      |        ^~~~~~~~~~~~~~~~~~~~~~~
/
opt/code/Odyssey/odyssey-r155188-1.23/Source/WebKit/OrigynWebBrowser/Api/MorphOS/appclass.cpp:1361:8errornarrowing conversion of ‘MA_OWBApp_QuickLinkLayout’ from ‘int’ to ‘long unsigned int’ [-Wnarrowing]
 
1361 |   case MA_OWBApp_QuickLinkLayout:
      |        ^~~~~~~~~~~~~~~~~~~~~~~~~
/
opt/code/Odyssey/odyssey-r155188-1.23/Source/WebKit/OrigynWebBrowser/Api/MorphOS/appclass.cpp:1367:8errornarrowing conversion of ‘MA_OWBApp_QuickLinkRows’ from ‘int’ to ‘long unsigned int’ [-Wnarrowing]
 
1367 |   case MA_OWBApp_QuickLinkRows:
      |        ^~~~~~~~~~~~~~~~~~~~~~~

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7041
@Walkero
Of course, I wrote about them in another thread as "enum" warnings. But as it just a warning, not a big deal. At least Odyssey compiled with GCC 10.1.0 works the same good as with 8.4.0.

I hope there will be some other small fixes in Odyssey pretty soon, one from Javier (in the spoofing area), and then can release beta08 compiled with gcc10

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 899
Thanks for your reply. I just wanted to be sure that you had that as well, and that's not a problem of my setup.
In my case, though, they are counted as errors and not warnings.

Also, do you plan to compile it against latest MUI?


Update:
I did a few changes that remove those issues, although I am not sure yet for the impact:

line 202 at /odyssey-r155188-1.23/Source/WebKit/OrigynWebBrowser/Api/MorphOS/mui.h

change to

while ((tag NextTagItem(&_tags))) switch ((long unsigned int)tag->ti_Tag)


line 120 at /odyssey-r155188-1.23/Source/WebKit/OrigynWebBrowser/Api/MorphOS/classes.h

change to

MA_dummy = (long unsigned int)(MTAGBASE),


line 202 at /odyssey-r155188-1.23/Source/WebKit/OrigynWebBrowser/Api/MorphOS/mui.h

change to

while ((tag NextTagItem(&_tags))) switch ((long unsigned int)tag->ti_Tag)


With the above changes I managed to compile Odyssey just fine, and seems to work so far I tested them. But as I said, as I am not that familiar with the code, those changes need your review.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 7041
@walkero
Quote:

Also, do you plan to compile it against latest MUI?


Already, over latest mui, over latest pthreads, over latest gcc and over latest newlib :)

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 899
Thanks Roman for the great work. Keep it up.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3432
@kas1e

Lot of time passed since beta 7, any chance in finishing to update the remaining dependencies and then try porting OWB 1.25 ?
Even just updating the dependencies would be cool, some sites start asking for new certs etc ..

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Just popping in
Joined:
2020/11/17 12:08
From Slough
Posts: 193
Updating root CA certs doesn't require updating the source code, heck it doesn't even require you to rebuild the app from source.

   Report Go to top

Re: Odyssey 1.23 progress: r5 beta07
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 4191
@samo79
@kas1e

I'd like to know too.

My email provider changed its website and now I'm not able to access it with Odyssey anymore.

Since there aren't any actively developed Mail apps anymore either it's going to be complicated to use email from the miggy.

   Report Go to top


« 1 ... 61 62 63 (64)



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project