Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
76 user(s) are online (63 user(s) are browsing Forums)

Members: 0
Guests: 76

more...

Support us!

Recent OS4 Files
OS4Depot.net




« 1 ... 50 51 52 (53) 54 55 56 ... 64 »


Re: Odyssey 1.23 progress
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6325
@raziel
Those "betas" just for ppls in that thread, nothing which will be placed anywhere after "r5" will be ready. I just made them so those who in interest can just test it if nothing got broken in process.

You don't need to remember any place where is it, it only just for easy download (and from amiga itself too, as from github it will be hard to download from our browsers). Once r5 will be ready, then it will be on our central "os4depot" place :)

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3719
@kas1e

Quote:

as from github it will be hard to download from our browsers

Hu?
I never heard that before.
I can download stuff from GitHub just fine, it is and was perfectly fine even with old Odyssey.

But since you'e maintaining it, it's your call

   Report Go to top

Re: Odyssey 1.23 progress
Not too shy to talk
Joined:
2018/1/4 10:56
From Italy
Posts: 260
@ kas1e
Thanks for the new beta 03 it's getting faster.
Now the links pointing to Youtube on sites like EAB etc. also work well.

I wanted to ask if it was possible in some way, to add spoffing to the following user-agent:
Mozilla / 5.0 (Nintendo WiiU) AppleWebKit / 534.52 (KTTML, like Gecko) NX / {Version No} NintendoBrowser / {Version No} .US

Or even more recent

In my example I can modify the user-agent with the following line to the user-startup

; BEGIN OWB
SETENV OWB_USER_AGENT "Mozilla/5.0 (Nintendo WiiU) AppleWebKit/534.52 (KTTML, like Gecko) NX/{Version No} NintendoBrowser/{Version No}.US"
; END OWB

but with this Beta 03 version it seems to slow down the browser, therefore I had to eliminate it from the user-startup.

Currently in my experience it seems the fastest user agent for Odyssey.

I'm probably wrong, but it seems to be faster for the 4.1FE update1.

Thanks for a possible reply.

Do you consider my comment unnecessary if it is not in line with the current project.

@All
Thank you all

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6325
@Raziel
Right, its comments didnt works in github's tickets, just messed it a bit with downloads. Maybe i can use github later too for downloads indeed.

@white
So you mean add latest Nintendo WiiU user-agent ? ok, will do so, one more agent should't do any harm.

   Report Go to top

Re: Odyssey 1.23 progress
Not too shy to talk
Joined:
2018/1/4 10:56
From Italy
Posts: 260
@ kas1e
Thanks a lot, really very much.
And thanks again for your work.

   Report Go to top

Re: Odyssey 1.23 progress
Just popping in
Joined:
2013/10/23 15:18
From Kuusamo, Finland
Posts: 92
Hi guys!
For example i am not a coder but i can support by saying thank you and maybe even click some donate buttons ...

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3719
@kas1e

Quote:

its comments didnt works in github's tickets

Now i start to wonder which user-agent you spoof with?

I can (also) comment to existing github bug tracker items just fine.

I cannot
1) create new bug tracker items (i can reach the items "editor window", but the "Post" button never appears). Have to use a PC for that.
2) edit my own comments/items. The "Edit" option (from the "..." menu) does nothing on a mouse click.
3) add smileys/reactions to posts (well, i can, but the smilies to choose from aren't displayed - they are shown as rectangles/boxes, so i don't know what i'm choosing). Seems to be some kind of unsupported gfx format.

The above are all, as far as i understand, unsupported features in css/html/javascript, so nothing we can do about, unless we get a newer webkit version (i think)

I m spoofing with IPad 13.2.3 for now, since all the others have problems with one or more sites.
Even this one i have to switch back to Odyssey, if i want to attach something to an email on my providers site...

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3335
@kas1e

Quote:
Try to unpack beta02 to ram, and then retestest everything again.


All right, extracted all versions to RAM and then retried the 2 sites
Spoofing is defaut (Odyssey Web Browser)

Downloading from https://tigerskunk.itch.io/inviyya
Works now, good

But the Dashboard of Transifex website still not, apparently it doesn't work in all versions now, including the public OWB on OS4Depot
Probably they did some changes very recently and that changes are no more compatible with our old webkit .. don't know really

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3335
@kas1e

Btw in beta03 the new variable date "#define DATE __DATE__" is wrong

It show: "Tue 16 2020"
But new date still miss the month completely

Maybe better following the original numeric scheme (day.month.year)


   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6325
@samo
Quote:

Probably they did some changes very recently and that changes are no more compatible with our old webkit .. don't know really


Usual stuff, more and more websites want new features.

Quote:

Btw in beta03 the new variable date "#define DATE __DATE__" is wrong

It show: "Tue 16 2020"


What wrong ? For me it show in the top bar :
Mar 16 2020

In the about box :
Mar 16 2020


Quote:

But new date still miss the month completely


Probably for you localisation in OS are broken, and Mar translate to some Tue, if that Tue dind't mean Mar in italian.

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6325
@all
Question : should we have by default in prefs/media all options being set to ON, instead as it now, when only fastseeking and mp4 is enabled ?

Those options when off, mean that when you click on those formats, they didn't plays in browser but bring you save-as requester to download it instead. But imho, the other way around expected to be defaul : everything enabled, and if one wish, he disable it.

So question, should i just enable them all by default ?

   Report Go to top

Re: Odyssey 1.23 progress
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 329
@kas1eQuote:
Question : should we have by default in prefs/media all options being set to ON

I vote all on since they seem to be working well.
Are there issues on slower systems than the X1000 or X5000?
People with slower systems might answer differently if they have issues.

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6325
@ktadd
But then, if you visit a page with video, you probabaly want to watch it ? And without let's say enabled webm, or ogg, you will have no ability to do so. But if you didn't visit those video pages, then it does not matter if things for media on or off, it will be the same by speed of odyssey usage.

In end, those options still will be there of course, and anyone will have a wish to not have video/audio played in browser can disable it easyly.

I just fear, some ppls unpack it, run, and then just didn't have working video/audio in some parts think "damn crap, odyssey can't play them", and they surely will not thing that to have working video/audio, they need to enabled those options (which in all other browsers everywhere just default thing).


Edited by kas1e on 2020/3/18 19:31:53
   Report Go to top

Re: Odyssey 1.23 progress
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 329
@kas1e

Agreed!

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6325
@ktadd
Also what make me curious : i tested video of webp which you point out on (that with Lava one), and there i can choice any format : webp, vp8 and vp9 too, and all works. But in prefs/media we have string "WebM (VP8) support", but then , should't it be "WebP (VP8,VP9) support" instead ?

   Report Go to top

Re: Odyssey 1.23 progress
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 329
@kas1eQuote:
Also what make me curious : i tested video of webp which you point out on (that with Lava one), and there i can choice any format : webp, vp8 and vp9 too, and all works. But in prefs/media we have string "WebM (VP8) support", but then , should't it be "WebP (VP8,VP9) support" instead ?

VP9 Codec is the successor to VP8 and was released in 2017. Since we can play it, go ahead and add it.

   Report Go to top

Re: Odyssey 1.23 progress
Quite a regular
Joined:
2007/2/6 13:57
From Donostia (SPAIN)
Posts: 543
@kas1e

If it supports "new" webp modes, maybe due 'cos you updated webp support, just changing the string in catalog/cd/ct to "WebP (VP8,VP9) support" will be nice.

I tried yotube on my SAM460ex it crawls, but doesn't freeze/crash as on your system, I'm using bultin sound sm502 (IIRC).

Will try yhat web page with webp video and see what happens.

THX everyone testing and kas1e to take time to update Odyssey, thx!!!!

   Report Go to top

Re: Odyssey 1.23 progress
Not too shy to talk
Joined:
2006/12/6 20:39
From California, Unitied States
Posts: 329
@kas1e @All

Found a good HTML5 Video/Audio test page with many different containers formats and video/audio codecs. Says it's mainly for Crome and Firefox so spoofing as those might help. Webm also supports a newer codec AV1 but we are not able to play it. You might even get a crash while trying to.

https://tools.woolyss.com/html5-audio-video-tester/

Have at it.

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3335
@kas1e

Quote:
Probably for you localisation in OS are broken, and Mar translate to some Tue, if that Tue dind't mean Mar in italian


Right, abbreviation of the letters for the day and the name of the month are the same in italian, also the order of the month/number of day is inverted in english compared to what it will be in italian so this probably can lead to some confusion :)

What wrong about reusing the old but very standard scheme for the date ?
like: 16.03.2020

   Report Go to top

Re: Odyssey 1.23 progress
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6325
@samo
Quote:

What wrong about reusing the old but very standard scheme for the date ?

That just need properly done stuff: need to create version.c , which will be always compiled does not matter if other files touched or not (so compilation date will be taken from every compile) , and that in turn mean needs to change a bit CMakefiles and some other stuff so makefiles for odyssey (at least for the amiga parts) will be generated with that force-to-compile version.c file with necessary flag to provide date.

That all easy, just boring stuff which can be done later, and instead i just use inbuild __DATE__ macro of GCC which have that format you see now

   Report Go to top


« 1 ... 50 51 52 (53) 54 55 56 ... 64 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project