Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
77 user(s) are online (58 user(s) are browsing Forums)

Members: 0
Guests: 77

more...

Headlines




« 1 2 (3)


Re: AmigaOne 500 audio is slow
Just popping in
Joined:
2012/8/25 10:27
From Southampton, UK
Posts: 34
Thanks Hans.

Does anyone know if the single lane PCI-E slot is useable either for an alternative sound card?

Lawrence

   Report Go to top

Re: AmigaOne 500 audio is slow
Home away from home
Joined:
2007/5/19 14:23
From England
Posts: 3555
@Hans Quote:
The slight audio gaps occur only with PlayCD. Playing the CD via Tunenet works fine. The gaps still shouldn't happen, though.

My guess is that PlayCD is using a different AHI frequency to Tunenet. Perhaps only certain frequencies are supported, and all others get (badly) approximated by the closest supported frequency?

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: AmigaOne 500 audio is slow
Just can't stay away
Joined:
2006/11/30 11:30
From Finland
Posts: 1804
@ChrisH

Quote:

My guess is that PlayCD is using a different AHI frequency to Tunenet. Perhaps only certain frequencies are supported, and all others get (badly) approximated by the closest supported frequency?


Since PlayCD plays CDDA data which is raw 16-bit PCM at 44.1KHz I would assume that the frequency used is 44100Hz. If the frequency in AHI audio prefs is set to something like 48000Hz this will lead to some degradation in audio quality due to resampling, the exact amount depending on what interpolation technique AHI uses.

   Report Go to top

Re: AmigaOne 500 audio is slow
Just popping in
Joined:
2009/11/25 1:08
Posts: 58
Quote:
Does anyone know if the single lane PCI-E slot is useable either for an alternative sound card?

Lawrence


Apparently it is not available for bi-directional use. This is what I have gathered from reading here. Unfortunately. The onboard SM502 audio on my sam board is not working properly and there is no way to circumvent it. I have simply given up until a properly functioning driver has been released or the operating system has support for PCI-E.

   Report Go to top

Re: AmigaOne 500 audio is slow
Quite a regular
Joined:
2006/12/2 0:35
From Sydney
Posts: 698
@salass00:

The sampling frequency within AHI prefs is fixed at 48 kHz for the SM502. That may be why there are glitches in the transformation.

PlayCD reads one-second bufferloads of data from the CD into two buffers and swaps them when AHI interrupts to say the previous one is free. Since the clicks can occur more often than once per second, I imagine they are being generated within AHI or the driver.

The same PlayCD binary runs OK on a slower Sam 440, so it's not the app's fault.

_________________
cheers
tony
   Report Go to top

Re: AmigaOne 500 audio is slow
Just can't stay away
Joined:
2006/12/9 10:44
From Lyon, France
Posts: 1341
Quote:
The sampling frequency within AHI prefs is fixed at 48 kHz for the SM502.


It's not a bug but it's the frequency the SM502 uses.

_________________
Philippe 'Elwood' FERRUCCI
Sam460ex 1.10 Ghz
http://elwoodb.free.fr
   Report Go to top

Re: AmigaOne 500 audio is slow
Just popping in
Joined:
2012/8/25 10:27
From Southampton, UK
Posts: 34
Quote:

graffias79 wrote:

Apparently it is not available for bi-directional use. This is what I have gathered from reading here. Unfortunately. The onboard SM502 audio on my sam board is not working properly and there is no way to circumvent it. I have simply given up until a properly functioning driver has been released or the operating system has support for PCI-E.


Darn it. I'd "happily" spend another 40quid for working sound. I would mind less if USB sound was available as I have a nice dongle around. Probably the worst of all situations, but right now my SAM460 has no speakers plugged in because I don't want to hear either crackly or slow sound.

Maybe a SAM440 would have been a better choice overall. An amiga without sound is not an amiga....

Lawrence

   Report Go to top

Re: AmigaOne 500 audio is slow
Just popping in
Joined:
2006/12/1 12:20
From Anzio (Rome), Italy
Posts: 115
To everyone interested: I've implemented I/O access over PCI-E in the AmigaOS4.1 Sam460ex kernel some days ago, it will be available in a "next" OS update.

It will be possible to use the PCI-E 1x slot directly with supported cards (audio and SATA for example), or via a PCI-E to PCI adapter.

_________________
Max Tretene, ACube Systems Srl, Soft3
   Report Go to top

Re: AmigaOne 500 audio is slow
Not too shy to talk
Joined:
2006/12/2 0:31
From Poland
Posts: 327
Great! Very good news

_________________
Sam440 flex 800MHz RAM 1GB R9250 128MB OS4.1 SBLive! ->
   Report Go to top

Re: AmigaOne 500 audio is slow
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 209
This is a marvelous news !

_________________
Sam 460EX, 2Gb Ram, Radeon R7 250, AmigaOS4.1 FE
A4000 PPC604@233, Mediator
A1200 PPC603@160, Mediator
uA1 G3@800, 512 Mb [sold]
   Report Go to top

Re: AmigaOne 500 audio is slow
Just popping in
Joined:
2009/11/25 1:08
Posts: 58
Quote:

m3x wrote:
To everyone interested: I've implemented I/O access over PCI-E in the AmigaOS4.1 Sam460ex kernel some days ago, it will be available in a "next" OS update.

It will be possible to use the PCI-E 1x slot directly with supported cards (audio and SATA for example), or via a PCI-E to PCI adapter.


Thank you so very much!

   Report Go to top


« 1 2 (3)



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project