Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
75 user(s) are online (56 user(s) are browsing Forums)

Members: 0
Guests: 75

more...

Support us!

Recent OS4 Files
OS4Depot.net






MiniGL4GL4ES v3.5 and Blender v248.7 issues
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 630
Hello guys.
There are a few issues running Blender v248.7 with the latest MiniGL4GL4ES v3.5, where no texts are visible in blender and no menus seem to work. Is it a know issue? Is there a possibility to have a fix for that?

   Report Go to top

Re: MiniGL4GL4ES v3.5 and Blender v248.7 issues
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6354
@Walkero
That is a known issue. Minigl4gl4es is not reentrant and if Daniel will make it be so is unknown. Probably issues with Blender are related (as it runs some different minigl processes if I remember right). But even if the issue is different, without being reentrant, going further makes no big sense.

The list of known issues are:


1. Window/Fullscreen issues

-- RTCW: no window mode works (works over original MiniGL)

-- Torcs: switching to fullscreen works, but then switching to window mode back crashes in mglut.library. Running in fullscreen by default and then switch to window mode: crash. So currently we can switch to fullscreen, but can't switch to window mode.


2. General:

-- can't run many MiniGL apps at the same time

-- Any app/game may crash on running if before you run/exit/run/exit some other minigl4gl4es app. Can happens with all games (with original MiniGL no such crash, can run/exit many times). It can be easy because "can't run many MiniGL apps at one time". Easy to reproduce is to run "prefs:screenblankers" and in the "active modules" window go through them one by one, and it will crash sooner than later.


3. Crashes/issues:

-- Blender: no menu visibly, black thumbs in the items -> can be because "can't run many MiniGL apps at the same time".

-- SuperTuxKart 0.6.2: crash in ogles2.library when actual race should starts. Checking that with debug version of ogles2.library point out on : ContextSmartSubmit(). The same code builds with gl4es of the same version which in minigl4gl4es didn't cause a crash there. It is probably something with minigl4gl4es.

-- UFO AI: crashes on running. Before it dies in the console we have "max texture size: detected 16384, but using 1024 as requested" and then crash. On original MiniGL after that libsdl_ttf.so loads and things continue. Maybe related to a fact, that .so should be loaded (so do things with loading another "library" inside of the MiniGL app) and maybe that causes issues. It shows 0xABADCAFC everywhere, which mean that we have accessed uninitialized memory.

-- Shogo crashes on running (works with original MiniGL). In the crash log, we can see that registers point on module Work:games/Shogo/mgl.ren, which is executable, which mean that probably Shogo tries to run "another MiniGL app" which and cause then crash.

-- Lariard: crashes on running with "0x00000000 symbol not found", just show a black screen and bah (works with original MiniGL)

-- ScummVM: crashes when choice "OpenGL renderer" with the same 0x00000000 symbol not found.

-- Frogatto: missing textures, some areas just a black, some areas transparent. It can be as well gl4es issue.

-- Boingball blanker crash on deactivation.


So as you can see, almost all issues related "we can't run more than one mgl4gl4es app". Once that will be deal with, probably almost all bugs gone. But will it happens or not, only Daniel and his motivation to do so known :)

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: MiniGL4GL4ES v3.5 and Blender v248.7 issues
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 630
@kas1e
Thank you for your reply and for gathering here all the known issues.

I am sure Daniel is going to do the best he can for all of us to be happy :D

   Report Go to top

Re: MiniGL4GL4ES v3.5 and Blender v248.7 issues
Not too shy to talk
Joined:
2011/6/3 13:49
Posts: 264
There was the same problem with blender/wazp3d
Was long ago but I remember blender need "direct to bitmap" drawing and "no indirect mode" = I mean each menu is fully drawn then next menu, so need a "flush" after each "drawprimitive"
Looks like menu drawing in blender is poorly coded and should have included a kinda "flush" for this drawing operation

   Report Go to top

Re: MiniGL4GL4ES v3.5 and Blender v248.7 issues
Not too shy to talk
Joined:
2015/6/11 9:51
From Cologne
Posts: 378
@walkero
Well, it's a dirty hack, an emergeny sort-of solution for those Polaris cards without classic W3D support (which I wouldn't recommend anybody with interest in older Amiga 3D stuff to buy at this time, better go for SI for best 3D support). And I certainly won't find time to make GL4ES reentrant and MiniGL4GL4ES more compatible / stable in the foreseeable future.

@thellier
Could well be that on top of that Blender would need some special treatment.

   Report Go to top





[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project