Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
87 user(s) are online (82 user(s) are browsing Forums)

Members: 1
Guests: 86

tarzin, more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 (3) 4 5 6 ... 10 »


Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2007/7/23 20:35
Posts: 628
Has anyone had any luck resolving these issues?
Wondering why I don't have these problems (not complaining).

Also what does difference does changing the memory speed from 60 to 70ns make?

Have tried both but can't see any difference..

   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2006/11/24 17:14
Posts: 624
@TiredOfLife

Quote:
Has anyone had any luck resolving these issues?.


Should have my new machinery soon (hopefully next week) then I'll have a go at the problem.

_________________
Seriously, if you do want to contact me write me a mail. You're more likely to get a reply then.
   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2007/7/23 20:35
Posts: 628
@Rogue

Excellent news.
Cheers.

   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2006/11/26 11:55
From South Wales, UK
Posts: 206
@All

Ive installed os4 on my classic 1200.
It has a mediator Z4 and a voodoo 3 graphics card, and i too experience the graphical glitches,
mainly screen and window titlebars are affected.

Apart from that, it all seems very stable.

_________________
A1XE G4 800mhz,512mb,Radeon9200,SonyDRU-510A and 800a, Esi Juli@,Sil680,WiFi.
   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2007/12/30 17:40
Posts: 3
Hello ,
I have an Amiga 1200 , mediator Ziv , Voodoo 3000 , pci netcard and trying to install OS4 . Have same as mentioned graphic problems , in AGA it is ok but in Voodoo screens it is all messed up . I have tryied to install MediatorUP2.1 but after this it freezes at every instance. No way to connect to internet also with pci card on Mediator .
Also @tiredoflife mentioned that he installed latest Mediator drivers , but when i run mediatorup2.1 and then try to set it up it all freezes . It freezes also in netwotk connection wizard .
Well i hope that soon comes up with a decent solution with mediator problems.

   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2007/7/23 20:35
Posts: 628
@Galaxy

3.10 was the latest update for Mediator files.
Anything earlier causes lockups for me.

   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2007/11/10 11:58
From Finland
Posts: 78
I'm using the latest Elbox drivers here also and a meantime workaround for the graphics trashing (i'm using 1024x768 16bit) for me is:

enter screenmode-prefs
click "autoscroll"
SAVE.

Now the screenmode builds itself again and the graphical trash is gone :).


EDIT: btw. i'm using 60ns settings in PPC-bootmenu and it seems not to have any consequences...

EDIT 2: so i've commented out in the KickLayout:
PCIGraphics.card
3dfxVoodoo.chip

and using:
Voodoo.card 4.23
PCI.library 6.5 (latest)

And NOT the latest Voodoo.card which is version 4.26. That driver causes serious graphic trash in OS4 just as under WB 3.9. 


Edited by bamiga2002 on 2008/1/15 8:49:52
Edited by bamiga2002 on 2008/1/15 9:55:50
   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2006/11/24 17:14
Posts: 624
Update on this one:

After I got the new case it turned out that my BlizzardPPC was dying - it would sometimes not initialize at all. I got a replacement two days ago.

The good news is that I've been able to fix the graphics trashing issue. I have also added support for the later Mediator models.

There is apparently another issue with SoundBlaster PCI cards not being set up correctly. Although the drivers don't work because of lack of DMA I intend to fix this since it might affect other cards as well. There is also one other thing that I need to add which.. well... more on that later.

We're putting together a few other things now that should go into a small update, like a fixed RTL 8029 driver. Hopefully this update will then be released later this month.

_________________
Seriously, if you do want to contact me write me a mail. You're more likely to get a reply then.
   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2006/11/22 18:00
From Sweden
Posts: 150
@Rogue

Yes! Thanks .. it worked perfectly, no more gfx bugs and the system is stable.. Looking forward to that RTL driver fix, so I can use internet without lockups..

   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 208
@Rogue

someone use 60ns settings in PPC-bootmenu and it seems not to have any consequences, can we use this settings ??

   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2007/11/10 11:58
From Finland
Posts: 78
@sofistisoftware
I used 70ns settings during the OS-installation process, but after installation switced back to my original 60ns setting. No probs yet .

_________________
Amiga - still alive & kickin'!
   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2006/11/24 17:14
Posts: 624
@sofistisoftware

Quote:

sofistisoftware wrote:
@Rogue

someone use 60ns settings in PPC-bootmenu and it seems not to have any consequences, can we use this settings ??


You are free to try. We do not recommend this setting, but if it works for you then by all means enable it. However, if you discover some problems/instabilities, you should try with 70 ns first before reporting an issue.

_________________
Seriously, if you do want to contact me write me a mail. You're more likely to get a reply then.
   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2007/12/30 17:40
Posts: 3
@Rogue
"The good news is that I've been able to fix the graphics trashing issue. I have also added support for the later Mediator models."

Hope you will come into a good solution for the graphic problem and give support to pci cards (network) also on Mediator Ziv . Thank you and we all wait for the fix.

   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2006/11/24 17:14
Posts: 624
@Galaxy

Quote:

Galaxy wrote:

Hope you will come into a good solution for the graphic problem and give support to pci cards (network) also on Mediator Ziv . Thank you and we all wait for the fix.


The Mediator ZIV should be supported already. If it isn't, then let me know, I'll see that I add it, but I was quite sure it was included already.

As for supporting PCI cards, if you are looking for supporting faked DMA tricks, no that will never happen. If someone desires to do so, he can write his own driver that uses a locked bitmap in graphics card memory to do this pseudo-DMA, but we will never support anything like that officially.

_________________
Seriously, if you do want to contact me write me a mail. You're more likely to get a reply then.
   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2007/12/30 17:40
Posts: 3
Hello again ,
well what i meant is that i have a mediator Ziv and right now its of no use . No tv card , no network card , no Voodoo card and no soundblaster audio card is supported without tricks. So i wait for at least the Voodoo 3 fix in order to be able to use OS4 and then i will try the other tricks to be able to have internet connection with pci lan . So right now mediator means only a voodoo card , hope elbox make also some new drivers to support their product .
The mediator ziv is supposed to be supported on Os4 but if no pci card is working then what is the point ?
Anyway first priority is the Voodoo 3 working and then i hope will be able to fix the network also .

   Report Go to top

Re: OS4 Classic GFX-problems..
Just popping in
Joined:
2007/11/10 11:58
From Finland
Posts: 78
Quote:

Looking forward to that RTL driver fix, so I can use internet without lockups..
I regularly lose internet connection in 30-45 mins after which i have to reboot to reconnect.

_________________
Amiga - still alive & kickin'!
   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2007/7/23 20:35
Posts: 628
Just had another go at getting my Terratec 512i sound card working.

Did everything by hand.
Now working fine.

Thought I had done that before but perhaps missed something.

Still can't get TV card displaying though.
Sound comes through but no picture.

Tried AmiTV but it crashes on launch.

@ Rogue

Any progress on the new kernel?

   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2006/11/24 17:14
Posts: 624
@TiredOfLife

Quote:
Any progress on the new kernel?


Sorry for the delay of this. Yes, there is progress, as a matter of fact the update is in testing now and should be available either later this week or early next week.

It will not only contain the graphics fix but also a few other fixes, so if you haven't registered your copy of AmigaOS 4.0 yet, it's time to do so

_________________
Seriously, if you do want to contact me write me a mail. You're more likely to get a reply then.
   Report Go to top

Re: OS4 Classic GFX-problems..
Not too shy to talk
Joined:
2006/11/24 15:10
Posts: 460
@Rogue

Good work Rogue, all your efforts are much appreciated.

Rude!

_________________
Nissan GTR '08
   Report Go to top

Re: OS4 Classic GFX-problems..
Quite a regular
Joined:
2007/7/23 20:35
Posts: 628
@Rogue

Great news.
It will be interesting to see if there are any speed gains when using the correct drivers.

Cheers.

   Report Go to top


« 1 2 (3) 4 5 6 ... 10 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project