Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
114 user(s) are online (103 user(s) are browsing Forums)

Members: 0
Guests: 114

more...

Support us!

Headlines




(1) 2 3 4 ... 12 »


OS4 UPDAAAATEE !!! BANANA !!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6690

https://www.hyperion-entertainment.com/

https://youtu.be/Fa4tpDZFwoc


Update 2 for AmigaOS 4.1 Final Edition available for download
AmigaOS 4.1 Final EditionBrussels, December 23rd, 2020

Hyperion Entertainment is proud to announce the immediate release of update 2 for AmigaOS 4.1 Final Edition. Update 2 is by far the largest update ever released for AmigaOS and includes more than 200 updated components with hundreds of bug fixes, improvements and new features and six completely new OS components. The update is the combined effort of four years of AmigaOS development and will bring AmigaOS4.1 Final Edition to a completely new level of stability and usability.

The complete list of updated, improved and new components can be found in the changelog that also contains a list of the major bugs and issues that has been resolved. Some of the highlights of update 2 are.

New kernel (exec) version 54.28 with many bug-fixes and stability improvements
Improvements and bug-fixes in the graphics.library, workbench.library, dos.library, application.library, elf.library and many other essential libraries making them more robust, bug-free and future proof
Bug-fixes and improvements to the USB-stack
Many bug-fixes and improvements to console.device, ram-handler, appdir-handler and env-handler
Many bug-fixes in all reaction classes, datatypes and device drivers
New OS-components such as the append dos command, an OS4.1 version of DiskDoctor from Olaf Barthel, SataControl, appdir-handler, ssh2-handler
Many, many more bug-fixes, improvements and new features
Update 2 is free to registered users of AmigaOS 4.1 Final Edition and can be found in the download area at https://www.hyperion-entertainment.com/.

This update is the result of the continuing effort of a dedicated group of AmigaOS 4.1 Final Edition developers and beta-testers. Thank you!

AmigaOS 4.1 Final Edition update 2 prerequisites

We strongly recommend that you install update 2 on top of a fresh install of AmigaOS 4.1 Final Edition update 1. If you decide to update your existing installation you should back it up beforehand!

Operating System: Installed AmigaOS 4.1 Final Edition Update 1 Hardware

Compatibility: AmigaOne XE & SE, MicroA1, AmigaOne 500, AmigaOne X1000, AmigaOne X5000, Sam440, Sam460, Pegasos 2, Amiga Classic PPC.


Edited by kas1e on 2020/12/23 15:08:05
_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 741
Woooohoooooo.... Christmas came early.

Nice video Roman...

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Not too shy to talk
Joined:
2015/6/11 9:51
From Cologne
Posts: 433
Great stuff and a big "eat that" to all the nay-sayers and those oh-so-well informed people who repeatedly claimed that there was no activity
Thanks to all involved!

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just popping in
Joined:
2018/12/28 7:02
From Oulu, Finland
Posts: 34
Wow, this is what I call Christmas miracle :)

Kas1e, nice video about the update.

Have anyone tried it on top of Enhancer or should I go with fresh install... or maybe fresh backup isn't so bad idea after all :)

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just can't stay away
Joined:
2009/5/1 18:57
From Czech Republic
Posts: 1224
Fantastic! A lot of things to tinker with over X-mas!

_________________
The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6690
@Tohe
With Enhancer you will have hard times if you install the whole package. That because Mattew create a mess when start naming the tools from Enhancer via the same names, and even making the 53.x sheme versioning. We all explain him that he done very bad thing, but he give a fuck :) Such components as format, time, sound and whatever else if will stay from Enhacner, they will broke the system in one or another way.

Of course, when you install Update2, all those badly-named Enhancer components will be overwritten back by update2, which is good.

And later, never install from Enhacner tools which named the same as system ones. Or, at least rename them yourself, and install everything manually.

On another note related to Enhancer and to other things over which Mattew have control there will be also such issues:

1). Dockies from ZZD10H package will be crashes on update2, because they were buggy, and Javier year ago fix them, and i betatest them so they works fine now, and i use them dayly on update2. They all was sends to Mattew back for re-release as i know, but never ever were released. Why ? Ask him. I will not anymore.

2). Tools which Joerg Strohmayer take with him when leave and sold to Mattew, such as PartitionWizard and AmiDVD will not work too anymore, as he specially made protection inside to not runs on any kernels past 53.98. So, until they fixed (if Mattew have access to source code, and somebody will deal with it for him), they will not works. If Mattew have only binary versions of those tools, without source, then cia to AmiDVD and to PartitionWizard.

And AmiDVD anyway have bugs even when you run it on old kernels (i offten have a freeze on exit on my x5000). In the very worse case, when one need AmiDVD, he may just for time being swith to kernel from update1, do things, and switch back. That a pain, and better if something will be done about.

So, somebody need to press on Mattew so he will put on AmiStore updated zzd10h packages we send him years ago, and deal with AmiDVD and PartitionWizard, if he for real owner of it. But i am sure will not asking him about this, he ignore all my logical explains and questsions all the time (and not only my), so , somebody should do so.


@Trixie

For first check changelog.guide ! That 120kb of the just a text about fixes and changes. Imagine, it just a text about fixes, how much of actual code work were done :)

Maybe Mattew will see how real proffesional changelogs should be done for release. But yeah, he will ignore it as well :)

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just can't stay away
Joined:
2009/5/1 18:57
From Czech Republic
Posts: 1224
@kas1e

Quote:
For first check changelog.guide! That 120kb of the just a text about fixes and changes.

I have reserved today's evening and I'll read the changelog with a glass of wine in my hand

As regards AmiDVD: I have been told that AmigaKit only has a binary licence, so an update is IMHO unlikely. As for Partition Wizard, I have no idea.

_________________
The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just popping in
Joined:
2018/12/28 7:02
From Oulu, Finland
Posts: 34
@trixie

the changelog seems so huge that it might take even two glasses :) - I'll follow your example :D

@kas1e

As Matthew has been active lately here - let's hope there'll be at least some reaction...

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6690
@Tohe
If Trixie is right (and he is probabaly), then no AmiDVD and PartitionWizard anymore. Surely PartitionWizard will miss no one imho, but AmiDVD can be a bit of loss. So, some replacement is must , just with better modern interface.

Or maybe its enough to just improve diskimage device, so it can have ability to "repack" to the ISO. Or maybe some programm based around diskimage device which will give ability to create ISOs.

So.. The only thing which then need to be done, its release newer ZZd10H tools, so they will works for everyone as they works for me now. But that agan, Mattew :)

And then AmiDVD and PartitionWizard need to be removed from Enhancer as well, as they not works anymore. But Mattew will keep them, and ignore the logic even if they will not works :)

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just popping in
Joined:
2009/6/11 2:19
From Germany
Posts: 89
Thanks to everone involved!

Installed directly above my existing OS4 Installation. No Problems so far!

Pretty nice that a detailed changelog has been included.

I can confirm that PartitionWizard and AmiDVD doesn't work anymore. I can't remember that i've ever used PartitionWizard. AmiDVD wasn't fully usable on X5000 because of SATA stuff and Device ID or something. So an updated Version of AmiDVD would be nice.

As for the ZZD10H Tools, at least SysMon and the CPU, RAM, GFX and Network Dockies are still working (all from latest AmiStore/Updater Release, so no Betas here).

@kas1e
Which Dockies do you mean from the ZZD10H Package?

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Home away from home
Joined:
2007/9/11 12:31
From Russia
Posts: 6690
@IamSonic
Quote:

Which Dockies do you mean from the ZZD10H Package?


RAM, GFX, CPU, and netdock. They works-runs, but when you will Dbl-click by mouse on it and back often will crash. At least the public versions. Javier spends some good time to rewrite some parts of it and fix things I report as well as add some new features. But as I say they were sent to Mattew and weren't put on amistore.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just popping in
Joined:
2017/10/28 11:03
From Netherlands
Posts: 108
Just updated on top of my existing OS4.1FE Update1 installation.
Followed the instructions and all went fine.
After the first reboot...the Clock was having an issue.
Run the A-EON updater utility..and there were 3 components that could be updated. One of them was the clock.

Updated all components, rebooted..and all seems working now.

A big thanks to all involved!

_________________
AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon R7 250 / M-Audio 5.1 -> AmigaOS 4.1 FE / Ubuntu Linux
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the world
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Home away from home
Joined:
2006/11/30 18:43
From Norway
Posts: 2492
This is the best thing this year.

_________________
X5000
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Not too shy to talk
Joined:
2008/3/15 2:00
From Alberta, Canada
Posts: 344
I had AmigaOS 4.1 Final Edition Update 1 plus Enhancer v1.5.

I used AmiDVD to backup my system to CD-R then updated on top of my existing installation.

I guess that will be my last backup using AmiDVD.

AmiDVD is toast. Too bad. I used it alot.

AmiDVD and Daniel Westerberg's BackUp tool are my main backup tools.

---
redfox




Edited by redfox on 2020/12/24 4:05:51
   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just popping in
Joined:
2020/11/17 12:08
From Slough
Posts: 85
Wonderful to have a new update after so long... but did anyone bother to test it? In first half an hour of usage:

1) system lock up when pasting from CLI to clipboard
2) system lock up 50% of time initiating any delete with asyncWB
3) on bootup, often a random one of my disks will be missing. need to reboot, or rather, restart amigaos, to make it come back
4) Ami Update is still a piece of shit

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Site Builder
Joined:
2006/12/2 23:57
From Athens/Dublin
Posts: 741
@NinjaCyborg
You bet it was tested. Did you do a clean installation or you updated your previous one? Also, what kind of computer you run it on?

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just popping in
Joined:
2006/11/30 11:59
From Lund, Sweden
Posts: 91
@kas1e

Fantastic, very nice surprise. I just got my X5000 up and running today and now this

I'm still a bit confused by how the enhancer pack fits into the picture though. Is there anything in the enhancer pack that adds value / doesn't break things? Can I trust the enhancer pack installer for cherry-picking or do I need to do this manually?

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Just popping in
Joined:
2020/11/17 12:08
From Slough
Posts: 85
@walkero

Yes, installed on a clean sam460ex. All I can say is, it was very stable before. Now it's not.

   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Not too shy to talk
Joined:
2014/6/29 15:12
From Montserrat
Posts: 342
@NinjaCyborg

Not seeing any instability up to now on a Sam460ex.
Did not do a fresh install instead installed as an update to my old installation .
Your issue could be hardware related so dont rule that out .

In the past I have had some instability while copying large files.
Tracked it down to a weird issue with the power supply.
Even though the power supply apparently tested ok it cased a problem. Swapped out the power supply for another of the same model and the problem stopped. Reinstalled the problematic power supply and the problem reappeared . so went back to the second one and problem ceased .


   Report Go to top

Re: OS4 UPDAAAATEE !!! BANANA !!
Not too shy to talk
Joined:
2006/11/29 1:00
Posts: 460
I installed the update on my SAM460. Everything seems to work well except for this one thing:
If I let the system boot up normally, all network connections are lost (I'm guessing that DEVS:NetInterfaces is failing) after about a minute. I can get the network to work again only if I do a hard reset (even a soft reset doesn't help), but then it's gone again in about a minute.

Things that I've tried:
*If I hold down SHIFT during system boot, the network works as it should and continues working without fail. (This is the only thing that seems to work so far.)

*I've tried removing all Enhancer software from my WBStartup, but the network still fails after about a minute.

*I've tried skipping S:User-Startup, but the network still fails.

Is anyone else having problems like this?
Does anyone have any other ideas to try?

   Report Go to top


(1) 2 3 4 ... 12 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project