Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
57 user(s) are online (36 user(s) are browsing Forums)

Members: 1
Guests: 56

geennaam, more...

Support us!

Headlines

Report message:*
 

Re: Odyssey 1.23 progress

Subject: Re: Odyssey 1.23 progress
by kas1e on 2020/3/4 8:11:37

@Mick
Enabled WebP, and it didn't help youtube images. So I assume youtube just needs updated core for some time.

Also, have issues with WebP rendering: all the images are in "over-blue" color, like something with endianness. I tried and your version from os4depot, and build my own latest 1.1.0, and has the same issue, see:

http://kas1e.mikendezign.com/aos4/odyssey_webp_blue.jpg

I tried to use "dwebp" example (and your one, and my one), and in both cases when i just do:

dwebp 1.jpg -o 1.webp

i have:

Decond of 1.jpg failed.
Status: 3(BITSTREAM_ERROR)

I also tested if webp_datatype from CrhisY works : and that one works surely, can show webp files correctly for me.

@all
Odyssey's webp decoder files there:

https://github.com/kas1e/Odyssey/tree/ ... geDecoder/WebCore/WEBP/WK

(if one want to check wtf)

@all
I tried to build Odyssey with LTO, and while I was able to do so, and the resulting binary save a lot of sizes (about ~15mb less!), it just crashes on start. Probably because of some issues lto-plugin bring on linking about violating c++ rules, redefines and all that stuff. Will create a ticket on GitHub about where everyone can see how to build it with lto and may be able to fix issues that cause crashes.

Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project