Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
89 user(s) are online (74 user(s) are browsing Forums)

Members: 0
Guests: 89

more...

Support us!

Headlines

Report message:*
 

Re: Trying to get a Radeon HD 7750 working in an AmigaOne XE

Subject: Re: Trying to get a Radeon HD 7750 working in an AmigaOne XE
by Hans on 2018/5/8 1:16:38

@Helloworld

Quote:
But it still didn't mount as a graphics board, double clicking
the new monitor driver still gives the same error message.

Did you set the BOARDNAME and CMPLENGTH tooltypes as described?

What do you mean with "didn't mount?" What does ScreenMode prefs show? Do you have a monitor connected to that graphics card (when the machine starts up)? It won't detect any modes without a monitor connected.


I'd expect it to give the same error message if you put it in DEVS:Monitors/, because it gets loaded on startup. So, double-clicking it tries to load it for a second time.

If you don't see any modes starting with RadeonHD: in ScreenMode prefs, then try adding some manual modes for the PCIGraphics monitor file using the monitors tab in ScreenMode prefs (which is what I assume TSK meant). You'll need to restart before those changes take effect. Normally the driver will detect the monitor's modes automatically, but sometimes a bad cable or bugs in the card's AtomBIOS prevents that from happening.

Quote:
or is there anyway to "poke" the 7750 to life in OS4?
it still only shows a blackscreen with a blinking text cursor.

With the driver properly installed, it should just work. The fact that it's still showing a blinking cursor, says that the RadeonHD.chip driver isn't starting up.

Quote:
And is it normal that the 7750 doesn't have a 'display controller' but the 9250 does?

Yes.

Hans


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project