Remember me

Lost Password?

Register now!
Who's Online
37 user(s) are online (20 user(s) are browsing Forums)

Members: 1
Guests: 36

Rigo, more...
Support us!
Recent OS4 Files
Report message:*

Re: Screenmode won't adjust after changing to smaller screen size.

Subject: Re: Screenmode won't adjust after changing to smaller screen size.
by Hans on 2017/10/3 1:21:52


I meant the place in the prefs where you edit height and width. Thought "viewable part" as opposed to "screenmode" was obvious. I would get to a state where it reverted back to values on the editing part and I needed to enable again and again "default" and it stopped after some boot sessions.

Okay. Not sure what's going on there. I just tried it, and checking the "default" tickboxes correctly set the width & height to their defaults, even though the values displayed in the boxes are different from the default (e.g., it displays 1085 in the height field, but correctly uses 1080 because default is ticked).

Setting a screenmode manualy with the prefs. I had this issue both with pre update 1 4.1FE on a lcd monitor and now on a tv. The range is setup properly. There is an issue with resolutions on 50hz (yes the hdtv supports 50hz like 1080p50). They are usually not saved and sometimes when I put 8-10 screenmodes manualy then the next one if it is 50hz can be saved sometimes (mostly not). I always had issues setting up 50hz resolutions so I used the p96 preferences for that.

Do you mean that you're manually adding modes to the list (as opposed to relying on DDC)? The only reason I know for modes being rejected, is if they fall outside of the vsync and/or hsync limits. Sometimes a mode needs to have "reduced blanking" enabled to be within the hsync limits. This is where using DDC makes life easier...

If you think you've found a genuine bug, then you should report it to Hyperion.

I checked and the setting "screen" was enabled so I disabled it and it worked. When I launched the screenmode prefs and tried disabling it from the pull-down menu it didn't take and I thought that fiddling with the tooltype might cause me more issues.

That's the behaviour I'd expect if the SCREEN tooltype is set. There's also the PUBSCREEN tooltype...

I think this was changed by the screens prefs because I had no reason to put it to a new screen and I didn't. Thanks.

More likely, you did it accidentally without realising it. It could be as simple as installing an icon theme that happened to have the SCREEN tool-type set.

... All of those behaviours I consider strange, because you don't know where they come from and you can't recognize a cause and effect situation. It just seemed to changed randomlly. Like after the "" situation and reverting to a backup, once in a couple of boots I would again get the "" message and every setting was again in a sort of a collapsed zero state. This time of course I understood that I just need to boot again and not do anything so then the backup was functioning after it. After a few more boots it happened again, and again a boot made it to the backup. Now it is not happening anymore and I don't have a clue why. That is weird, like it was possesed

You can't blame ScreenMode prefs for stupid stuff that other software on your system does.


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project