Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
83 user(s) are online (63 user(s) are browsing Forums)

Members: 1
Guests: 82

amigakit, more...

Support us!

Headlines

Report message:*
 

Re: can't send an email with the latest Claws email client?

Subject: Re: can't send an email with the latest Claws email client?
by cygnusEd on 2020/4/9 16:39:27

@328gts

Claws-Mail uses the gnutls 2.12.24 library for SSL/TLS. It searches for cert files like this:

* If the variable "Cygnix/SSL_CERT_FILE" is set to a cert collection file, it uses this file (path must be unix style).

* If the variable is not set, it takes the file "Cygnix:CygnixPPC/gtk2.24/share/curl/curl-ca-bundle.crt" or "Cygnix:CygnixPPC/share/curl/curl-ca-bundle.crt". A file "Cygnix:CygnixPPC/share/curl/curl-ca-bundle.crt" is provided with the AmiCygnix base package V1.5.

Maybe it helps to replace the file with a newer one.
But I guess, that you a need newer version of gnutls. Current version is 3.6.13. If a cert file is too old, Claws-Mail asks for a permission to use the received cert and stores it in the settings (see menu "Extras").

My port of gnutls will be updated in the next AmiCygnix release.

Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project