Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
47 user(s) are online (20 user(s) are browsing Forums)

Members: 2
Guests: 45

Chris, Raziel, more...
Support us!
Recent OS4 Files
OS4Depot.net
Report message:*
 

Re: Enhancer Bug thread

Subject: Re: Enhancer Bug thread
by salass00 on 2019/9/23 12:50:53

@Raziel

It is because newer z.library versions have some new functions that were not in 53.5 and older versions (53.6 added Uncompress2(), 53.8 added InflateReset2() and 53.9 added InflateValidate()).

I made a modified version of the stub library that you can try:
https://www.dropbox.com/s/6z4u4yxihtaeafj/libz.7z?dl=0

This one will only require z.library 53.5 at start, but if a program tries to use one of the functions only available in one of the newer library versions they will fail with the error code Z_VERSION_ERROR unless a new enough version is installed.
Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project