Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
43 user(s) are online (18 user(s) are browsing Forums)

Members: 1
Guests: 42

devils_advisor, more...
Support us!
Recent OS4 Files
OS4Depot.net
Report message:*
 

Payback on OS4.1 guide

Subject: Payback on OS4.1 guide
by ChrisH on 2010/11/29 20:24:54

I've previously made some posts (on AW.net) about how to get Payback working on OS4.1, but they were a bit short & spread out, so I thought I'd make a more comprehensive post. There are three parts to getting Payback to work:

A. Configure AmigaInput to use your USB Joystick (and set-up Lowlevel emulation).
B. Install Payback, update it, configure it, and tweak it.
C. Run Payback, using some very specific steps.

Here is part A:
* You need a USB joystick (or joypad), or Payback's keyboard controls won't work! So buy a compatible one if you don't have one; I recommend the Competition Pro USB (which AmigaKit sell).
* Boot OS4 withOUT the joystick plugged in, and then afterwards plug it in. You should see a brief USB message indicating it was recognised. (If you don't follow this step exactly then AmigaInput will not recognise the joystick.) If you see no message, then your USB port may not be working - try another port.
* Start the Sys:Prefs/AmigaInput program. Under "Available interfaces" you should see "USB". Clicking on this should show the name of your joystick under "Available drivers" (in my case it says "SPEED-LINK Competition Pro 2.0"). If you don't see anything then either your joystick is not supported, or you didn't follow the earlier steps correctly.
* Under "Units" you should see "OK" for Status. If not then your joystick may no be supported. If all is OK, then we need to calibrate your joystick, so click on "Test/Calibrate unit". This should open a new window.
* In the new window, click on the "Calibrate" button. Now you MUST follow the instructions at the top of the window (which are easy to overlook). (But basically it should ask you to move the joystick to the top-left corner & press fire, then move it to the center & press fire, then move to bottom-right corner & press fire.)
* Now wiggle the joystick & press the fire buttons - you should see the window react. If so then you can click on the "Save" button (this is important!). If not then retry following the earlier instructions. If still no luck then follow the instructions at the bottom of this post (aimed at AmigaInput crashing or behaving strangely).
* Now click on the "Lowlevel" tab. From the cycle gadget choose "Port 1 - Gamepad" (you may also find that "Port 1 - Joystick" works, but I have not tried that).
* Under "Drivers" you should see the name of your joystick. Click on it, and then under "Units" click on "0". The "Assign" button should now be clickable, so click it! Answer Yes to any requester asking if you really want to do it.
* Now change the cycle gadgets under "Button remapping" to Red = Button 1, Green = Button 2, Blue = Button 3 & Yellow = Button 4. If you have less buttons then just set the ones you can. If you have more buttons (!) then set-up the remainder as you feel like.
* Now change the cycle gadgets under "Directional mapping" to Horizontal = X-Axis & Vertical = Y-axis.
* Finally click the "Save" button (this is important!).
* You are done!

If you find that AmigaInput crashes at any point, or otherwise seems to behave wierdly, then please follow these steps:
1. Unplug the joystick.
2. Reboot OS4.
3. Plug the joystick back in, and follow the instructions again from the beginning.
4. If it still doesn't work then AmigaInput may have corrupt AmigaInput prefs files. Open a Shell and enter the following command EXACTLY:
Quote:
Delete EnvArc:Sys/AmigaInput/#? All

5. After pressing enter (it should report deleting some files), wait a few seconds for HD activity to finish, then unplug the joystick, reboot OS4 & follow the instructions again from the beginning.
Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project