Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
31 user(s) are online (14 user(s) are browsing Forums)

Members: 0
Guests: 31

more...

Support us!

Recent OS4 Files
OS4Depot.net

Report message:*
 

UAE UAE-X1000 help for an exact configuration

Subject: UAE UAE-X1000 help for an exact configuration
by white on 2018/6/15 10:50:45

Hi,
Before opening this little post, I thought about it a lot.
I hope to get help, I do not own a real amiga machine.
But reading documentations, and receiving the help of many people here on the forum, I was able to gradually configure amigaOS 4.1.1 using winUAE 64bit.
Now it works very well.
I can surf to watch videos and do many other things.

I know the limits of the emulation of 4.1.1, so I do not expect it to work like a real machine.
Over time I started using E-UAE.
There are two UAE and UAE-X1000 executables, the one I use is UAE-X1000
All games work very well, including demos written in assembly.

I do not expect its functioning to be perfect.
While UAE crashes, UAE-X1000 works perfectly in the window and in full screen.

Placed here the .log and my configuration, I ask for help to understand if the configuration is correct.
What I would like to know to learn, and if the parameters are correct.
The emulated machine is a 040 with fast ram.
I have followed some guides to configure these parameters so I do not expect everything to work better, but to understand if the configuration is right, I have to correct some parameters.

I'm sorry, if I put the .log directly and the configuration in the post.
If I have to delete this post because it's too long, I can put them on
on mediafire not to take up space on the forum.

Thanks again for every help!

.log
E-UAE 1.0.0
Build date: Jan 1 2015 18:38:45
Found 0 joysticks
Opening cfgfile '.uaerc'...okay.
unknown config entry: 'sound_max_buff=8192'
Opening cfgfile 'T:RunInUAE.uaerc'...okay.
Error: directory/hardfile 'Sys:Emulation/RunInUAE/WB31' already added
EClock frequency:16.079060 MHz
Rexx port "UAE" installed.
Resetting frame rate hack
Building CPU table for configuration: 68040
1866 CPU functions
Building CPU function table, 46416 opcodes (4 0 0).
JIT: Building compiler function table.
JIT: Allocation of translation cache...
JIT: Translation cache size in prefs: 8192
JIT: Allocated 8192 KB translation cache.
JIT: allocated 1760 KB macroblock buffer.
Resetting frame rate hack
AMIGFX: Using screenmode: 0x50031300:24 (1342378752:24)
AMIGFX: Using a 24-bit true-colour display.
Sound driver found and configured for mono at 44100 Hz, buffer is 10584 bytes.
Driveclick init...
reset at 0
JIT: Compiling reset
PAL mode, 50Hz (h=227 v=312)
chipmem cleared
SERIAL: period=372, baud=9600, hsyncs=16 PC=f8018a
JIT: Change cache emulation: enabled
Fastcard: mapped @$200000: 8MB fast memory
Card 1 (ZorroII) done.
Filesystem: mapped memory @$e90000.
Card 2 (ZorroII) done.
Mounting uaehf.device 0 (0):
FS: mounted virtual unit DH0 (Sys:Emulation/RunInUAE/WB31)
Mounting uaehf.device 1 (0):
FS: mounted virtual unit Amiga_ (Amiga:)
FS: Workbench starting..
FS: Amiga starting..
JIT: Change cache emulation: disabled
PTEST @ 0022338c
JIT: Change cache emulation: enabled
PAL mode, 54Hz (h=227 v=286)
PAL mode, 50Hz (h=227 v=312)
Illegal instruction: 4e7a at 0025da42 -> 0025da52
Illegal instruction: 4e7a at 0025da5a -> 0025dad8
Remote CLI started.
PFLUSH @ 0084a182
PFLUSH @ 0084a188
JIT: Change cache emulation: disabled
JIT: Change cache emulation: enabled
JIT: Change cache emulation: disabled
PFLUSH @ 0084a368
PFLUSH @ 0084a36e
PFLUSH @ 0084b700
PFLUSH @ 0084b700
PFLUSH @ 0084b700
JIT: Change cache emulation: enabled
PFLUSH @ 0084b700
PFLUSH @ 0084b700
PFLUSH @ 0084b700
PFLUSH @ 0084b700
0000 written to DSKDAT. Not good. PC=00849A1A
PFLUSH @ 0084b700
PAL mode, 52Hz (h=227 v=300)
PAL mode, 50Hz (h=227 v=312)
PFLUSH @ 0084b700
PFLUSH @ 0084b700
PFLUSH @ 0084b700
PFLUSH @ 0084b700
PFLUSH @ 0084b700
PFLUSH @ 0084b700
Byte put to custom register DFF05B PC=0086DEDA
Byte put to custom register DFF05B PC=0086DEDA
New max_color_change=750
Byte put to custom register DFF05B PC=0086DEDA
Byte put to custom register DFF05B PC=0086DEDA
Byte put to custom register DFF05B PC=0086DEDA
Byte put to custom register DFF05B PC=0086DEDA
Byte put to custom register DFF05B PC=0086DEDA
Byte put to custom register DFF05B PC=0086DED6
Byte put to custom register DFF05B PC=0086DED6
Byte put to custom register DFF05B PC=0086DED6
Trying on public screen...
AppWindow started.
AMIGFX: Using a 24-bit true-colour display.

.config
# UAE config for RunInUAE, which is designed to modify an existing working UAE config

# Use 3.1 Kickstart for Workbench, but allow ADF-booted games to still use an older Kickstart
kickstart_rom_file=kick3.1.rom

# Emulate an A1200, but still allow A500 emulation for ADF-booted games
cpu_type=68040
cpu_speed=max
chipmem_size=4

chipset=aga
#collision_level=none

# Emulate an expanded A1200 with 8MB of Fast Ram!
fastmem_size=8

# Set frame skipping (1=show all frames, 2=show every 2nd frame, 3=show every 3rd frame, etc)
#gfx_framerate=2

# Add floppy disk which can be used for saving games
floppy0=PROGDIR:SaveGames.adf

# Filesystem settings for virtual devices
filesystem2=rw,DH0:Workbench:Sys:Emulation/RunInUAE/WB31,1
filesystem2=rw,DH0:Workbench:Sys:Emulation/RunInUAE/WB31,1
filesystem2=rw,Amiga_:Amiga:Amiga:,-0

Example .config Breathless AGA
#RUNINUAE: LOCAL_VERSION=2
floppy_speed=800
cachesize=8192
gfx_width_windowed=640
gfx_height_windowed=480
gfx_lores=false
gfx_correct_aspect=yes
gfx_linemode=double
gfx_framerate=2
amiga.screen_type=ask
gfx_fullscreen_amiga=true
joyport0=kbd3
collision_level=none
#RUNINUAE: SCREENMODE=ScreenMode_HiRes.prefs

Here small video
https://www.youtube.com/watch?v=PBXHanDwaLw

Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project