Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
91 user(s) are online (77 user(s) are browsing Forums)

Members: 0
Guests: 91

more...
Support us!
Recent OS4 Files
OS4Depot.net
Report message:*
 

Re: Porting apitrace

Subject: Re: Porting apitrace
by kas1e on 2019/9/21 20:03:40

@Capehill
Thanks for adding it ! I tried today's glsnoop, and while starttime/duration thing works, i found a new crash which wasn't there before. Maybe it because of newer functions added, dunno.

So, to reproduce:
1. run glsnoop with "profile" only
2. run any ogles2 app
3. press "Ctrl+c" in the shell where glsnoop running
4. You will see that glsnoop says "Terminated, patches removed" and then BAH , crash in ogles2.library with 0x00000000

I find it when test starttime/duration, where it automatically exit after duration time, so it crashes. I then start reduce test cases to see if crash related to new functionality, and as result find that it crashes just as it.

Probabaly some new function forgotten to restore, or resotred wrong, or something ?

I tried that on 3 ogles2 apps : irrlichts's 02.quake3map , foobillard++ and prototype. All of them reacts like that (but i remember there wasn't that bug, so its something about last added things)
Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project