Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
115 user(s) are online (83 user(s) are browsing Forums)

Members: 0
Guests: 115

more...
Support us!
Recent OS4 Files
OS4Depot.net
Report message:*
 

Re: Building Cross-Compiling adtools for Amiga OS4 PowerPC (ppc) with Cygwin/Bash on Ubuntu on Windows

Subject: Re: Building Cross-Compiling adtools for Amiga OS4 PowerPC (ppc) with Cygwin/Bash on Ubuntu on Windows
by angelheart on 2017/11/8 4:49:55

@Hans

Anyone trying BEBBOs toolchain ?:

https://github.com/bebbo/amigaos-cross-toolchain


This would be the default AmigaOS 3.x, AROS toolchain to keep a set standard across Amiga systems in 2017+.

Stefan "Bebbo" Franke's fork of Krystian Bacławski's AmigaOS Cross-Compiler Toolchain.

Tested on multiple machines,Windows Cygwin 32 bit, Ubuntu 32/64 bit and CentOs 64 bit, & Mac.

http://eab.abime.net/showthread.php?t=85474

A Docker is available:
Dockerfile for Stefan "Bebbo" Franke's fork of Krystian Bacławski's AmigaOS Cross-Compiler Toolchain.

https://github.com/sebastianbergmann/docker-amigaos-cross-toolchain

docker run -v $HOME:/host -it sebastianbergmann/m68k-amigaos-bebbo \
m68k-amigaos-gcc /host/hello.c -o /host/hello -noixemul

docker run -v $HOME:/host -it sebastianbergmann/m68k-amigaos-bebbo \
vasm -Fhunkexe -o /host/hello /host/hello.s

run the Amiga software in Linux using Docker :

docker-execute-amiga helloworld

or Dockerized emulation using vamos eg (compile & run an AmigaOS C/C++ compiler from the internet/server !! )

docker run -v $HOME:/host sebastianbergmann/amitools:latest \
vamos -C 68020 /host/hello



Details

ppc-amigaos target:

gcc 4.2.4, g++ 4.2.4, binutils 2.18 (assembler, linker, etc.)
newlib, clib 2.2
AmigaOS headers & libraries & autodocs (for AmigaOS 4.1)

AmigaOS, 68k
binutils 2.9.1 & 2.14, libnix 2.2, libm 5.4

AmigaOS 3.x toolchain, vbcc toolchain (vasm, vlink & C standard library)
Headers, libraries, autodocs, for AmigaOS 3.9

MacOSX users : Require MacPorts or Homebrew installed.

Prerequisites

You have to have following packages installed in your system:

GNU gcc 5.x 32-bit version! or Clang
Python 2.7.x
libncurses-dev
python-dev 2.7
GNU make 4.x
perl 5.22
git
GNU patch
GNU gperf
GNU bison

Windows 10 64-bit with Cygwin 32bit

Install cygwin via setup.exe and add wget. Then open cygwin shell and:

wget https://raw.githubusercontent.com/tran ... en/apt-cyg/master/apt-cyg
install apt-cyg /bin
apt-cyg install gcc-core gcc-g++ python git perl-Pod-Simple gperf patch automake make makedepend bison flex libncurses-devel python-devel gettext-devel libgmp-devel libmpc-devel libmpfr-devel



Ubuntu 16.04 LTS 32-bit (gcc 5.4.0)

sudo apt-get install git gcc g++ python-dev gperf patch automake make bison libncurses-dev gettext libgmp-dev libmpc-dev libmpfr-dev
git clone https://github.com/bebbo/amigaos-cross-toolchain

Build

git clone git://github.com/bebbo/amigaos-cross-toolchain.git cd amigaos-cross-toolchain

./toolchain-m68k --prefix=/opt/m68k-amigaos build

optional -threads, AHI, CyberGraphX, Magic User Interface, etc

/toolchain-m68k --prefix=/opt/m68k-amigaos install-sdk ahi cgx mui

Failed ? send email and log to report and fix issues & asm optimizations. Donations welcome.

./toolchain-m68k build 2>&1 | tee build.log

cleanup build before use
rm -rf .build-m68k
rm -rf /opt/m68k-amigaos



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project