Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
82 user(s) are online (65 user(s) are browsing Forums)

Members: 1
Guests: 81

nbache, more...

Support us!

Headlines

Report message:*
 

Re: OS4.1 Update 1 problems & solutions

Subject: Re: OS4.1 Update 1 problems & solutions
by JOS on 2010/4/5 16:58:04

Overall, I think the OS4.1 update 1 is a good package.
Although, there still are some critical (and less critical) issues that need to be fixed (see below).
I really wish Hyperion have some time to have a look at them.

My computer is a Sam440EP (mini-ITX, 667MHz, 512MB RAM) with a clean Amiga OS 4.1 update 1 install.
To measure the CPU usage, I have used CPUInfo.


Summary:

1) Multitasking
a) Limited resources left for GUI-interactions
b) Delayed access to partitions in certain circumstances

2) DVD-rom read/write speed
a) Slow write speed
b) Slow read speed
c) Adjusting read speed of DVD-roms using IdeTool

3) (Partly) non-working USB devices
a) Razer Copperhead gaming mouse (laser)
b) Corruption of flash memory cards (formatting issue?)

4) Kickstart-function "Rename" in DOS.library




Details:

1) Multitasking

a) Limited resources left for GUI-interactions

When the CPU usage is 100% when running several programs in parallell, I get problems moving the mouse pointer; The mouse pointer lags behind.

All tasks have priority 0.

My opinion is that tasks related to mouse pointer movements and keyboard keypresses should always have the highest priority, and/or the user should have the opportunity to choose the priority himself.
I think this is important in order to avoid problems when/if programs "hang".

Example:
Several programs together uses 100% of the CPU (and maybe the GPU), and it's impossible to close the application (because the mouse pointer can't be moved).
If the mouse pointer always had top priority, I could have closed the application to free resources (or reduce the application's task priority).



b) Delayed access to partitions in certain circumstances

While copying between/to/from flash memory cards (via USB) or from a DVD-rom drive, other tasks don't get the CPU resources they need.
This prevents efficient use of my computer.
(PS: As soon as the copy is finished, everything works as normal again).

In my tests, some of the files being copied were large (up to 800MB each).

Examples:
- When running other tasks from the shell at the same time as the copy, they don't get the CPU-resources they need. According to CPUInfo, the CPU usage is unusual low (<30-35%). In my testcase I used OpenSFV (which normally uses much CPU).
When the copy is finished, the tasks runs as normal again.

- When burning files to DVD, it's almost impossible to access directories and files on the same partition as the burning software is reading from (0,5-1,5 minutes waiting time). Accessing other partitions works better.
I get the delay no matter which program I use; When browsing files directly from my Workbench, from the shell (cd and list commands), from Directory Opus 4, so this is most likely an OS issue. As soon as the burning is finished, the response is quick again.




2) DVD-rom read/write speed
First some general info:

My DVD-burner is a Plextor PX-820SA.
Output from idetool (my current settings for my DVD-rom (unit 0)):

Flags : $0000011D - present, supports DMA, removable media, ATAPI, interrupts used,
Xfer mode : best pio 12 (PIO 4, 16 MB/s) / best dma 69 (UDMA 5, 100 MB/s) / current 69 (UDMA 5, 100 MB/s)
Total blocks : 0
Blocksize : 0
SCSI devtyp : 5
Packet size : 12
Current medium read speed : x 65535 ('65535' stands for max.)
Current medium write speed : x 65535 (idem)
Power mode : 2 / idle (ready for operation)
IO1 / IO2 / BMCR @ : $1100 / $110A / $1120

Here is the description of the issues I have with my DVD-rom:


a) Slow write speed

On my system, a write speed of 4xDVD (5.4MB/sec) seems to be max, though the drive itself should handle up to 20xDVD and the media used supports 16x writing speeds.
The DVD burning software I use is AmiDVD.

I have tried to change the maximum speed with IdeTool, but the result doesn't get any better.

CPUinfo shows me very little CPU load, so it's not the CPU which is the bottleneck here.



b) Slow read speed

The maximum read speed seems to be 2xDVD (2.7MB/sec), though the drive should handle up to 16xDVD. It's a lot of noise from my DVD-rom, so the rotating speed is most likely at maximum.
The strange thing here, is that the reading speed is only 1/2 of the writing speed. Something strange is going on here..

I have tried to change the maximum speed with IdeTool, but the result doesn't get any better.

CPUinfo shows me very little CPU load, so it's not the CPU which is the bottleneck here.



c) Adjusting read speed of DVD-roms using IdeTool

To avoid unnecessary delays and noise from my DVD-rom, I use idetool to reduce the reading speed.
This doesn't work as intended.
It is not possible to reduce the DVD-rom's MAX read speed for DVD-R and DVD-RW media.
However, CD-R and CD-RW media works fine.

Details:
Idetool reports it has changed the max speed to the requested value, but the DVD-rom acts like this:
* DVD-R media: Drive always spins up to MAX rotating speed, even if IdeTool has reported it has changed it to 1x.
* DVD-RW media: Same here. Although with the previous version of the OS4.1, 4xDVD RW media were always read with a low speed (4x?).
* CD-R & CD-RW media: The drive spins up/down to the requested speed when reading (ok).




3) (Partly) non-working USB devices
Below is a list of devices that doesn't work correctly with OS4.1:


a) Razer Copperhead gaming mouse (laser)

When moving the mouse slowly to the right or down, the mouse pointer doesn't move at all.
(Left and up works fine).



b) Corruption of flash memory cards

Copying to/from memory flash cards sometimes leads to corrupt directories and/or files (CRC error and/or cryptical directory names).
The biggest problem with this, is that no error messages are given, so the user doesn't know which files are ok and which aren't.

To detect this error, I have to calculate checksums manually before and recalculate/check it after the file copy (otherwise I don't discover the file errors until it's too late).
The copy in my test was done between 2 cards (SD and Compact Flash) with a 8-in-1 flash card reader.
I got the error above with a Kingston 128MB SD Card. The flashcard was formatted with FAT16 from OS4.1.
After formatting the SD-card on my digicam, everything worked fine.
My best guess is that this bug has something to do with the formatting-routine in OS4.1 + maybe a lack of checksum checks.

Another strange behaviour:
Deleting files sometimes leads to corrupt files.
First I get a "Seek error" message, then the file was unreadable.
Tries deleting the file again, and the file gets deleted as normal.




4) Kickstart-function "Rename" in DOS.library
This function has a different behaviour compared to OS3.x.
The consequences of the bug, is that some files will not be renamed.

Details:
If the parameter which specifies the old filename has exactly the same case'ing as the new one, rename isn't done, even if the file on disk has different case'ing.
This behaviour differ from that in OS3.x, where renaming always is done.

My opinion:
I think this function should have similar behaviour as in OS3.x, rather than trusting the calling program always "knows" the correct case'ing of the old filename.

Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project