Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
70 user(s) are online (60 user(s) are browsing Forums)

Members: 0
Guests: 70

more...

Headlines

Report message:*
 

Re: IBrowse 2.4 OEM how to use YT.rexx "SOLVED"

Subject: Re: IBrowse 2.4 OEM how to use YT.rexx "SOLVED"
by MickJT on 2018/2/7 9:24:01

Hi,

It's better but not 100% correct.

PathFP="APPDIR:Amiga:Utilities/FFmpeg/Generic/ffplay.xdelta3"

.xdelta3 is not an executable file. After extracting ffmpeg.lha, you need to run the "Unpack" script which creates the remaining binaries from the xdelta3 files. It works similar to spatch or gpatch which you might be more familiar with. In summary, extract ffmpeg.lha to RAM:, then in shell type "cd ram:ffmpeg" then "unpack" and you'll have the proper ffplay binary.

Also, if you're using a non-APPDIR path, get rid of APPDIR: from the start, so the line looks like:

PathFP="Amiga:Utilities/FFmpeg/Generic/ffplay"

All that being said, ffplay is/was only used to play live streams, and YouTube has deprecated HLS streams and they don't work properly anymore. So, there's no real need to worry about fixing that path or installing ffplay anyway.

Edit (2nd March): HLS streams over SSL/TLS has been fixed in the ffmpeg git repo. A fix from December '17 hasn't made its way into any official release yet.

Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project