Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
43 user(s) are online (30 user(s) are browsing Forums)

Members: 0
Guests: 43

more...

Headlines

 
  Register To Post  

(1) 2 »
Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@All

I think some of you will find it interesting to see actual boot times of an amigang hardware in a single topic.

Everything was tested using AmigaOS 4.1 Update 2 and an extra TESmart KVM switch and passive USB hub with four ports.
Everywhere, the latest firmwares and environments are set to maximum speed. Of course, I can miss something, and if you have faster boot times, please feel free to discuss.


AmigaONE X1000
Nemo board rev. 2.1, latest CFE (Friday, June 8, 16:04:49 CEST 2012), SSD disk with SFS0 boot partition, RadeonHD


-- 14 seconds till the X1000 boot logo disappear from the screen.
-- 18 seconds for bus scanning.
-- 23 seconds for full load up of os4update2.

The entire boot time, from power on to working system, is 55 seconds.

AmigaONE X5000
Cyrus board rev. 2.1, latest Uboot firmware, RadeonRX

-- 11 seconds till x5000 logo disappear from screen.
-- 14 additional seconds for bug scanning (also with same kvm, usb hub, etc).
-- 12 seconds for full load up of os4update2 when on SSD, and 23 seconds when on HDD

The entire boot time, from power on to working system, is 37 seconds on SSD and 48 seconds on HDD


Sam460CR
Latest UBoot (U-Boot 2015.a (May 16 2015 - 14:20:11)), SSD disk with SF0 for boot partition, RadeonRX

 -- 4 seconds first initilisation (yeah! the video, ram, etc just 4 seconds)
 -- 9 seconds for bus scanning until SLB starts
 -- 18 second for full load up of os4update2 

The entire boot time, from power on to working system, is 31 seconds.

Pegasos2
 Board rev 1.0 (2B3) firmware 1.2 (2004.08.10) , IDE 2 SATA adapter used in IDE slot with SSD disk and SFS0 partition as boot one , Radeon9250:

 -- 9 seconds initialisation till firmware's boot menu
 -- 32 seconds from amiboot till full loaded workbench.
 
The entire boot time, from power on to working system, is 41 seconds.

To summarize the whole boot process from power-up:

-- x1000 on SSD  55 seconds
-- x5000 on SSD  37 seconds
-- x5000 on HDD  48 seconds
-- Sam460 on SSD 31 seconds
-- Peg2 on SSD   41 seconds


The Sam460 is unquestionably the boot-time winner.


Edited by kas1e on 2022/12/1 14:12:42
Edited by kas1e on 2022/12/1 14:13:30
Edited by kas1e on 2022/12/1 14:16:34
Edited by kas1e on 2022/12/3 7:44:09
Edited by kas1e on 2022/12/3 7:46:35
Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Just popping in
Just popping in


See User information
Sam460ex@1.15 GHz, latest Uboot.

32 seconds from coldstart with mechanical drive and MorphOS 3.17. 3 seconds OS bootselect timeout.

Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Not too shy to talk
Not too shy to talk


See User information
@kas1e

On my X5000, the boot logo appears pretty quickly, then stays frozen for around 10 seconds before the animation commences. I have amigabootmenu_animate set to 1 and amigabootmenu_anicycles set to 1.

Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@daveyw
Quote:

On my X5000, the boot logo appears pretty quickly, then stays frozen for around 10 seconds before the animation commences.

I am a bit correct first port, it was not "until logo showups", but "while logo showups". Or better "until logo disappear from the screen". I.e. ~10 seconds of logo like doing nothing on both x1000 and x5000

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Just popping in
Just popping in


See User information
It is for a long time booting You x5000 for me it is 32 seconds (power on to working system).

Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@mufa
32 seconds for x5k after you hit poweron till fully loadef wb with amidocks and co ? Sounds strange.. i mean logo+busscaning take ~25 seconds alone..

If you indeed have 32 seconds for everything, can you answer plz on those questions:

- is it 020 or 040 version ?
- Did you use ssd or hdd ?
- what version of ngfs ?
- Beta uboot or public one ?
- fresh update2 or a long time working system (with big appdir cache, etc) ?
- Can you post there your whole "printenv" from uboot ?
- can you meassure plz those times:
1). How much for x5000 boot logo ? I.e. how many seconds from power on till logo disappear ?
2). How many seconds between disappeared logo and amigaboot loading ?
3). How many seconds after amigaboot starts till full working wb ?

Because 32 seconds sounds too good. X5000 logo alone take 10 seconds.. and 10-15 seconds for usb bus-scanning.

Thanks!

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Not too shy to talk
Not too shy to talk


See User information
@kas1e

Quote:
32 seconds for x5k after you hit poweron till fully loadef wb with amidocks and co ? Sounds strange.. i mean logo+busscaning take ~25 seconds alone..

That is nearly exactly what I get on my system. 33 seconds from power-on to Workbench ready to go.

Quote:
If you indeed have 32 seconds for everything, can you answer plz on those questions:

- is it 020 or 040 version ?
- Did you use ssd or hdd ?
- what version of ngfs ?
- Beta uboot or public one ?
- fresh update2 or a long time working system (with big appdir cache, etc) ?
- Can you post there your whole "printenv" from uboot ?

I can't speak for Mufa, but my answers would be:

1. X5000/20
2. SSD (a Samsung 240GB unit)
3. SFS/0 1.293
4. U-Boot aeon_2021-01-05
5. Long working system; latest beta components

As for my U-Boot variables, I'll post a graphic via the site Images section. Hope this data helps.

-- eliyahu

"How do you know I’m mad?" said Alice.
"You must be," said the Cat, "or you wouldn’t have come here."
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Just popping in
Just popping in


See User information
around 33 seconds here too with a similar setup as eliyahu.

Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@eliyhau, smf

So i loose somewhere 15 seconds. Can you measure exact steps and which take what ?

I mean

1). how much you have from power up , till x5000 logo disapper
2). how much you have after logo disappear, till the amigaboot start loading
3). how much you have from amigaboot starting loading till the working system

@smf
Can you share your "printenv" there as well ? If you have serial cable of course, as typing all manually is unreal :) And probabaly you use latst public uboot from 2015, and not the beta one from 2021-2022 ?

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Quite a regular
Quite a regular


See User information
33 seconds on my X5000, but that is with the disabled animations and also debugging completely turned off.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@rjd324
Thanks, but have the same question to you as to smf and eliyhau in previous post, can you plz meassure those steps ? (so i will know where i loose 15 seconds).

I do have disabled animation of course as well.

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Quite a regular
Quite a regular


See User information

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@rjd324
So as i suspect the initialization speed is the same, it's the loading of amigaos4 much faster on your video : 11 seconds from "white" screen till usable WB, for me it takes 26 seconds. So ...

That can be and because differences HDD vs SSD, and, which a think as well can be "big" appdir cashe, and maybe debug-level add something .. Also i have lot's more on startup to run : 2 amidock panels , 1 xdock panel, dopus4, shell, few dockies, etc.

Will check futher, thanks!

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Quite a regular
Quite a regular


See User information
@kas1e

X5000 loading of amigaos4 from the white screen with a HDD seems to take at least 24 Seconds .

Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Quite a regular
Quite a regular


See User information
yeah, debug level added a few seconds (no more than a few) to my bootup. i think i was using level 5. now it is just completely turned off.

i use an ssd.

good luck.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@Spectre
Yeah, same as for me. But for mufa, eliyhau, smf and rjd324 it takes only 11 seconds.

Did you use SSD or HDD ?

In meantime tried to delete from prefs AppCache dir - it didn't speed thing up. Removing running AmiDock and XDock and i have 21 seconds from white screen to workbench still. In the uboot all i have for os4_Commandline for now is "serial", and nothing else.
And i see how offten "hdd" blinks in this time. Probabaly worth to test with SSD, it looks like it..

And intersting, that those ones who do have 11 seconds for os4 loading all on SSH, while we both on HDD and have 23 seconds. Dunno if it related or not.

Maybe it also make a difference what filesystem is used for booting (sfs vs ngfs ?) and all those settings in mediatool box..

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Quite a regular
Quite a regular


See User information
To add, I use sfs.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@smf
You also as eliyhau and rjd324 use SFS and not NGFS ?

@all
Those of you who have x1000 instead of x5000, can meassure the full loading from power on to working workbench as well as meassuer just a time between white screen (when amigaboot starting load modules) and the working system ?

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Just popping in
Just popping in


See User information
@kas1eQuote:
kas1e wrote:@smf
You also as eliyhau and rjd324 use SFS and not NGFS ?


Sorry, i don't remember what kind of filesystem my default boot partition uses but probably the very latest NGFS as it "outperforms" sfs when it comes to kickstart loading since a few years back. (i have a mixture of boot partitions with old and new ngfs and sfs).

My uboot is from this year, 2022-01-something.
I can not check it, i only had time for a quick test yesterday and is now stuck with my tabor for the rest of the week :)

Go to top
Re: Different AmigaOS4 machines boot times: X1000,X5000,Sam460 and Peg2
Home away from home
Home away from home


See User information
@smf
So it seems that at least you, eliyahu, and mufa do use some latest betas of uboot..

@rjd324
Did you have public uboot on your side from 2016 coming on x5000 ? Or also a beta one ?

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top

  Register To Post
(1) 2 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project