Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
67 user(s) are online (52 user(s) are browsing Forums)

Members: 0
Guests: 67

more...

Headlines

 
  Register To Post
(1) 2 3 »

Enhancer 2.2 Video Playback Problem
Quite a regular
Quite a regular


See User information
I have an X1000 with an ASUS Radeon HD card. Since I have installed enhancer 2.2 I have video playback problems with both DVPlayer and Emotion.
When I try to play a video the playback window is gray and I get the following output in a console window that opens up.

"EE radeon_uvd.c:1285 si_common_uvd_create_decoder UVD - Can't init command submission context."

If I disable the "RadeonHD_drv_video.library" then videos play just fine.
The version of the library is 1.11.

I thought that video playback worked right after the enhancer install but I'm not sure.
I was playing with options in Emotion tooltypes and may have enabled the "VAAPIAccel" tool type by accident at one point. This of course won't work but would it cause a problem?

Have other run across this problem?

AmigaOne X1000, uA1
Go to top
Re: Enhancer 2.2 Video Playback Problem
Just popping in
Just popping in


See User information
Unfortunately Enhancer don´t contains the RadeonHD V5 driver. It can be purchased here:

http://amigakit.amiga.store/radeonhd- ... -p-1107.html?currency=GBP

Later it could be available on Amistore???

I don´t understand this because we get va.library which software tries to use, but we can not use it because missing of the newest driver ;)


.... in my world we would have ONE Radeon Driver Suite with all components for all graphic cards which gets a major paid update every year including drivers, va.library, Warp3D Nova etc.. all stuff around graphics + card.

And Extra Enhancer for Software suff...

Go to top
Re: Enhancer 2.2 Video Playback Problem
Site Builder
Site Builder


See User information
@imagodespira
I'd love to live in your world :D

Go to top
Re: Enhancer 2.2 Video Playback Problem
Home away from home
Home away from home


See User information
@walkero

In my world there would be no Enhancer Package at all but a unique AmigaOS package comprising of everything .. the legal disputes should had stayed among themselves instead of making them weigh to users making stews of the os

Go to top
Re: Enhancer 2.2 Video Playback Problem
Site Builder
Site Builder


See User information
@samo79
I agree with you. That would be perfect.

On the other hand, Linux doesn't come with NVidia drivers, just some open source, with fewer features. Also if you install Windows you need to go and grab the latest drivers from NVidia or AMD and install them as extra, right? Windows have some basic drivers for it to boot and work.

What I am saying is that the OS doesn't have to have the latest full-featured gfx drivers included or implemented by the OS developers. They can come as separate packages developed by third parties, and this is happening a lot in the tech world.

Now, why in the Amiga world a third party decided to create a package with unrelated software included, and necessary parts being in different packages, that is not for me to say. Maybe the following can give you a clue
https://www.amigans.net/modules/newbb/ ... id=132343#forumpost132343
https://www.amigans.net/modules/newbb/ ... id=132347#forumpost132347

I am sure they know what they are doing.

Go to top
Re: Enhancer 2.2 Video Playback Problem
Site Builder
Site Builder


See User information
@ktadd
Back to the topic, if you have a RadeonHD gfx card, although the VA library is included in the latest Enhancer, this doesn't mean you are going to have Video Accelerated playback.

You need the brand new and hot RadeonHD v5 packages from A-Eon available in a physical box at https://amigakit.amiga.store/radeonhd-driver-version-p-1107.html and soon at your closest AmiStore. No discounts available I am afraid.

Go to top
Re: Enhancer 2.2 Video Playback Problem
Quite a regular
Quite a regular


See User information
@imagodespira

Quote:

I don´t understand this because we get va.library which software tries to use, but we can not use it because missing of the newest driver ;)


The concept and primary use of the Enhancer Software 2 is to be bundled with current A-EON hardware such as a the X5000 and future models. The Enhancer Software fills in the missing gaps with OS4.1 for customers who buy the X5000.

The RadeonHD is not a current graphics card sold in shops- it has been superceeded by the RadeonRX which is still available from shops. Therefore the latest RadeonRX driver is included on the Enhancer Software 2.2 to benefit the new X5000 users who receive it bundled with their machine. It is a necessity to have the RadeonRX driver in the Enhancer Software when a reseller is building a brand new X5000 with new RadeonRX card installed in the system.

Therefore RadeonHD is now considered a legacy graphics chipset. RadeonHD V5 driver costs many tens of thousands of Euros to develop so to recuperate some of these costs it needs to be sold separately. The money from sales gets reinvested into future software development.

Go to top
Re: Enhancer 2.2 Video Playback Problem
Quite a regular
Quite a regular


See User information
@imagodespira

Quote:
.... in my world we would have ONE Radeon Driver Suite with all components for all graphic cards which gets a major paid update every year including drivers, va.library, Warp3D Nova etc.. all stuff around graphics + card.

And Extra Enhancer for Software suff...


Unfortunately end-users buying a brand new A-EON machine such as the X5000 want more than a basic OS. It is a larger need than just the graphics sub-system.

The Enhancer Software is bundled with the X5000 to give them much more modern and satisfying experience than the basic OS4.1 ISO can provide.

Put yourselves in a customers shoes. Imagine you had just bought a brand new X5000 and switched it on for the first time. Would you prefer to use MultiView or MultiViewer, Notepad or MultiEdit, Unarc or Archiver, AmiDock or X-Dock, RAWBInfo or InfoWB ? Would you be satisfied with a very old Ringhio or would you want the latest Ringhio included in the Enhancer Software?

In the absence of real OS4.1 progression (not just bug fixes), the Enhancer Software is giving new users the chance to have better system software bundled with their shiny new X5000.

The Enhancer Software's raison d'etre is to offer the best software experience we can to users with the resources available. We work with the cards we have been dealt.

Go to top
Re: Enhancer 2.2 Video Playback Problem
Site Builder
Site Builder


See User information
@amigakit

Quote:
Put yourselves in a customers shoes.


Ahhh... we are all customers of these products. Are you missing something?

Quote:
Would you prefer to use MultiView or MultiViewer...


Sometimes less is more. Those are two totally different apps, in my opinion. And if you compare them by size, memory consumption and speed, I am sure Multiview beats Multiviewer. Don't get me wrong, Multiviewer is awesome and I was one of those who bought it separately the first days it came out before it was included in Enhancer 2.

Some people prefer something simple and fast, and others prefer full-featured ones. That's one of the differences for ages between Windows and MacOs, KDE and Gnome, AmigaOS and MorphOS. That doesn't mean that either is bad software, just people prefer different things.

Go to top
Re: Enhancer 2.2 Video Playback Problem
Just can't stay away
Just can't stay away


See User information
@amigakit

I am a long time supporter of the ESP program and welcome the continued development.

For AEON customers with X1000, is their GPU path forever officially locked to RadeonHD cards? Should X1000 owners accept that the hardware is now legacy?

The recent X1000 hack by Goos to get past CFE RX limitations shows promise to users, but a challenge to RadeonHD 5 purchases.
A hack is less than ideal if we want to be able to access recovery partitions or CD units from boot.

What of the long discussed CFE upgrade to support RX, I suspect X1000 owners might be open to paying for this?

AmigaOne X1000.
Radeon RX550

http://www.tinylife.org.uk/
Go to top
Re: Enhancer 2.2 Video Playback Problem
Quite a regular
Quite a regular


See User information
Quote:
Ahhh... we are all customers of these products. Are you missing something?


I was replying to Imagodespira's post, who is a commercial publisher and developer of software (not a general customer).

Quote:
Sometimes less is more. Those are two totally different apps, in my opinion. And if you compare them by size, memory consumption and speed, I am sure Multiview beats Multiviewer.


Maybe this viewpoint is relevant when using an older machine with limited resources such as Classics. However we are talking about the Enhancer Software being bundled with the X5000. A powerful machine with many resources. Customers expect to utilise some of that power at least. Otherwise what it the benefit of getting more powerful hardware?

Incidentally, MultiViewer uses GPU Shaders to render graphics through Warp3D Nova. That is going to be much faster than MultiView displaying the same graphics.

Archiver, MultiEdit, X-Dock, InfoWB are all examples of Enhancer Software components that give more than the stock OS4.1 install.


Quote:
Multiviewer is awesome and I was one of those who bought it separately the first days it came out before it was included in Enhancer 2.

The Multiviewer Version 1.x was sold separately. We are now a further five years on with development. MultiViewer Version 3.x is part of the Enhancer Software now. This latest version is now reliant on other important components of the Enhancer Software: Warp3D Nova, AK-Datatypes and the many advanced classes included in the Enhancer Software.


@DDNI

The AmigaDeveloper Team do not have the CFE source code. If it is returned, we can take a look at updating it.

amigakit.com - the Amiga store
Links: www.amigakit.com | New Products | Enhancer Software
Go to top
Re: Enhancer 2.2 Video Playback Problem
Site Builder
Site Builder


See User information
@amigakit
Quote:
I was replying to Imagodespira's post, who is a commercial publisher and developer of software (not a general customer).

So those who create their own commercial software and happen to buy your products have different treatment by you than your "general customer"?

Quote:
Maybe this viewpoint is relevant when using an older machine with limited resources such as Classics.

Some people will disagree with you, because they use Classic AmigaOS 4, Sam 440, microAmigaOne etc., but I get it. They are not your target customers. And I agree that you need to move forward with more features. I just said that you can't compare Multiview with Multiviewer. The purpose of each program is different.

Quote:
The Multiviewer Version 1.x was sold separately. We are now a further five years on with development.

I haven't doubt about it, nor wrote anything against it. For sure, since it was included in Enhancer it became much better. Why this defensive tone?

Quote:
The AmigaDeveloper Team do not have the CFE source code. If it is returned, we can take a look at updating it.

I know you answer to ddni here, but I am curious. All this time that people complain about X1000 support for RadeonRX nothing was done?

I am sorry, but who maintains CFE right now? If I am not wrong it's ExecSG team, right? ExecSG is owned by Trevor, right? Your A-Eon partner, correct?

If I am not wrong on my above questions, and you need help contact Trevor or Steven, please let me help you and bring you in touch. Seriously now, I want to help you, and unblock this situation for you.

Go to top
Re: Enhancer 2.2 Video Playback Problem
Not too shy to talk
Not too shy to talk


See User information
@amigakit

I understand that development costs are higher than return on sales, but you should communicate precisely with us, your customers. By purchasing the ES2.0, RadeonHD users helped to develop the RadeonRX driver. Now we have to pay for RHDv5 again. Buyers of Dvplayer were promised a discount.... Just read other places. People get frustrated at any such additional costs. IMO, System54's chances of success are lower than ever. But hey, I'm ready to pay for the RHDv5 driver again. I was told MAYBE the SAM460 version would work with my SAM440 & HD7750. So if this fails, will I get a refund? OR maybe someone could send me a driver to try?
Im quite happy with ES1.X and ES2.0 so far. The ability to use UVD is cruicial while waiting for some newer hw.
I asked this a second time. Hope to get an answer

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top
Re: Enhancer 2.2 Video Playback Problem
Quite a regular
Quite a regular


See User information
@mr2

Enhancer 2.0 included Radeon Rx Driver v2.4 .
So unless you prepaid for Enhancer 2.0 your time line is off .

Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: Enhancer 2.2 Video Playback Problem
Just popping in
Just popping in


See User information
@Amigakit: To pay for new stuff is not the biggest problem. A big problem is that no one knows what to buy.

Now: Enhancer 2.2 is out, great.
But Software which was working before crashes as the HD Lib for Video is now there... but not the driver ;) So we have many posts to make in forums and also as PM or Email from Emotion customers. And we have these problems since the first Enhancer (if i remember right, the sound "enhancement" was the problem and Spencer did not run anymore).

So here my whish of clean communication and drivers, less is more.
For me, the Enhancer should only have Software and not GFX drivers. I would be happy to pay a GFX Suite like "Radiance" every year with some updates or a subscription to pay the development.

I also understand that your X5000 Customers has the priority, but it is not a cheap computer and we have to use our hardware until it dies.

Beside this, in our groups and on meetings the most users use the enhancer install only for graphics drivers and don´t install the rest. So you never will know how much components are really used and needs to maintain over so much years. For single software, a Store would be nice, then you know by sales how users like it.

I understand your problem with Hyperion updates. But currently we have a working official OS4.1. I never would install any replacement parts. We also will not use these parts as it is more support (now: with every little problem we have to check if a user has installed Enhancer Components). Our software is aimed for OS4.1 and we are happy to support additional drivers but not Enhancer components.

Over the years some really needed software should have been released. A Browser, Email whatever... Video Player was on our List, now we have two ;) Double work...


I am happy with the drivers. It is also no problem to pay for my outdated 7750 (if my RX550 will not run, not yet tried).

Go to top
Re: Enhancer 2.2 Video Playback Problem
Site Builder
Site Builder


See User information
@imagodespira
I agree with every single of your points. I would be glad to pay for that development if there was clarification. But let me remind you that so far NovaBridge was announced and presented by Hans last year, and so yet it was not announced how we will get that, except that it is going to be part of the V54.

So, if someone wants that, to use it with his RadeonRX on his system, he will be forced to buy the V54, paying again for Enhancer 2, DVPlayer and all the rest of the software he already has paid for the same machine. No discounts will be available.

Do you see a pattern here?

I find Individual Computer's paying schema for Picasso drivers more honest to be true. You get all the updates for a year free of charge and you pay again every year for a newer version.

Go to top
Re: Enhancer 2.2 Video Playback Problem
Not too shy to talk
Not too shy to talk


See User information
@imagodespira

Quote:
For me, the Enhancer should only have Software and not GFX drivers. I would be happy to pay a GFX Suite like "Radiance" every year with some updates or a subscription to pay the development.

Absolutely. I have yet to meet a single X5000 customer that really wants command replacements, replacements for DefIcons, replacements for Exchange, replacements for ..., etc. We like what AOS4 already provides. What we want aren't replacements with barely any enhancements. We want the graphics stack.

Quote:
Beside this, in our groups and on meetings the most users use the enhancer install only for graphics drivers and don´t install the rest. So you never will know how much components are really used and needs to maintain over so much years. For single software, a Store would be nice, then you know by sales how users like it.

I understand your problem with Hyperion updates. But currently we have a working official OS4.1. I never would install any replacement parts. We also will not use these parts as it is more support (now: with every little problem we have to check if a user has installed Enhancer Components). Our software is aimed for OS4.1 and we are happy to support additional drivers but not Enhancer components.

Bingo! This is what the customers want. Enhancements to the OS are welcome. Replacements just so ownership is different, not so much. I wish A-EON would listen. It'd be terrific if Matthew could make AmiWest this year. We'd love the opportunity to discuss this in-person.

-- eliyahu

"How do you know I’m mad?" said Alice.
"You must be," said the Cat, "or you wouldn’t have come here."
Go to top
Re: Enhancer 2.2 Video Playback Problem
Not too shy to talk
Not too shy to talk


See User information
@Spectre660

I bought ES2.0 and got free ES2.2 updates. I have a nice W3DNova but no UVD. Meanwhile, RX owners got W3DNova plus UVD for the same price. The cost of developing the UVD for the RX was partially funded by customers owning RadeonHD. This is what I'm trying to say.
The wiki / Amistore info was talking about machines that support PCIe. There is no roadmap or who gets what, and no honest information about upcoming features.
As far as I remember, AEon was selling Amigas with RadeonHD cards? It seems that they are trying not to inform in order not to harm the sale.

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top
Re: Enhancer 2.2 Video Playback Problem
Quite a regular
Quite a regular


See User information
@eliyahu


A reminder that you can install as much or restrict what you install in the Enhancer Software 2.2- it is up to the user and down to personal preference. I have had correspondence with dozens of users who have installed everything and are very happy. Just take a look at users Workbench screenshots on here and other websites. You will most often see X-Dock, Clock and Calendar installed and running.

Quote:

Absolutely. I have yet to meet a single X5000 customer that really wants command replacements, replacements for DefIcons, replacements for Exchange, replacements for ..., etc.


Just some clarification before I explain yet again what I have written here several times before.

The commands are wholly paid for by AmigaKit Ltd and are written by an author that just loves creating commands. It is a good match for us. No resources (money or man power) are diverted from the Enhancer Software team to create or update the commands. Furthermore, the commands are a contribution from AmigaKit Ltd and they do not add any cost to the Enhancer Software retail price. It would be exactly the same cost as if they were not included. So consider them a bonus if you wish to install and use them.

Quote:
DefIcons, replacements for Exchange,

Deficons is not included in the Enhancer Software 2.2 or any other public release.

Exhanger was written 5 years ago and offers several enhancements over the basic Exchange utility. No notable investments in development time have been made since so I am not sure why this is being used as an example.

Quote:
We like what AOS4 already provides. What we want aren't replacements with barely any enhancements. We want the graphics stack.


Well, if you like what OS4.1 already provides, then this is more a request for Hyperion then, not A-EON, and shouldn't be directed to me. Wasn't the Snap 2D drivers and Gallium 3D on the Hyperion development roadmap? If so consider our work an interim solution whilst you wait for the official solution from their developers.

Quote:
barely any enhancements

Archiver, MultiViewer, MultiEdit, InfoWB, X-Dock, AK-Datatypes, Ringhio Notifications - please try these Enhancer Software components and let me know if there are marginal enhancements. I would suggest they are notable improvements on their counterparts.

Compare and contrast Toolbar Gadget vs Speedbar, Shared Image vs Bitmap IC, Tabbed Gadget vs ClickTab, ListViewer vs ListBrowser, Select vs Chooser GC etc. You will find there are large improvements in functionality. Yes, they are not as mature as the older classes, but we respond quickly to bug reports, update and release frequently.

Quote:
Replacements just so ownership is different, not so much.


The benefits of reimplmentation from scratch are:

- clean room implementation free from royalties, legal problems etc
- ability to update and release when we want at the pace we want. This enables us to be agile in response to customer bug reports and feature requests.
- define our own development roadmap in response to customer needs
- use in self-booting future projects

Please take into consideration that the next tranche of development work involves the complexity being raised and a greater diversion from the "pure" OS4.1 ISO. This is the price to pay for more features- you cannot have it both ways. In fact a self-booting Enhancer Software will be a necessity to gain these new features.

amigakit.com - the Amiga store
Links: www.amigakit.com | New Products | Enhancer Software
Go to top
Re: Enhancer 2.2 Video Playback Problem
Quite a regular
Quite a regular


See User information
@imagodespira

Quote:
And we have these problems since the first Enhancer (if i remember right, the sound "enhancement" was the problem and Spencer did not run anymore).

Spencer works perfectly on my machine with all Enhancer Software components. We have not had any bug reports filed to indicate otherwise. Feel free to file report and we will look into it:

www.amiga.org/developer/bugreports

Quote:
For me, the Enhancer should only have Software and not GFX drivers. I would be happy to pay a GFX Suite like "Radiance" every year with some updates or a subscription to pay the development.


In your proposal where does the OpenGL ES 2.0 lib, Power Prefs, Power libraries, Sensor API, VA libraries, Warp3D Nova go- in the Enhancer Software or your proposed "Radiance" package? Many components in the Enhancer Software package would have to be reproduced in the proposed "Radiance" package and then you would have lots of customers complaining they are paying twice for components because they need to buy Enhancer Software too. This is why all these developments are converging towards a single future distribution. The components require each other as dependencies.

Quote:
I am happy with the drivers


This is a misunderstanding and simplification of the work that has been done in the Enhancer Software over the last six years. It contains some drivers but the array of libraries and components form a complete graphics sub system. Warp3D Nova, VA Library, Power Management, OpenGL ES Library are huge bodies of work- collectively much larger projects than the video driver work.

Go to top

  Register To Post
(1) 2 3 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project