Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
82 user(s) are online (49 user(s) are browsing Forums)

Members: 0
Guests: 82

more...

Headlines

 
  Register To Post
(1) 2 3 »

Amigaone X1000 - 3 years in.
Just can't stay away
Just can't stay away


See User information
This week, I will have owned an AmigaOne X1000 for 3 years.
I was an ardent classic user and this machine was my first AmigaOS4 experience.
Despite the surprisingly glacial pace of OS development, I have enjoyed the X1000. AmigaOS has developed steadily during this time and is much more stable and feature rich than the update5 install I first encountered.

I am constantly impressed by the third party developers out there who invest their free time to create interesting and sometime essential programs for AmigaOS

Some old bug bears continue to gnaw at me though;

The promised AmigaOS4.2 license still hasn't arrived.
Half of the CPU is unused.
The onboard ethernet driver continues to be locked away.

I am not ranting about these things (lord knows there have been enough threads that have), but it would be really nice for AEon and Hyperion to get together and produce a formal news release detailing the current position on HW/OS development...

AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
Go to top
Re: Amigaone X1000 - 3 years in.
Home away from home
Home away from home


See User information
@ddni

It's not called a bug, rather missing features.
The onboard ethernet i don't really care about if it will be added or not. Network is working nicely anyway. And i have plenty of spare slots.

X5000
Go to top
Re: Amigaone X1000 - 3 years in.
Just popping in
Just popping in


See User information
I'm very happy with my x-1000

Go to top
Re: Amigaone X1000 - 3 years in.
Just can't stay away
Just can't stay away


See User information
There are bugs (depending on your configuration). I haven't booted my X1000 since weeks.

With 4.1.6 I used to use it all the day long. Now, with my config, it's merely unsuable.

--
AmigaONE X1000 (not used anymore)
Go to top
Re: Amigaone X1000 - 3 years in.
Home away from home
Home away from home


See User information
@ddni

my goodness time flies when we're having fun

looking forward to the journey of getting full dual core support, onboard ethernet, and use full 4GB ram and HD Radeon vram

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Indivision AGA & Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Amigaone X1000 - 3 years in.
Just can't stay away
Just can't stay away


See User information
@K-L

Have you commented your problems on Hyperion's forum ?

Rock lobster bit me, so excuse me.
X1000 + AmigaOS 4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." - Seymour Cray
Go to top
Re: Amigaone X1000 - 3 years in.
Just can't stay away
Just can't stay away


See User information
@TSK

Many times. Why?

--
AmigaONE X1000 (not used anymore)
Go to top
Re: Amigaone X1000 - 3 years in.
Just can't stay away
Just can't stay away


See User information
@K-L

What support did you get?

AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
Go to top
Re: Amigaone X1000 - 3 years in.
Home away from home
Home away from home


See User information
@K-L

I can buy it cheap from you.

X5000
Go to top
Re: Amigaone X1000 - 3 years in.
Just popping in
Just popping in


See User information
@ddni
Yeah, I'm hoping Amiga OS 4.2 can be released before the end of year 2016, but very happy with 4.1 Final Edition and new Radeon HD 3D drivers. If there are people who can write hardware drivers, it would help a lot. I know Hyperion's time has to be split between hardware support and OS development.
My wish is to attend AmiWest and learn some programming so I can do more than say "Hello" to the world.

Edit: K-L, I'm also curious to what issue you have, maybe you can post a link here to the forum thread about it?

Sam460 : X1000 : X5000
Go to top
Re: Amigaone X1000 - 3 years in.
Just popping in
Just popping in


See User information
@ddni

My delivery wasn't in August, but I agree with much with your original post.
The machine is just plain fun to play with!

I'm sure that the experience is different for each of us. Personally I don't do much with games. For the first couple years I was completely consumed with the compiler, and a long list of projects.. Some for myself, some for others, some just for personal education.

Lately, my "real world" job has simply taken over. No time to code, no time for socializing, and when I get a chance to sit in front of the X1000, I mostly wish I had more than fifteen minutes at a go. But last week I opened up Score, and had an absolute blast. I start playing, and switching back and forth between hard and soft synths, and I start feeling creative again. But for me Amiga has always meant MIDI. :)

As far as the missing parts go, I may have a different view. AmigaOS 4.2 has not released, but the OS has continued to grow and mature anyway. To put it simply, I don't care what they call it, as long as it's still progressing. I had a "go" at that network driver, and it almost drove me loopy. (A short trip, some might say). After that experience, I am perfectly happy running a network card and never thinking about that code again.

And the other core? The one core that IS running on my X1000 is working quite well really. If the other one joins in one day all the better, but I'm not losing any sleep waiting for it. My X out-runs all my previous Amigas by a wide margin, even with one core tied behind it's back.

And it's even more amazing when you realize that we're not done yet. The OS is maturing, there is new hardware being made, and despite a few snags along the way, it's still the computer for the creative mind.

I'm beginning to sound like a commercial.. I'd best stop here.

Have Fun!




Go to top
Re: Amigaone X1000 - 3 years in.
Not too shy to talk
Not too shy to talk


See User information
@logicalheart

Quote:
My wish is to attend AmiWest and learn some programming so I can do more than say "Hello" to the world.

not to go off-topic, but, yeah, you gotta come to amiwest and the devcon. having guys like ssolie to answer coding questions in-person is a resource worth the trip.

-- eliyahu

"How do you know I’m mad?" said Alice.
"You must be," said the Cat, "or you wouldn’t have come here."
Go to top
Re: Amigaone X1000 - 3 years in.
Just can't stay away
Just can't stay away


See User information
@ddni
Quote:
What support did you get?[/§quote]

Except from tommysammy who tried to help me, none from anyone.

@logicalheart

[quote]Edit: K-L, I'm also curious to what issue you have, maybe you can post a link here to the forum thread about it?


http://forum.hyperion-entertainment.biz/viewtopic.php?f=14&t=2812

http://forum.hyperion-entertainment.biz/viewtopic.php?f=14&t=3054

Better : when I posted a little critic about AmiStore (TBA ?), I was answered in an aggresive way from some developpers.

--
AmigaONE X1000 (not used anymore)
Go to top
Re: Amigaone X1000 - 3 years in.
Just can't stay away
Just can't stay away


See User information
X1000 is a cool machine not much running for the time beeing. Its mostly collecting dust but i power it on sometimes just to updated whatever comes. Its pretty dry on amiupdate since the news a bigger update will come later. As the work on x5000 drivers means os4.2 is even farther.

The most downthing was waiting for 3d drivers but as we got it (had to change gfx card to a supported) im in chill mode :) For the network driver im fine with the external card even if it would be nice to ditch it for internal.

On the music front theres not much from me. No updates of music apps i use(d) and some not have midi and other planned for some future. If i remember right hd-rec crashes more under FE.

The sunny weather is what takes time away from my x1000. Autumn and winter will for sure be more miggyn. :)

I just wish my x1000 would boot faster. My win10 with ssd boot in some seconds.


Edited by Kicko on 2015/8/18 19:55:54
Edited by Kicko on 2015/8/18 22:04:50
Go to top
Re: Amigaone X1000 - 3 years in.
Just popping in
Just popping in


See User information
@K-L

It sounds like the difficulty is to reproduce the problem on other people's machine. I've not seen it happen on my AmigaOne XE, Sam440, Sam460 or X1000.

Do you know what specific symptom I can try to replicate on my machine? I can try a Radeon 9250 in my X1000.

Sam460 : X1000 : X5000
Go to top
Re: Amigaone X1000 - 3 years in.
Quite a regular
Quite a regular


See User information
My X1000 is now 4 years old and works very good.

Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
Go to top
Re: Amigaone X1000 - 3 years in.
Just can't stay away
Just can't stay away


See User information
@logicalheart

Yes, you can try with your 9250 (I'm using a PCI<->PCE-E adapter), you should encounter the sames trobles as me.

Tell me about your results when you have made the tests.

--
AmigaONE X1000 (not used anymore)
Go to top
Re: Amigaone X1000 - 3 years in.
Just popping in
Just popping in


See User information
@K-L

Just wondering..... Since the PCI slots come out of the SB600 could using the PCI>PCIe have something to do with the problem? Maybe wrong speed, a missing signal.... ???

Does the 9250 work in the PCI slots?

A1-X1000
Go to top
Re: Amigaone X1000 - 3 years in.
Not too shy to talk
Not too shy to talk


See User information
@ddni

Costel did a great job fixing the RTL8169 GigE ethernet driver for 4.1 FE.
I wouldn't worry about the onboard ethernet when you can pick up an RTL8169 for peanuts on ebay.

I personally think the onboard ethernet is broken or there is a bug in CFE, but thats my opinion. If you look around the back of the machine there are times when all the LED's are on and even after a powercycle CFE can't reinitialise it and get it out of a hung state. Then all of a sudden after the next powercylce it will initialise it correctly. No pattern to it.

Llye did a great job with the onboard sound and freed up a PCI slot for which is now taken up by my catweasel MK4 and SID Chips.


A1XE, A1200T, X5020, CDTV, CD32 , A500+ A500
OS4.1b / OS3.2b
Go to top
Re: Amigaone X1000 - 3 years in.
Just popping in
Just popping in


See User information
@Jurassicc

>>I personally think the onboard ethernet is broken or there is a bug in CFE<<

I'm using it right now under Linux Mint so it's probably like Lyle said and finding the info to get it working is next to impossible.

Not a big deal, except that it is there.

EDIT

And now I'm doing this edit using the onboard that is using remote desktop to use a BeagleBone running a chromium browser.



Edited by mechanic on 2015/8/19 20:41:50
A1-X1000
Go to top

  Register To Post
(1) 2 3 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project