Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
54 user(s) are online (40 user(s) are browsing Forums)

Members: 0
Guests: 54

more...

Headlines

 
  Register To Post
« 1 ... 7 8 9 (10) 11 12 13 14 »

Re: Getting Napalm to run on AmigaOS 4.1.2?
Quite a regular
Quite a regular


See User information
Thanks Chris, that worked a treat.

You might have given me an indication what speed to use though.
I tried one first, big mistake.
Like trying to run underwater.

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
@salass00

Could you please give me some more info on spatch?? I have downloaded it, but all I get from it is DSI, no ouput. From looking at the source it seems, that it only works with IFF files, or??

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Just popping in


See User information
Quote:

alfkil wrote:
Could you please give me some more info on spatch?? I have downloaded it, but all I get from it is DSI, no ouput. From looking at the source it seems, that it only works with IFF files, or??


I am not an expert but there is an OS4 version on OS4Depot http://www.os4depot.net/index.php?fun ... opment/utility/spatch.lha maybe that will be more useful than the 68k version.

Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
@alfkil

Spatch is only for applying SAS/C patches. You'll need another tool (probably provided with SAS/C) for creating the patches. I'm sure there are other more modern formats for binary file patches though, just need to search for one.

@Dwyloc

That's the one I linked to, but as I said it's a tool only for applying already created patch files (i.e. like unix patch command is for applying diff files).

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
Ok I used GPatch instead, it works really great. So now the patch is up on Os4depot! Looking forward to hear, if it actually works or not .

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
any video of this yet?

AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Just popping in


See User information
Quote:

alfkil wrote:
Ok I used GPatch instead, it works really great. So now the patch is up on Os4depot! Looking forward to hear, if it actually works or not .


The good news is that your patch works and I can play Napalm like the beta's you e-mailed me

The not so good news is that I when I try to save the save name fills up with "=================" signs like you are holding the key down even if you don't press any keys.

Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
@dwyloc

Ah... Forgot to test that feature. This is probably a result of me trying to fix the repeated key issue. Will fix it and upload another one!

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Amigans Defender
Amigans Defender


See User information
GPatch is really good. Shame there's not an OS4 native version, but the 68k one works perfectly.

(actually I've just found the source, I'll see if it builds and works)

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
I have fixed it, but I need to wait for the file to be updated before I can upload a replacement.

EDIT: Ok I have just uploaded it nonetheless, see the "Uploads" queue.


Edited by alfkil on 2011/11/29 19:03:06
Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Amigans Defender
Amigans Defender


See User information
@alfkil

OS4 native GPatch if you want to put it in the archive instead of the 68k one:
http://www.unsatisfactorysoftware.co.uk/download.php?file=gpatch

I tested it with your Napalm patch file and it works, although it lost the Executable bit. You might want to add a protect command to your install script after the patch takes place to ensure this doesn't happen.

When you create the new patch can you do it so it works against the original file and the old patched version? GPatch makes this easy to do apparently!

edit, damn, too slow!

edit2 I still lose the Executable bit with the 68k version of GPatch, so definitely a protect command needed there (Installer has one - (protect "crimsoncrisis" "+e") should suffice)

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Just popping in


See User information
I am not sure if it just a glitch with trying to download the second version from the upload section of OS4 depot but I am still seeing the same problem here.

you may also want to update the version of the cdplayer.library you have included in your patch as there is a newer version on OS4depot and the old version gives me a DSI error on startup with your patch, but the new one does not


Anyway thanks for your hard work its nice to play Napalm on my sam440 and have it play better than it does under winUAE on my Windows 7 laptop.

One other suggestion while I am at it would it be possible to change the default game speed to 6 and auto scroll to 7 so we dont need to set it each time we start a game/mission.

Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
I tried the napalm patch but i have some problems.. after installing the game from original cd, after installing the 1.4 patch available from amiga future (not found on aminet) and after installing the os4 patch using the installer script. I edited the prefs file in setup drawer of napalm. I edited the cd line and audio lines as described in the readme file. I tried to use the setup utility of napalm but it doesn't work and if i try to run the game, it starts but in pal screen.. there is no way to use it using picasso?.. i tested it on Amiga 1200 with radeon and amiga os 4.1 classic

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
@nubechecorre

Ah, that is a problem! I should probably insert some screen mode recognition, thought I didn't need to because the standard screenmode on SAM/A1 is 640x480 VGA. Let me see what I can do about it.

For now I'm just curious: Does it actually behave normally except for being in PAL mode, or is it just garbled graphics??

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Quite a regular
Quite a regular


See User information
I just tried Napalm on my Pegasos2 G4 system and I assure you that it plays very well and very fast indeed.

@ nubechecorre

Did you fully finalized the original Napalm installer script? Usually at the end it asks to install the rtgmaster.library also.

To Be A True Adventurer, You Ought To Play Real Text Adventures
Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just popping in
Just popping in


See User information
@alfkil
Just to confirm that the version in the recent files list on OS4depot now works nicely on my sam440ep and I can load and save in game with out any issues.

I have also managed to complete the first Human mission without problems, other than it being quite hard

Now for the small issues I have noticed I do still get the DSI on startup if I have been running other software before running Napalm, but you can skip the error and I don't get it on a clean boot.

Also I can only load games from the in mission menu not the first menu, but this can easily be worked round by just starting the first mission and loading from there so I am very happy to have another good game to play under OS4.

So thanks again for making this good game playable under OS4

Edit: Fixed typo's


Edited by Dwyloc on 2011/11/30 14:46:16
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Quite a regular
Quite a regular


See User information
I am using a the same setup as Dwyloc and had exactly the same minor issues and got round them in the same way.

This is a great game and I'm very happy to have it up and running under OS4 on my Sam.

Many thanks to Alfkil, much appreciated.


Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
I used the rtg master archive found on napalm cd, i unpacked it to ram and then run the installer script that copied everything in the right place (i guess). after doing this i installed the 1.4 patch and then run the os4 installer script.. Btw, i downloaded os4 patch from the upload queue of os4depot and there were two archives. Now i see that there is only one archive.. should i re-download the archive and re-install it?

Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Quite a regular
Quite a regular


See User information
The current Napalm patch is 0.1.2.

I run NapalmBOOT first before running Napalm though. I don't know if that's make any difference. Tried to run Napalm straight away and I got a Recoverable Alert message.

To Be A True Adventurer, You Ought To Play Real Text Adventures
Go to top
Re: Getting Napalm to run on AmigaOS 4.1.2?
Just can't stay away
Just can't stay away


See User information
@nubechecorre

As shadow says, the current version is 0.1.2, and I'm guessing you have only 0.1.1. Try the new version, but be aware that it will only work, if you have the original 1.4 version "crimsoncrisis" executable in your Napalm archive.

@Shadow

Which recoverable alert do you get?? Does it work after you run NapalmBOOT?? Actaully NapalmBOOT is supposed to run Napalm from a custom RAD: disk, so I am quite puzzled if you get it working this way.

Go to top

  Register To Post
« 1 ... 7 8 9 (10) 11 12 13 14 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project