Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
53 user(s) are online (33 user(s) are browsing Forums)

Members: 0
Guests: 53

more...

Headlines

 
  Register To Post
« 1 (2) 3 »

Re: Flare enough
Quite a regular
Quite a regular


See User information
@Severin

What happens if you remove USR: assign? I just ran the program without one and it still worked with PROGDIR: / relative paths just like the original README suggests.

edit: I didn't alter any code for these versions.


Edited by Thematic on 2018/5/31 2:08:06
Go to top
Re: Flare enough
Just popping in
Just popping in


See User information
@Thematic,

Works now with new version.

Thanks

Sam460ex
Os4.1 Final Edition
2GB Fast Memory
envy 24 HT sound card
HD R9 TRIX 280X 3GO GDDR5
Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@Thematic

usr: doesn't seem to make any difference.

I found that env:mplayer is coming from an envvar HOME which was somthing I had to sort out an mplayer problem which was later fixed.

deleted it and going to retry after rebooting.

EDIT:

Flare is now working properly, a userdata drawer was created with saves and mods drawers inside etc.

Thanks all!


Edited by Severin on 2018/6/1 0:56:18
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: Flare enough
Quite a regular
Quite a regular


See User information

Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
oops... posted by error.

Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: Flare enough
Site Builder
Site Builder


See User information
Tried the game today on my X5000 and works great.

It is a pity that hardware surface has problems, because the game becomes very smooth even on HD screens. Tried it and everything seems to work, except the texts in dialogs, buttons, loot etc.

It would be great if someone could have a look on that.

Go to top
Re: Flare enough
Just popping in
Just popping in


See User information
On my Sam460, the game is very slow in fullscreen mode. It was exactly the same with the previous version. If I switch to window mode, then, I must edit the config file and change screenmode to 1024X768. I can play quiete well but it's not smooth.
With older versions, it was smoother. Is there a way to improve that ?
Thanks

Sam460ex
Os4.1 Final Edition
2GB Fast Memory
envy 24 HT sound card
HD R9 TRIX 280X 3GO GDDR5
Go to top
Re: Flare enough
Quite a regular
Quite a regular


See User information
@pseudaxos

The minimum resolution should be 640 by 480, so that change gives NOT a 156 % speed increase (other things need doing than minding the bus), but is probably still substantial.

Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@Thematic

If people can run OpenGL ES 2.0 then here is one trick that can be tested.

setenv SDL_RENDER_DRIVER opengles2

and restart flare. I haven't tested this myself other than for the setenv general behaviour: it works for "software", "compositing" and "opengl" ("opengl" can't be used due to missing render targets, though).

Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@Capehill

Doesn't work here on my X1000, just gives a black screen.

Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@Capehill

Doesn't work here either on my X1000.

setenv SDL_RENDER_DRIVER compositing gives the best result (the less slow).

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re: Flare enough
Not too shy to talk
Not too shy to talk


See User information
@walkero

Don't works for me.
Freezes after one or two seconds.

:(

Virginio

AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
@Capehill
But should that "setenv SDL_RENDER_DRIVER opengles2" works at all with plain opengl apps ? Imho it can't and shouldn't , as not only plain GL use more functions than GLES, but also creation of context, handling of it and co are different.

Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@kas1e

No, it should not do anything for application that don't use renderer subsystem. https://wiki.libsdl.org/SDL_HINT_RENDER_DRIVER

Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
@Capehill
I still didn't get. I mean, does not matter what, but opengl app can't works over opengles as it (only wrappers can help there, like gl4es one). Even if it not pure context creation, but just some renderer , still ogles2 renderer will works only over ogles2 context , which will mean nothing will works in opengl app which targeted to opengl calls, and not to opengles ones. Right ?:)

I mean, how it supposed to work, if one compile pure opengl app with opengl calls, over ogles2 renderer, if, its just different in context meaning and gl calls ?

Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@kas1e

Application doesn't need to know anything about drivers or versions if it uses the renderer subsystem. Flare, for example, is not an OpenGL application. Quake 3 is.

Based on a very brief look at Flare's code, it either requests a SW or HW renderer. Meaning that by default, "compositing" renderer will be preferred in case of HW acceleration, unless programmer or user sets a hint.

Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
@Capehill
Ah, ok got it, sorry. Was sure that flare gl based (dunno why).

Go to top
Re: Flare enough
Site Builder
Site Builder


See User information
I tried on my system the following values of SDL_RENDER_DRIVER

opengles2 - it gives a black screen but music keeps playing at the back, and I was able to quit it by pressing the esc

opengl - gives black backgrounds but the menu gui works

composite - everything works just fine

None of the above works help HW Surface.

Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@walkero

"composite" is not supposed to do anything, it's not recognized so SDL will choose something else, probably depending on the HW/SW setting.

Flare could print the renderer name, then it would very easy to verify.

Go to top
Re: Flare enough
Quite a regular
Quite a regular


See User information
@Capehill

Here Flare says:
Quote:

INFO: Using Render Device: SDLHardwareRenderDevice (hardware, SDL 2, os4)
INFO: RenderDevice: 1 display(s), using display 0 (1280x1024 @ 60hz)
INFO: RenderDevice: Internal render size is 640x480
INFO: RenderDevice: Window size is 640x480
INFO: RenderDevice: Fullscreen=0, Hardware surfaces=0, Vsync=0, Texture Filter=0
INFO: RenderDevice: Display DPI is 0.000000


Only the first line is ambiguous to me.

Go to top

  Register To Post
« 1 (2) 3 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project