Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
36 user(s) are online (29 user(s) are browsing Forums)

Members: 0
Guests: 36

more...

Headlines

 
  Register To Post  

« 1 ... 7 8 9 (10) 11 12 13 ... 17 »
Re: Enhancer Software v2.0 Released
Not too shy to talk
Not too shy to talk


See User information
@kas1e

Just use latest RadeonRX 2.4 driver with public Uboot version

Emotion crashes the whole system after 1-2 seconds of playback. Tested with RX550 and RX560.

Sinan - AmigaOS4 Beta-Tester
- AmigaOne X5000
- AmigaOne A1222
- Sam460ex
Go to top
Re: Enhancer Software v2.0 Released
Just popping in
Just popping in


See User information
My cache coherency crash is not related to the ScreenMode prefs program but to the amigaos reset. If I boot into workbench and perform a warm reset (only amigaos) then I get the same cache coherency error output and system halt.


Edited by geennaam on 2021/4/1 17:10:01
Go to top
Re: Enhancer Software v2.0 Released
Not too shy to talk
Not too shy to talk


See User information
@all

I can reproduce same RadeonRX V2.4 crash on A1222.
When I downgrade to V1.17, it doesn't crash.

Boot log also reports "System doesn't have full memory coherence. Compensating"

So can this problem be related to P5020 / P1022 CPUs ?
I guess it is not X5000 specific.

I added crashlog to MantisBT #731

Sinan - AmigaOS4 Beta-Tester
- AmigaOne X5000
- AmigaOne A1222
- Sam460ex
Go to top
Re: Enhancer Software v2.0 Released
Not too shy to talk
Not too shy to talk


See User information
Double post.please delete

Sinan - AmigaOS4 Beta-Tester
- AmigaOne X5000
- AmigaOne A1222
- Sam460ex
Go to top
Re: Enhancer Software v2.0 Released
Home away from home
Home away from home


See User information
@AmigaKit

Anyone know if AmigaKit is still in business?

I don't get any answers to emails since 30th of March...and it's (for me) kinda urgent.

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: Enhancer Software v2.0 Released
Quite a regular
Quite a regular


See User information
@raziel

Our support sent you an
Email reply at 08:41 on Tuesday 30 March

amigakit.com - the Amiga store
Links: www.amigakit.com | New Products | Enhancer Software
Go to top
Re: Enhancer Software v2.0 Released
Quite a regular
Quite a regular


See User information
@IamSONIC

Re: immediate OS freezes when showing folder information (select Folder + RAmiga + I) and clicking on "Size" inside InfoWB Window


I have duplicated and filed a bug report .


http://www.amiga.org/developer/bugreports/view.php?id=734

Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: Enhancer Software v2.0 Released
Home away from home
Home away from home


See User information
@amigakit

Yes and i PayPal'd you the money at 10:52 and since then...nothing.

No answers to my emails, no activation, no feedback, no nothing

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: Enhancer Software v2.0 Released
Quite a regular
Quite a regular


See User information
Sorry your reply was missed. Your request has been processed now. Apologies for the inconvenience

amigakit.com - the Amiga store
Links: www.amigakit.com | New Products | Enhancer Software
Go to top
Re: Enhancer Software v2.0 Released
Quite a regular
Quite a regular


See User information
@Spectre660 @IamSonic

Thanks. We will investigate and get it fixed

Go to top
Re: Enhancer Software v2.0 Released
Home away from home
Home away from home


See User information
@amigakit

Thank you.

Still funny that my other emails seem to were also missed.

If you happen to find them, could I get a new username?

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: Enhancer Software v2.0 Released
Not too shy to talk
Not too shy to talk


See User information
@geennaam

Hans said @MantisBT

Okay, ignore the "System doesn't have full memory coherence" message. It's irrelevantv(and wrong).

Please tell Geennaam to ignore everything I've said so far, and to submit bug reports.

Sinan - AmigaOS4 Beta-Tester
- AmigaOne X5000
- AmigaOne A1222
- Sam460ex
Go to top
Re: Enhancer Software v2.0 Released
Just popping in
Just popping in


See User information
@SinanSam460

Ok. I've already ordered a new PSU. (Modular 750W 80 plus gold).

Let me try this one first to rule out any PSU problems.


Go to top
Re: Enhancer Software v2.0 Released
Not too shy to talk
Not too shy to talk


See User information
@geennaam

Hans sent me these videos..I will test tomorrow when I return from office. These are the videos that Hans is testing in his development.

https://www.dropbox.com/s/3hj557j2joi6 ... RROUND.x264-VODO.mp4?dl=0

https://www.dropbox.com/s/5bbywh4q830c ... us%20-%20Trailer.mp4?dl=0

He requested

- Disable Frameskip (Emotion)
- Use release (non-debug) kernel

Sinan - AmigaOS4 Beta-Tester
- AmigaOne X5000
- AmigaOne A1222
- Sam460ex
Go to top
Re: Enhancer Software v2.0 Released
Just popping in
Just popping in


See User information
@geennaam

Ok, there is definitly something weird going on with my system. I use the RadeonRX V1.17 driver (latest one without GART/DMA). I can see that the CPU load peaks to 100% every second or so. But this can be normal behaviour without DMA.

I've just installed my HD audio soundcard again. Sound is playing at the correct speed but I noticed that the stereo sound is off. Music is audible without any stuttering or hissing but still you can hear that it is not entirely how it is supposed to sound. Like a "Hall" effect.

When I pan the volume in amigaamp I can confirm that it is not real stereo because I cannot completely mute the other channel anymore. Although possible, panning is not handled inside the sound hardware. It could be done by AmigaAmp or the AHI mixing routine. The only explaition that I have is that someting is going wrong with the DMA transfer, the DDR3 memory controller or os memory handling in general.

Sound is playing at the correct speed means in this case that the soundcard is fetching the expected amount of data with DMA from memory at the correct rate. So somehow the order of samples is mixed up. I doubt that it would get to this stage if wrong setup information was send to the soundcard.

Playing sound is nothing more than:
1. Wait for a DMA complete interrupt
2. Calling the AHI mixing routine to request a new block of samples. (AHI CPU routine; no dma involved)
3. Run a "for" loop to fetch, byteswap and write those samples to the DMA buffer location with the CPU. (again no DMA involved)
4. Repeat

So something goes wrong such that those samples arrive in the wrong sequence at the soundcard. But the error is subtile because music is audible. Maybe 1 failed write every x samples. This would swap left and right every x samples because the left and right samples are interleaved in memory.

A memory handling issue would also explain the cache coherency output on a warm reset. Afterall, the wrong CPU information is fetched from memory.

Anyways, like all the other issues. This issue disappears too when I go back to my R9 270x.

Go to top
Re: Enhancer Software v2.0 Released
Just popping in
Just popping in


See User information
@SinanSam460

Ok, I managed to login to MantisBT and can see the bug report with answers from Hans.

I can swap cards again and test those video files. But the link suggests that those files are MP4 files. At the same time I read this comment on MantisBT:

Did *all* of them fail? MP4's shouldn't even use HW video decoding, because the libva MPEG4 code for UVD is buggy.

Ok, MP4 is not a compression standard but a container format. It can, among others, contain regular MPEG4 part 2 and MPEG4 part 10 (h.264) compressed data. But still, if libva also handles the container and not only the video data then I am a bit confused about that comment.


Edited by geennaam on 2021/4/2 13:11:22
Edited by geennaam on 2021/4/2 13:14:52
Go to top
Re: Enhancer Software v2.0 Released
Just popping in
Just popping in


See User information
@geennaam

Another quote from MantisBT thread about the RadeonRX UVD crash issue:

NOTE: Soft-resets usually don't work with Polaris cards. Only a hard-reset does.

Didn't know that until now. So that should explain the issue with monitor prefs/soft reset versus the cache coherency message and system halt.

The UVD crash seems related to GART/DMA.

So only the screenmode change from 3440x1440@60Hz to something else issue remains unexplained. That issue will result in a permanent loss of signal and system freeze. No matter if this is done by a program or if I just use the test button in the ScreenMode pref. Cycling through screens doesn't work either to bring back workbench.

Go to top
Re: Enhancer Software v2.0 Released
Not too shy to talk
Not too shy to talk


See User information
@geennaam

Can you try running videos from Ram Disk: ?

I am able to play some videos from Ram Disk: using RadeonRX V2.4, but it crashes when playing from SSD: (NGFS / SFS2 tested)

Sinan - AmigaOS4 Beta-Tester
- AmigaOne X5000
- AmigaOne A1222
- Sam460ex
Go to top
Re: Enhancer Software v2.0 Released
Just popping in
Just popping in


See User information
First impressions after two hours of using an MSI Radeon RX 560 Aero ITX 4G OC in X5000 on AmigaOS 4.1 FE U2 + Enhancer Software 2.0

- MiniGL (via MiniGL4GL4ES) depends on game - as a interim solution ok
- Warp 3D - as known doesn't work (no driver)
- Warp 3D Nova - Great performance (better than R7 250E and even R9 280X) !!!
- Power Prefs work
- Video Acceleration works

Resized Image

Go to top
Re: Enhancer Software v2.0 Released
Home away from home
Home away from home


See User information
Someone remind me again, please (since this is the first time i'm using RadeonHD v3).

Wasn't it supposed to break the memory limitation barrier on supported cards? (I have a RadeonHD series 7000)
Is it just not showing up in Workbench (because i still have only 256MB) or do i have to set somekind of variable fist?

I also remember some kind of docky that could show if all the memory is used or not, but i can't remember where.

Thank you very much

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top

  Register To Post
« 1 ... 7 8 9 (10) 11 12 13 ... 17 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project