Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
33 user(s) are online (24 user(s) are browsing Forums)

Members: 2
Guests: 31

salass00, MigthyMax, more...

Headlines

 
  Register To Post  

(1) 2 »
Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
Hi,

I need some help with aPod.
Installed, I have;

aPod http://os4depot.net/index.php?functio ... ity/hardware/apod.tar.bz2
Latest SDK.
Perl reaction http://os4depot.net/index.php?functio ... isc/perl_reaction.tar.bz2

I run this from shell
Resized Image


I get this AmigaDOS request
Resized Image


and finally this shell output
Resized Image


Any help appreciated.

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
I should add that assigning ipod: to the attached ipod does not seem to work.

AmigaOne X1000.
Radeon RX550

http://www.tinylife.org.uk/
Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
Does anyone else use aPod with update 6?

AmigaOne X1000.
Radeon RX550

http://www.tinylife.org.uk/
Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
I tried too weeks ago but no luck.

I have a Classic iPod 32gb who should be detected as mass storage.
When I plug it, it's not mounted by the system.

Is yours well mounted on Workbench ?

I don't remember if it was recognized before upd6...

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
@zzd10h

Yes, it is a 4th gen 8gb ipod nano. It appears on workbench as a hard drive and I can browse through its drawers.
I can also drag files into it however these are not playable from the ipod. I was hoping to use aPod to fix this.

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
You are luckier than me ;)
No life from my iPod when plugged on my x1000 front USB .

Sorry for the off-topic,
Good luck for your problem !

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
Thanks, but I feel that I might not get this working... :(

AmigaOne X1000.
Radeon RX550

http://www.tinylife.org.uk/
Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
Small progress?

I rename the ipod to iPod and installed perlpatch from os4depot.

Now I get this error.
Resized Image



AmigaOne X1000.
Radeon RX550

http://www.tinylife.org.uk/
Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Home away from home
Home away from home


See User information
I think the problem is your ipod is too new.

It works well with my quite old G3 ipod but at some later point the iTunesDB format has been extended and the aprsder can't understand the changes.

I did add the --restore option to apod 1.5 this allows you to rebuild the iTunesDB with an old style database. Someone tested this for me and allow the ipod was functional some information was lost (album lists?).

It backs up the old database so you can restore by hand if you are unhappy about the way it works. You will only be able to use it with aPod after this as iTunes will probably updte the database.


Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Home away from home
Home away from home


See User information
@zzd10h

Chack the filesystem, is it windows (FAT32) or mac ?

It needs to be FAT32 to work with amigaos.


Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
@broadblues

thanks. Not sure how to use the --restore option from shell.

Is there any merit in using your newlib perl package? http://os4depot.net/index.php?functio ... /language/perl_newlib.lha

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
@broadblues

Mine is well in FAT32 (mountable under Windows)

It's this one

http://support.apple.com/kb/ht1353?vi ... EN&locale=en_EN#ipodfifth

On this page which is yours, broadblues ?

Thanks

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Home away from home
Home away from home


See User information
@ddni

Quote:


thanks. Not sure how to use the --restore option from shell.



Simply do

perl585 apod --restore


where perl585 is your perl 5.8.5 executable (maybe just perl if you haven't installed the 5.16.3 port)

It assumes your ipod is mounted as iPod:

(you can set the path to the ipod in the .apodrc file by the way)

Quote:

Is there any merit in using your newlib perl package? http://os4depot.net/index.php?functio ... /language/perl_newlib.lha



Yes but not for apod at the moment, I have not ported perl_Reaction to the new perl and don't intend to. It's "depricated" in favour of ProAction, which is faster and easier to program for. At some point I'll probably make a ProAction version of aPod. But that by itself wont fix your problems. The MAC::iPod::GNUPod class this is based on has not been updated for some time. I lack the resources to maintain an amiga fork of it.


Edited by broadblues on 2013/12/30 17:08:26
Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Home away from home
Home away from home


See User information
@zzd10h

This one:

http://support.apple.com/kb/ht1353#dockconnector

I said it was old ...

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Home away from home
Home away from home


See User information
@zzd10h

Does you iPod at least appear in usb inspector? If so what class does it show as?


Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
Ah yes, it was because one of my two front USB ports on my x1000 doesn't seems to work (neither with my iPod nor with a joypad)

Now, I see it on my Workbench, I have created the .gnupod directory on it but fails a little bit like ddni, see grab :

http://zzd10h.amiga-ng.org/Divers/iPod_OS4.jpg

Thank you for your help (yes, yours is very old but at least it works on OS4 ,) )

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Home away from home
Home away from home


See User information
@zzd10h

Based on that screen shopt you don;t appear to have the necessary perl modules installed.

Did you install using the installer script?

Did it show any errors?


Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
@broadblues
Yes, to be sure, I just reinstalled it from OS4Depot.

It detected an existing APOD: assign, I overwrite the previous installation and rebooted.

Same error.

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Home away from home
Home away from home


See User information
do you see

list sdk:local/clib2/lib/perl5/site_perl/5.8.5/Mac/
Directory "sdk:local/clib2/lib/perl5/site_perl/5.8.5/Mac" on Monday 30-Dec-13
iPod Dir ----rwed 24-Oct-11 00:10:01

??

Did you install the perl_patch over the perl5.8.5 install? It's needed for building and installing modules in the old perl.

I assume you haven't installed the newer perl? (your getting a clib2 based INC path so assume you haven't).


list sdk:local/clib2/lib/perl5/site_perl/ all

Go to top
Re: Help needed with aPod on AmigaOS4.1 u6
Just can't stay away
Just can't stay away


See User information
Right, the 2 lists failed, not found.

I installed the perl_patch from os4depot and I have tried to compile the perl_Reaction.

But the perl_Reaction compilation failed with

/RAM Disk/perl_Reaction/Reaction> make
gmake[1]: Entering directory `/RAM Disk/perl_Reaction/Reaction/Classes'
gmake[2]: Entering directory `/RAM Disk/perl_Reaction/Reaction/Classes/Arexx'
rm -f ../../blib/arch/auto/Reaction/Classes/ARexx/ARexx.pmod
LD_RUN_PATH="" gcc -nostartfiles -mcrt=clib2-ts -L /SDK/Local/clib2/lib SDK:clib2/lib.threadsafe/crtbegin.o ARexx_init.o ARexx.o SDK:clib2/lib.threadsafe/crtend.o -o ../../blib/arch/auto/Reaction/Classes/ARexx/ARexx.pmod -lauto -lraauto -lunix -lnet
ld: cannot find -lgcc



Go to top

  Register To Post
(1) 2 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project