Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
72 user(s) are online (59 user(s) are browsing Forums)

Members: 0
Guests: 72

more...
Support us!
Recent OS4 Files
OS4Depot.net



(1) 2 3 4 5 »


MickJT-MPlayer
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 908
1.0.1 released on OS4Depot:

* Disabled experimental AHI code that was freezing some machines
* Suppressed an error preventing some .avis playing with vo_comp_yuv/yuv2
* Fixed some path issues preventing OSD menus from working
* P96_PIP: Fixed issue causing some videos to play distorted
* P96_PIP: Remember window position when returning from fullscreen
* Added "Stay on Top" functionality for all video outputs
* Change keyboard shortcut for "Load File". Conflicted with "Loop".
* Cosmetic tweaks to the About window.
* Disabled some debug output that was printing to shell


--- Original post below ---

Hello,

It's just turned Christmas day here in my timezone and I've uploaded a new MPlayer build to OS4Depot. Naturally, there's already been a bug report Seeing as I'm going to be unavailable most of the day, if any of you with altivec capable machines are experiencing lockups or crashes, please try this binary and report back here, and I will check on it as soon as I have time. Keep in mind my programming knowledge is extremely limited for C and I probably can't fulfill feature requests.

(Links removed)


Edited by MickJT on 2017/12/25 0:13:57
Edited by MickJT on 2017/12/26 2:47:46
Edited by MickJT on 2017/12/26 11:20:21
Edited by MickJT on 2017/12/30 16:25:04
Edited by MickJT on 2018/1/3 9:51:42
   Report Go to top

Re: MickJT-MPlayer
Not too shy to talk
Joined:
2006/11/27 17:18
From West Jordan, Utah, USA
Posts: 377
@MickJT

Thank you for all your hard work on behaft of the Amiga community, and a very merry Christmas to you!


_________________
Valiant@Camelot
AmigaOne XE, 800Mhz, 512Mb, 9250 Radeon, OS4.1u7
Sam440ep, 666Mhz, 512Mb, 9250 Radeon, OS4.1u6
A1-X1000, 1.8Ghz, 2GB, 9250 Radeon, OS4.1x

[url=http://forum.hyperion-entertainment.biz]Officia
   Report Go to top

Re: MickJT-MPlayer
Just popping in
Joined:
2013/10/23 14:18
From Kuusamo, Finland
Posts: 82
Big thank you and merry merry Christmas to you! 🤗

_________________
\o/....X1000....\o/
   Report Go to top

Re: MickJT-MPlayer
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1152
Nice work!

I'm getting the following output and a black window with your updated version above:

9> mplayer "dh12:tv/Doctor Who/04 - Tom Baker/1977-15-092-1-4 Horror Of Fang Rock.avi"
Cannot find HOME directory.
MickJT-MPlayer-1.0 1.3.0 (C) 2000-2016 MPlayer Team

Playing dh12:tv/Doctor Who/04 - Tom Baker/1977-15-092-1-4 Horror Of Fang Rock.avi.
libavformat version 57.25.100 (internal)
AVI file format detected.
[aviheader] Video stream found, -vid 0
[aviheader] Audio stream found, -aid 1
[aviheader] Audio stream found, -aid 2
VIDEO: [DX50] 640x480 24bpp 25.000 fps 1687.0 kbps (205.9 kbyte/s)
VO: [comp_yuv2] Welcome man !.
gfx_nodri = 0
gfx_novsync = 0
benchmark = 0
vsync is enabled = 1
Opening video filter: [screenshot]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 57.24.102 (internal)
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
Load subtitles in dh12:tv/Doctor Who/04 - Tom Baker/
==========================================================================
Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
AUDIO: 44100 Hz, 2 ch, s16be, 192.0 kbit/13.61% (ratio: 24000->176400)
Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
==========================================================================
AO: [ahi_dev] 44100Hz 2ch s16be (2 bytes per sample)
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
[swscaler @ 0x50c9b088]bicubic scaler, from yuv420p to rgb24 using AltiVec
[swscaler @ 0x50c9b088]ALTIVEC: Color Space RGB24
[swscaler @ 0x50c9b088]using unscaled yuv420p -> rgb24 special converter
VO: [comp_yuv2] 640x480 => 640x480 Planar YV12
screen w 1920 h 1080 aspect 1.78:1
VO: Disabling blanker
from 3d5c9000 to 3d641000
from 3d641000 to 3d67d000
from 3d641200 to 3d67d200
VO: [comp_yuv2] allocated DR buffer 0
from 3ae07000 to 3ae7f000
from 3ae7f000 to 3aebb000
from 3ae7f200 to 3aebb200
VO: [comp_yuv2] allocated DR buffer 1
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
[swscaler @ 0x50c9b088]ALTIVEC: Color Space RGB24
VO: [comp_yuv2] 640x480 => 640x480 Planar YV12
Select error: No such file or directory
AmigaOS4.1 Bug select() don't reset or set errno value
[VD_FFMPEG] DRI failure.

then nothing but the next two lines repeating:

[mpeg4 @ 0x50b7aa10]get_buffer() failed (stride changed)
Error while decoding frame!

_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3069
Tested on my Sam440 .. PIP seems working but i have spare output when i close or resize the video:

Have My_Screen

Will test it further, great to see an update


   Report Go to top

Re: MickJT-MPlayer
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 908
@samo79

By spare output, you just mean the "Have My_Screen" printed to shell? I think would be present in LiveForIt-MPlayer too, right? It's in cgx_common.c. I could remove that line. Is it causing any issues?

@all

If you have an altivec capable machine, please try some .mp4 files using the version on OS4Depot. I would like to know if the altivec build on OS4Depot crashes sporadically and if the build in post #1 fixes it.

   Report Go to top

Re: MickJT-MPlayer
Quite a regular
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 960
@MickJT

I've been testing many MP4 videos with the OS4Depot release and I got no crash.

@Sam79

Yes, "Have my Screen" was already there with LiveForIt-Mplayer, it appears when you resize the window while playing a video.

_________________
--
AmigaONE X1000 1,8Ghz, 2GB, Sapphire Radeon HD 7700, with Amiga OS 4.1 FE
http://www.amiga-ng.org
   Report Go to top

Re: MickJT-MPlayer
Just popping in
Joined:
2017/10/28 10:03
From Netherlands
Posts: 21
Thanks!!

The Non Altivec version works great on my X5000

Merry Xmas

_________________
On a Strict need to know Basis..
   Report Go to top

Re: MickJT-MPlayer
Just popping in
Joined:
2009/12/31 17:27
From Westerwald
Posts: 76
@MickJT

Tested a few mp4 and have so far no problems with both versions.
X1000 with OS4.1FE.

   Report Go to top

Re: MickJT-MPlayer
Just popping in
Joined:
2014/11/21 2:30
From Israel
Posts: 124
@MickJT

With upload 2 I can't play the big buck bunny avi file. It goes into an endless something about a bug.

   Report Go to top

Re: MickJT-MPlayer
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 908
@Srtest

I'll need something a little more specific than that :) Does it work with the one on OS4Depot? Usually that would be the one with the bug. If you have any shell output that'd be appreciated. I'll check back later, in the meantime, zzZZzzzz.

P.S Try with -vo comp or -vo sdl. Still, shell output if you can grab it. Might be useful to delete/rename the config file or remove quiet=1 from it.

   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3069
@MickJT

Quote:
It's in cgx_common.c. I could remove that line. Is it causing any issues?


No, just it's annoying and useless, need to be removed

   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3069
Still an output (without any text) also when you press "P" or "spacebar" for pause .. still to remove this aswell


Edited by samo79 on 2017/12/25 15:25:07
   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3069
Another little issue ... still various but try to collect them step by step

The screenshot option from menu always generate an image called "mplayer.png" instead to pick the real name of the video (as it happen if you just press "s" to pick a grab of the video)

Should be easy to fix

   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3069
The functionality "Stay on top" (Video options) does not work ...
I tested the old MPlayer from afxgroup and it works on that version .. probably the functionality get broken by some modification of LiveForIt ...

   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3069
New one, again a minor thing but still ...

Tested MickJT version with MPlayer GUI and noted a strange typo in title window (GUI)

Here it is:

"MickJT-MPlayer-1.0 1.3.0 (C) 2000-2016 MPlayer Team000-2010 MPlayerTeamTeam"

But should be:

"MickJT-MPlayer-1.0 1.3.0 (C) 2000-2016 MPlayer Team""

By the way, what was the sense to named this version as a personal "MickJT" version instead of just using the original scheme of LiveForIt including his old readme and so on ?

I understood you started from his latest version right ?
So just add your name as contributor in about window and to the readme .. less confusion no ?

And to say more, it was even strange to have a version called "LiveForIt" instead of just call it MPlayer as to end that version was partially based to the initial work of afxgroup ... not to mention we have also a MUI version ported by kas1e !!

So please just call it "MPlayer" without all that blablabla so we can replace the old LiveForIt and MPlayer versions marking them as obsolete --> 1 version = 0 confusion

   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2708
@samo79

Just so know who worked on it.

for example I'm not responsible for older versions, that is distributed under name "afxgroup". I made lots of changes and take provide in improvements I made.

Also I'm not person to contact if something is not working in MUI MPlayer, or any other MPlayer build.

I think "MickJT" has always called his build MickJT, that is perfectly fine with me.

Version is just a number, it does not matter, as long know this older newer then older one.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3069
@LiveForIt

Yep, however with 1 single common repository and all info in documentation/about windows everyone will know who contributed and in what way they did ...

Ideally we could have only 2 versions, the MUI one from kas1e can't be merged for obvious reasons but your version, the ancient one from afxgroup (and this latest modifications from MickJT) could be merged in a unique release .. once completed of course as still there some issues here and there ...

Quote:
Version is just a number, it does not matter, as long know this older newer then older one.


Well i don't agree, it's not just a name ... because if now, for example Mick will solve an issue and he will add anything, then that things should be availible also in your version .. and considering that he started from your version it's an absolute nonsense to have 2 separate versions ... same story for the old version of Andrea .. pratically all his previous work was merged in your version (or improved/fixed) so what is the sense to have his version around ?

   Report Go to top

Re: MickJT-MPlayer
Just popping in
Joined:
2014/11/21 2:30
From Israel
Posts: 124
@MickJT

Select error: Illegal seek
AmigaOS4.1 Bug select() don't reset or set errno value
Cache empty, consider increasing -cache and/or -cache-min. [performance issue]
Seek failed
Select error: Illegal seek
AmigaOS4.1 Bug select() don't reset or set errno value
Cache empty, consider increasing -cache and/or -cache-min. [performance issue]
Seek failed

My cache settings work with other mp4 or mpg files. These settings are also nothing out of the ordinary.

   Report Go to top

Re: MickJT-MPlayer
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2708
@Srtest

AmigaOS4.1 Bug select() don't reset or set errno value

Yes that error was put in there so people know, how SDK should work can have look at it...

Cache empty, consider increasing -cache and/or -cache-min. [performance issue]

Read the mplayer docs or google it, your settings are wrong.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top


(1) 2 3 4 5 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project