Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
80 user(s) are online (64 user(s) are browsing Forums)

Members: 2
Guests: 78

Rigo, ddni, more...
Support us!
Recent OS4 Files
OS4Depot.net





YAM and HTML
Quite a regular
Joined:
2007/7/23 20:35
Posts: 610
I have used OWB for a number of years now to read HTML emails in YAM.

I know I could use Simplemail but am happy enough with YAM.
I would like to use Odyssey instead of OWB but cannot get this to work.

Can anyone help?

I would also be interested to know what everybody else is using to read HTML emails with AOS4.

Cheers




   Report Go to top

Re: YAM and HTML
Not too shy to talk
Joined:
2007/2/6 13:57
From Donostia (SPAIN)
Posts: 335
You can try to use URLOpen and then let URL (prefs) to do the job.

URLOpen file://%s


Or if you want to use Oddysey directly (not sure if you need quotes around file:///%s):
APPDIR:Odyssey file:///%s

   Report Go to top

Re: YAM and HTML
Home away from home
Joined:
2006/11/26 21:45
From A haunted Castle somewhere in the Bavarian Mountains
Posts: 2804
@jabirulo

I've got
"*"file:///%s*""
in the commandline, then again i'm using a self made script to open up Odyssey which cares about an already running Odyssey and opens a new tab instead

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: YAM and HTML
Not too shy to talk
Joined:
2006/11/27 22:28
From Germany
Posts: 281
@Raziel

this is correct.
you should use
APPDIR:OdysseyLauncher2 "*"file:///%s*""

in url prefs on the file tab.
instead of the arexx script you mentioned you can use OdysseyLauncher2 from os4depot. working quite nice.

regards...
michael

_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt
   Report Go to top

Re: YAM and HTML
Quite a regular
Joined:
2007/7/23 20:35
Posts: 610
It's not the URL config that is the problem, I have Odyssey Launcher 2 working fine with that.
I can click on links withing an email and Odyssey opens up a new tab or launches if not already running.

It's the mime config within YAM that is the problem.

mime type text/html viewer Utilities/internet/OWB/OWB %s works fine.

Replacing the above with Odyssey opens Odyssey but just a blank page.
Replacing OWB with Odyssey Launcher 2 also brings up a blank page.

Cheers



   Report Go to top

Re: YAM and HTML
Not too shy to talk
Joined:
2007/2/6 13:57
From Donostia (SPAIN)
Posts: 335
@TiredOfLife

Just change on your YAM's MIME html settings the viewer to:

URLOpen file://%s

I have/use on YAM:
MV03.ContentType = text/html
MV03.Command = URLOpen file://%s
MV03.Extension = html htm shtml php
MV03.Description = documento HTML
MV03.CharsetName = ISO-8859-1

   Report Go to top

Re: YAM and HTML
Quite a regular
Joined:
2007/7/23 20:35
Posts: 610
@jabirulo

Brilliant, would never have thought to do it that way.
You have no idea how long this has been getting on my nerves.
Thanks very much.

Cheers


   Report Go to top

Re: YAM and HTML
Quite a regular
Joined:
2009/2/9 19:32
From Brussels Belgium
Posts: 988
I am not sure, but i believe the solutions given are for clicking on a link in a YAM message. Right?


If so there is another problem i solved sort of::
an html message is seen as a text message in YAM. You can save it s "part 1.2 | html file" though. it is saved under a name such as YAMm00000064-p2.2 You have however to add a .htm or .html extension or Odyssey
won't load it.

I automated the process using Gui4Cli's xNOTIGY event.

xNOTIFY t:YAM ON
IF $RepNotify = -1
cd t:yam
CLI 'list >env:.YAM__htm lformat="%N"'
IFexists FILE $.YAM__htm
copy $.YAM__htm t:$.YAM__htm\#.htm
.YAM__htm = $.YAM__htm\#.htm
CLI "URLOPen file:///t:$.YAM__htm"

ENDIF
ENDIF
RepNotify = $(-$RepNotify)

I do save the html part in a t:yam directory, the file gets an extension and URLOpen is called to load the file in Odyssey
Using Odysselauncher2 will work too of course

If a previous file is allready in that directory i use the save requester to first delete that file, before savint the new one.

Not perfect but still

The code resides in background Gui4CLI program, that i start up early. It could be launched on startup or a YAM script could launch it when loaded.


   Report Go to top

Re: YAM and HTML
Not too shy to talk
Joined:
2006/11/27 22:28
From Germany
Posts: 281
@JosDuchIt

Quote:
an html message is seen as a text message in YAM. You can save it s "part 1.2 | html file" though. it is saved under a name such as YAMm00000064-p2.2 You have however to add a .htm or .html extension or Odyssey
won't load it.


if you just want to view the html message you press the "show" button next to the save button. then select "raw format".
here it then opens odyssey and displays the html mail.

regards...
michael

_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt
   Report Go to top

Re: YAM and HTML
Quite a regular
Joined:
2009/2/9 19:32
From Brussels Belgium
Posts: 988
@MichaelMerkel

I did not succeed.
I guess you start with putting in the MIME prefs "default settings" either urlopen or OdyssayLauncher 2
exactly what?

In the Odyssseylancher2 Readme file it is stated


Quote:

(b) But if you do not have an entry for Odyssey yet, then click on "Add new
client", and enter the following information exactly:

Odyssey APPDIR:OdysseyLauncher2 "*"file:///%s*""

5. Once you have done this for all the 4 tabs, click Save.
(Or you can first click on Test and give it a URL like http://www.google.co.uk )


I guess "file:///%" is only for a local file and justt copying that for http, https and www is wrong?


   Report Go to top

Re: YAM and HTML
Not too shy to talk
Joined:
2006/11/27 22:28
From Germany
Posts: 281
@JosDuchIt


Quote:

I did not succeed.
I guess you start with putting in the MIME prefs "default settings" either urlopen or OdyssayLauncher 2
exactly what?

of course urlopen. as this then opens the browser of your choice. it even asks you which browser to use of you define more than one.

but do not use the default setting! because the default is the default-program used for any type of file which is not yet defined. a good choice here is multiview which should already be entered.

create a new entry (or change the existing one):
mime-type: text/html
file extension: htm html shtml
program : UrlOpen "file://%s"

Quote:

In the Odyssseylancher2 Readme file it is stated

Quote:
(b) But if you do not have an entry for Odyssey yet, then click on "Add new client", and enter the following information exactly:

Odyssey APPDIR:OdysseyLauncher2 "*"file:///%s*""

5. Once you have done this for all the 4 tabs, click Save.
(Or you can first click on Test and give it a URL like http://www.google.co.uk )

I guess "file:///%" is only for a local file and just copying that for http, https and www is wrong?


yes. you need to use http/https for the others.
there already should exist some default entries in urlprefs (Ibroiwse/aweb)? maybe inactive? just enter the odysses one like the others.
i mean - it's quite straight forward.

regards...
michael

_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt
   Report Go to top

Re: YAM and HTML
Quite a regular
Joined:
2009/2/9 19:32
From Brussels Belgium
Posts: 988
@MichaelMerkel


I am using YAM 2.10 dev and wonder if this is the origin of my problem


the URL given to Odyssey to open is something like
file:///Stock:Internet/YAM_2.10/Folders/Incoming/SbfIPQABvDE=.001,R

Odyssey will propose to download it not to open it.

If i try to display the html part of the message i get
file:///RAM%20Disk:T/4-YAMm00000048-p1.1
and odyssey won't open it either. ( That's why i wrote the gui4Cli script
adding a html extension to the html part in t:)

The above result is with appdir:urlopen file:///%s as default viewer.

If i use as before Next %s as default viewer, while having the htm html and htmls MIME viewers set to appdir:urlopen file:///%s
and their extensions respectively to htm html and htmls, Next wiill open the message.

If i delete Next as default viewer (empty field-) nothing happens when trying to display raw msg or html attachmetn

If i add a MIME type now with no extension defined, but still with appdir:urlopen file:///%s as a viewer, nothing happens when trying to display raw msg or html attacchment (this MIME type does not take over the function of the default viewer)




   Report Go to top

Re: YAM and HTML
Not too shy to talk
Joined:
2006/11/27 22:28
From Germany
Posts: 281
@JosDuchIt

Quote:

I am using YAM 2.10 dev and wonder if this is the origin of my problem

i'm also using the nightly version. perfect.
Quote:

the URL given to Odyssey to open is something like
file:///Stock:Internet/YAM_2.10/Folders/Incoming/SbfIPQABvDE=.001,R

?? where is this url coming from?
if you click the view button in a html mail and chose the html part this is different. the file is exported to ram:t first and then displayed.
what are you trying to view here?!
Quote:

Odyssey will propose to download it not to open it.

If i try to display the html part of the message i get
file:///RAM%20Disk:T/4-YAMm00000048-p1.1
and odyssey won't open it either. ( That's why i wrote the gui4Cli script
adding a html extension to the html part in t:)

that's what i am doing. and the file yam exports and gives to odyysey (or urlopen) is like this:
file:///RAM%20Disk:T/2-YAMm00000064-p2.htm
file:///RAM%20Disk:T/1-YAMm0000007b-p1.htm
...
so quite similar to yours.
have you checked the files with notepad? are they proper html files or smth different?! yours are missing the .htm extension.
Quote:

The above result is with appdir:urlopen file:///%s as default viewer.

don't forget the quotation marks!
UrlOpen "file://%s"

Quote:

If i use as before Next %s as default viewer, while having the htm html and htmls MIME viewers set to appdir:urlopen file:///%s
and their extensions respectively to htm html and htmls, Next wiill open the message.

If i delete Next as default viewer (empty field-) nothing happens when trying to display raw msg or html attachmetn

If i add a MIME type now with no extension defined, but still with appdir:urlopen file:///%s as a viewer, nothing happens when trying to display raw msg or html attacchment (this MIME type does not take over the function of the default viewer)


maybe your url.prefs settings are still wrong? can you post a screenshot?

Resized Image

Resized Image

Resized Image

regards...
michael


Edited by MichaelMerkel on 2017/3/12 10:59:23
Edited by MichaelMerkel on 2017/3/12 11:05:24
_________________
Michael Merkel
(Michael.Merkel@gmx.net Home)
Member of Amiga-Freunde Pfalz, OS4 Welt
   Report Go to top

Re: YAM and HTML
Quite a regular
Joined:
2009/2/9 19:32
From Brussels Belgium
Posts: 988
@MichaelMerkel

The URL's i mention are those appearing in Odyssey's URL textin gadget and comparing with yours there is a big difference
yours
file:///RAM%20Disk:T/2-YAMm00000064-p2.htm
mine would be
file:///RAM%20Disk:T/2-YAMm00000064-p2
without the extension appearing
That last file would exist, but i never have a file with an .htm extension generated by YAM

I doubt it is the role of urlopen to create that extension.
Can you check if it pre-exists on your YAM install before calling urlopen?

If not maybe you found some other way for renaming the file?

BTW i had to reset the YAM MIME types htm, html, htms viewers to
appdir:urlopen %s
because clicking on a link in the mail didn't work anymore


My URL prefs are here http://users.online.be/AD/URLprefs.jpg

   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project