Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
75 user(s) are online (59 user(s) are browsing Forums)

Members: 1
Guests: 74

Templario, more...
Support us!
Recent OS4 Files
OS4Depot.net





(solved) Hieronymus not working on Sam440 ?
Home away from home
Joined:
2007/5/19 13:23
From England
Posts: 3487
I tried Hieronymus on my Sam440, but all it outputs is this obscure error message:
Quote:
ˆFailed to acquire samples, the interrupt server does not work or interrupt context is null


Does it work on anyone else's Sam440? Any idea what the problem could be?

EDIT: It works when I use a different boot partition, so looks like something's borked on my first boot partition.

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: (solved) Hieronymus not working on Sam440 ?
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1116
@ChrisH

On X1000 I get:

"Sorry, Hieronymus can't run on this hardware at the moment"

_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: (solved) Hieronymus not working on Sam440 ?
Just popping in
Joined:
2011/11/29 0:54
From Norway
Posts: 245
so it isn't really solved is it?

and what is that program?

_________________
Sam460ex 2GB 120Gb SSD&1Tb HD7750 Envy24HT A-Eon Drv 2.10+Warp3D New Uboot
Amiga 1230 33mhz 128MB Indivision ACA 1200 MK2 USB PCMCIA WIFI 60GB&DVD-ROM OS 3.9
AmigaOne X1000 250SSD+1TB 7970
   Report Go to top

Re: (solved) Hieronymus not working on Sam440 ?
Just can't stay away
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 1028
@noXLar

Quote:
so it isn't really solved is it?
Yes it is. Chris' problem was getting it to run on his Sam440, where it was supposed to work. It is already known (and documented) that it doesn't work on the X1000.

Quote:
and what is that program?
http://os4depot.net/index.php?functio ... ment/debug/hieronymus.lha

Best regards,

Niels



   Report Go to top

Re: (solved) Hieronymus not working on Sam440 ?
Just popping in
Joined:
2011/11/29 0:54
From Norway
Posts: 245
@nbache

yes, i understand. but what made the "borked" bootdisk do too make it work.. and the issue was with sam440

_________________
Sam460ex 2GB 120Gb SSD&1Tb HD7750 Envy24HT A-Eon Drv 2.10+Warp3D New Uboot
Amiga 1230 33mhz 128MB Indivision ACA 1200 MK2 USB PCMCIA WIFI 60GB&DVD-ROM OS 3.9
AmigaOne X1000 250SSD+1TB 7970
   Report Go to top

Re: (solved) Hieronymus not working on Sam440 ?
Not too shy to talk
Joined:
2007/3/30 17:39
Posts: 252
@Severin

The message on the X1000 does not say much but if it has done, it would have been as obscure than on Sam440

The initial implementation of Hieronymus relies on a system feature that was not fully implemented on Sam440 and on X1000. That was fixed for the Sam440, let's say ... in Update 5. That is still not the case on X1000.

For the X1000, I developed a second implementation that works well on the MicroAOne but there is a problem with the X1000. But these days, I have thought that there is maybe a remaining hope. We will see after some tests.

   Report Go to top

Re: Hieronymus not working on Sam440 ?
Not too shy to talk
Joined:
2007/7/14 20:30
From Lothric
Posts: 267
Hello corto,

I would like to use Hieronymus on Sam440 but it crashes. Is it a known issue? I can send full crashlog if needed.

(0x588CFEE0) native kernel module Kickstart/elf.library.kmod+0x00008254
(0x588CFF20) native kernel module Kickstart/elf.library.kmod+0x00008248
(0x588CFF60) native kernel module Kickstart/elf.library.kmod+0x000004d0
(0x588CFFB0) native kernel module Kickstart/elf.library.kmod+0x000005e0
(0x588D0020) Hieronymus:Bosch_StopAcquisition()+0x3fc (section 1 @ 0xBA8)
(0x588D0080) Hieronymus:main()+0x490 (section 1 @ 0x13E4)

   Report Go to top

Re: Hieronymus not working on Sam440
Not too shy to talk
Joined:
2007/7/14 20:30
From Lothric
Posts: 267
BUMP. I would like to know is it a hieronymus issue or elf.library issue. In elf.lib case I could open a bug report.

Here is a better crashlog: http://forum.hyperion-entertainment.b ... 8&hilit=hieronymus#p41758

   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project